how to clear codes? - TheDieselGarage.com
Thread Details Posted by ehopp88ss, this thread has received 9 replies and been viewed 12647 times.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 04-26-2010, 12:24 AM Thread Starter
2004.5 Dodge Ram 2500
 
ehopp88ss's Avatar
 
Join Date: May 2009
Location: Northern Illinois
Posts: 1,239
Points: 63,190
Thanks: 650
Thanked 44 Times in 39 Posts
Garage
how to clear codes?

hey guys.
so as some of you know i am in the process of making a cold air intake outta the stock one on my truck.

i also changed the fuel filter and was unsure if the o ring sealed so me being me i started it to see if it was indeed leaking (with the MAF sensor disconnected.

it set the check engine light. and codes po173 and po0073. i already looked the codes up on the sticky and i believe they are just from running it without the MAF.

is there a way to clear the codes on the dash (like a Cadillac)?

i already know how to access the codes (key on three times) but im not sure if theres a way to clear them.

thanks
erik

Erik

My Vehicles

2004.5 Dodge Ram 2500 4X4 QCLB, NV5600, 177K miles, 10000k HIDS, FASS 150, EDGE juice w/ attitude "HOT UNLOCK", VALAIR 650HP DD thanks to DAN'S DIESEL PERFORMANCE!

1988 Monte Carlo SS, 305 SBC, true dual 2.25" t-304 Stainless exhaust, T-Tops, custom red pryzmatique paint, 2 12" Alpine Type-R Subwoofers, 500 Watt Alpine amp, Alpine speakers inside, complete 2 year ground up restoration, 22K miles on rebuild
ehopp88ss is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-26-2010, 12:34 AM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,824
Points: 41,546
Thanks: 302
Thanked 690 Times in 598 Posts
Garage
Reconnet the MAP and check for codes. It will reset after so many key cycles once the problem is no longer detected. Other wise if you don't want to live with it you need a scan tool or someone with a tuner like smarty to clear the codes.

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2015 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
The Following User Says Thank You to neeltburn For this addition to TDG:
ehopp88ss (04-26-2010)
post #3 of 10 (permalink) Old 04-26-2010, 12:36 AM Thread Starter
2004.5 Dodge Ram 2500
Threadstarter
 
ehopp88ss's Avatar
 
Join Date: May 2009
Location: Northern Illinois
Posts: 1,239
Points: 63,190
Thanks: 650
Thanked 44 Times in 39 Posts
Garage
thank you sir. so it will clear itself eventually?

heres another question. so one of the codes it set was for a lean condition. could this be caused by the MAP sensor or could this be the symptoms of a failing lift pump?

thanks
erik

Erik

My Vehicles

2004.5 Dodge Ram 2500 4X4 QCLB, NV5600, 177K miles, 10000k HIDS, FASS 150, EDGE juice w/ attitude "HOT UNLOCK", VALAIR 650HP DD thanks to DAN'S DIESEL PERFORMANCE!

1988 Monte Carlo SS, 305 SBC, true dual 2.25" t-304 Stainless exhaust, T-Tops, custom red pryzmatique paint, 2 12" Alpine Type-R Subwoofers, 500 Watt Alpine amp, Alpine speakers inside, complete 2 year ground up restoration, 22K miles on rebuild
ehopp88ss is offline  
post #4 of 10 (permalink) Old 04-26-2010, 01:18 AM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,824
Points: 41,546
Thanks: 302
Thanked 690 Times in 598 Posts
Garage
[QUOTE=ehopp88ss;984881]thank you sir. so it will clear itself eventually?

Yes If there is not problem it will eventually go off, I my self am not paitient enough to wait for this. You could also have Autozone or a car parts place clear them.


heres another question. so one of the codes it set was for a lean condition. could this be caused by the MAP sensor or could this be the symptoms of a failing lift pump?



The lean condition is not because it is not getting fuel it is because the O2 sensor in the air intake was not plugged in. This caused the ECM to know know how much fuel to put with the air coming in.

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2015 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
The Following User Says Thank You to neeltburn For this addition to TDG:
ehopp88ss (04-26-2010)
post #5 of 10 (permalink) Old 04-26-2010, 03:31 AM Thread Starter
2004.5 Dodge Ram 2500
Threadstarter
 
ehopp88ss's Avatar
 
Join Date: May 2009
Location: Northern Illinois
Posts: 1,239
Points: 63,190
Thanks: 650
Thanked 44 Times in 39 Posts
Garage
another question?

could me being a dumba** and starting it without the map sensor in cause it to run weird for a while?

i just took it out for a spin and she is running a little weird.

thanks
erik

Erik

My Vehicles

2004.5 Dodge Ram 2500 4X4 QCLB, NV5600, 177K miles, 10000k HIDS, FASS 150, EDGE juice w/ attitude "HOT UNLOCK", VALAIR 650HP DD thanks to DAN'S DIESEL PERFORMANCE!

1988 Monte Carlo SS, 305 SBC, true dual 2.25" t-304 Stainless exhaust, T-Tops, custom red pryzmatique paint, 2 12" Alpine Type-R Subwoofers, 500 Watt Alpine amp, Alpine speakers inside, complete 2 year ground up restoration, 22K miles on rebuild
ehopp88ss is offline  
post #6 of 10 (permalink) Old 04-26-2010, 02:42 PM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,824
Points: 41,546
Thanks: 302
Thanked 690 Times in 598 Posts
Garage
Did you prime the fuel system after you where done? You can do this by cycleing key 3-4 times and not starting the truck. If you didn't I would drain some fuel out of the water seperator and and try to reprime the fuel system.

I doubt this is the case at all but the o2 sensor and intake air temp sensor in the air intake can get damaged ( MAP sensor is in the head) make sure you have them clicked in good and they are not loose in the air intake. They should not be damaged but simply removing them once, just make sure the pins in the connection are all straight and locked on the sensors good. I wouldn't sweat it man, did you light clear yet? It's amazing how that little amber light makes you think something is wrong even if it isn't!

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2015 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
The Following User Says Thank You to neeltburn For this addition to TDG:
ehopp88ss (04-26-2010)
post #7 of 10 (permalink) Old 04-26-2010, 04:08 PM Thread Starter
2004.5 Dodge Ram 2500
Threadstarter
 
ehopp88ss's Avatar
 
Join Date: May 2009
Location: Northern Illinois
Posts: 1,239
Points: 63,190
Thanks: 650
Thanked 44 Times in 39 Posts
Garage
thanks for this amazingly detailed info.
my dad has a scanner, snap on i think not too sure but we cleared the codes last night and i drove it for about 2 hours last night and an hour to work and so far nothing has gone wrong. (knock on wood) haha

Erik

My Vehicles

2004.5 Dodge Ram 2500 4X4 QCLB, NV5600, 177K miles, 10000k HIDS, FASS 150, EDGE juice w/ attitude "HOT UNLOCK", VALAIR 650HP DD thanks to DAN'S DIESEL PERFORMANCE!

1988 Monte Carlo SS, 305 SBC, true dual 2.25" t-304 Stainless exhaust, T-Tops, custom red pryzmatique paint, 2 12" Alpine Type-R Subwoofers, 500 Watt Alpine amp, Alpine speakers inside, complete 2 year ground up restoration, 22K miles on rebuild
ehopp88ss is offline  
post #8 of 10 (permalink) Old 04-26-2010, 04:17 PM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,824
Points: 41,546
Thanks: 302
Thanked 690 Times in 598 Posts
Garage
Sounds like your golden then man!

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2015 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
post #9 of 10 (permalink) Old 04-26-2010, 04:28 PM Thread Starter
2004.5 Dodge Ram 2500
Threadstarter
 
ehopp88ss's Avatar
 
Join Date: May 2009
Location: Northern Illinois
Posts: 1,239
Points: 63,190
Thanks: 650
Thanked 44 Times in 39 Posts
Garage
i hope so. and the good thing about the light being off is that if the piece that i glued back on breaks and starts sucking air the light will go on and i'll know its broken.

Erik

My Vehicles

2004.5 Dodge Ram 2500 4X4 QCLB, NV5600, 177K miles, 10000k HIDS, FASS 150, EDGE juice w/ attitude "HOT UNLOCK", VALAIR 650HP DD thanks to DAN'S DIESEL PERFORMANCE!

1988 Monte Carlo SS, 305 SBC, true dual 2.25" t-304 Stainless exhaust, T-Tops, custom red pryzmatique paint, 2 12" Alpine Type-R Subwoofers, 500 Watt Alpine amp, Alpine speakers inside, complete 2 year ground up restoration, 22K miles on rebuild
ehopp88ss is offline  
post #10 of 10 (permalink) Old 04-28-2010, 01:18 AM
CRAZY CANUCK
 
BriteWhiteRam's Avatar
 
Join Date: Oct 2006
Location: Alberta, Canada
Posts: 4,317
Points: 46,787
Thanks: 350
Thanked 506 Times in 416 Posts
Garage
if your a little unsure about your glue Erik you could throw a couple short screws into it to hold it in place, thats what i did, i got impatient and put screws into it and threw it back on the truck before the glue was entirely set

Aaron the Crazy Canuck
2006 Chevrolet Silverado LT 2500: LBZ - Allison, Greystone Metallic, 4x4,PPE airbox mod, missing muffler/cat, EFILive tuned by Nick at duramaxtuner, MA tie-rod sleeves and Grade C headgaskets
Totalled!! May 2nd 2008-2005 Dodge Ram 3500 laramie: Cummins auto, plain white, rebuilt tranny
1986 Mercury Capri - 5.0L, AOD, shorty headers, acell ignition, Holly street dominator intake, Holly 625 vacuum secondaries carb, Dual glass packs "my little yellow terror"

DURAMAX INDEX; You want a Duramax? you want to click on this >>The Duramax Index

Canadian Club Member #1
Singles Club member #186
Ridin Dirty Club #5


TDG MAFIA


Check out the NEW and IMPROVED TDG Truck Poll!
TDG TOTQ
BriteWhiteRam is offline  
The Following User Says Thank You to BriteWhiteRam For this addition to TDG:
ehopp88ss (04-28-2010)
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
99-04 clear headlights x2 6L strokin Whats Been Sold 2 02-27-2009 09:39 PM
Clear cab lights for OBS Dualie General Ford Truck and Excursion 2 07-03-2007 12:10 AM
6.0 won't start... clear codes, then starts ekbearly 2003-2007 6.0L Power Stroke 1 08-26-2006 02:41 AM
Why you use a 1.4 not a 1.3 to shoot clear TooMuchBoost The Detailing, Paint & Bodyshop 7 04-09-2006 04:28 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome