Oil Pressure Sensor Location - TheDieselGarage.com
Thread Details Posted by 04lariatfx4crewcab, this thread has received 8 replies and been viewed 15990 times.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 07-07-2009, 05:03 PM Thread Starter
Junior Member
 
04lariatfx4crewcab's Avatar
 
Join Date: May 2009
Location: Guadalupe River State Park, Texas
Posts: 373
Points: 30,242
Thanks: 75
Thanked 19 Times in 17 Posts
Oil Pressure Sensor Location

Ok, I give up. I can not find where the oil pressure sensor is located on my truck. I am still trying to figure this diesel thing out. Does anyone have a picture of where this sensor is located?

Thank you

Jakob

2004 5.9L/47rh Lariat FX4 Crew Cab Short bed. 213K miles 18" dbacks with nitto A/T grapplers, Zoodad mod, and 2000 turn signal mod. Limited Excursion bumpers front and back. Chrome grill, EGR delete, FICM delete, glow plug delete, HPOP delete, 2 cylinders delete, and 20 valves deleted

97 12v/47rh built by Garmon's



04lariatfx4crewcab is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 07-07-2009, 05:46 PM
Senior Member
 
hpprose's Avatar
 
Join Date: Feb 2007
Posts: 387
Points: 27,143
Thanks: 6
Thanked 82 Times in 54 Posts
Images: 2
The sensor for the low pressure is right next to the oil filter housing.

The sensor for the high pressure oil is on the passengers side valve cover right next to the glow plug controller (on 04's and newer)

My life is like my license plate.

Everything is right side up, but feels upside down.
hpprose is offline  
post #3 of 9 (permalink) Old 07-07-2009, 07:35 PM Thread Starter
Junior Member
Threadstarter
 
04lariatfx4crewcab's Avatar
 
Join Date: May 2009
Location: Guadalupe River State Park, Texas
Posts: 373
Points: 30,242
Thanks: 75
Thanked 19 Times in 17 Posts
Thanks hpprose.

There are two?
wich one is for the oil pressure guage on the dash?
Also are they the same part number because I can only find one part number for an oil sensor it is F81Z-9278-AA.

Thanks for the reply.

Jakob

2004 5.9L/47rh Lariat FX4 Crew Cab Short bed. 213K miles 18" dbacks with nitto A/T grapplers, Zoodad mod, and 2000 turn signal mod. Limited Excursion bumpers front and back. Chrome grill, EGR delete, FICM delete, glow plug delete, HPOP delete, 2 cylinders delete, and 20 valves deleted

97 12v/47rh built by Garmon's



04lariatfx4crewcab is offline  
post #4 of 9 (permalink) Old 07-07-2009, 09:23 PM
Senior Member
 
hpprose's Avatar
 
Join Date: Feb 2007
Posts: 387
Points: 27,143
Thanks: 6
Thanked 82 Times in 54 Posts
Images: 2
Quote:
Originally Posted by hpprose View Post
The sensor for the low pressure is right next to the oil filter housing.

The sensor for the high pressure oil is on the passengers side valve cover right next to the glow plug controller (on 04's and newer)
The oil pressure gauge on your dash uses the sensor by the oil filter housing.



The sensor on the passengers side valve cover is the ICP which reads injection control pressure.

My life is like my license plate.

Everything is right side up, but feels upside down.
hpprose is offline  
The Following User Says Thank You to hpprose For this addition to TDG:
04lariatfx4crewcab (07-08-2009)
post #5 of 9 (permalink) Old 07-08-2009, 01:15 AM
Member
 
Join Date: Dec 2008
Posts: 169
Points: 3,246
Thanks: 1
Thanked 68 Times in 48 Posts
the oil pressure switch is the one with the single wire. the other with two wires is the oil temperature sensor. they are both located by the oil filter housing and screw into the oil cooler. the connector for the switch is black and the connector for the temp is grey. if you want the switch the part number you listed is correct. why are you wanting to change the switch.

Ford Diesel Engine Master Certified
Ford Senior Master Certified
Dodge Cummins Level 4 Certified
Cummins Certified
cb44473 is offline  
The Following User Says Thank You to cb44473 For this addition to TDG:
04lariatfx4crewcab (07-08-2009)
post #6 of 9 (permalink) Old 07-08-2009, 02:35 AM Thread Starter
Junior Member
Threadstarter
 
04lariatfx4crewcab's Avatar
 
Join Date: May 2009
Location: Guadalupe River State Park, Texas
Posts: 373
Points: 30,242
Thanks: 75
Thanked 19 Times in 17 Posts
cb44473,
I just want to check the sensor see if it is working correctly or if the wire might be shorting or loose I keep getting a check guage light and the oil pressure guage dies some times it dies for a few seconds sometimes only a split second. the truck does not die no matter how long the guage is dead. it only ever happens when I slow for a stop. if I press the vertical pedal it will come back to life. I just want to make sure it is not the sensors or something easy before I tear into it looking for an HPOP problem.

Thanks for the reply.

Jakob

2004 5.9L/47rh Lariat FX4 Crew Cab Short bed. 213K miles 18" dbacks with nitto A/T grapplers, Zoodad mod, and 2000 turn signal mod. Limited Excursion bumpers front and back. Chrome grill, EGR delete, FICM delete, glow plug delete, HPOP delete, 2 cylinders delete, and 20 valves deleted

97 12v/47rh built by Garmon's



04lariatfx4crewcab is offline  
post #7 of 9 (permalink) Old 07-08-2009, 05:02 AM
Senior Member
 
hpprose's Avatar
 
Join Date: Feb 2007
Posts: 387
Points: 27,143
Thanks: 6
Thanked 82 Times in 54 Posts
Images: 2
When mine started doing that, my sensor had a small hole and it was filling the wiring up with oil.

My life is like my license plate.

Everything is right side up, but feels upside down.
hpprose is offline  
post #8 of 9 (permalink) Old 07-08-2009, 06:04 AM
Senior Member
 
4play's Avatar
 
Join Date: Dec 2008
Location: norman, ok
Posts: 1,700
Points: 40,800
Thanks: 55
Thanked 387 Times in 342 Posts
Quote:
Originally Posted by 04lariatfx4crewcab View Post
cb44473,
I just want to check the sensor see if it is working correctly or if the wire might be shorting or loose I keep getting a check guage light and the oil pressure guage dies some times it dies for a few seconds sometimes only a split second. the truck does not die no matter how long the guage is dead. it only ever happens when I slow for a stop. if I press the vertical pedal it will come back to life. I just want to make sure it is not the sensors or something easy before I tear into it looking for an HPOP problem.

Thanks for the reply.
your on the right track going after the sender, remember though its just a single wire switch with a brown/orange stripe wire. these senders are notorius for what you explained. this sender only indicates "low" pressure and not actual oil pressure. its basically and idiot light but with a guage. with normal oil pressure the sender grounds the wire to indicate good oil pressure and turn the light off. If you have a wiring concern you need to look for an open circuit. but i bet you will be fixed with a new sender/switch.
4play is offline  
The Following User Says Thank You to 4play For this addition to TDG:
04lariatfx4crewcab (07-08-2009)
post #9 of 9 (permalink) Old 07-08-2009, 01:07 PM Thread Starter
Junior Member
Threadstarter
 
04lariatfx4crewcab's Avatar
 
Join Date: May 2009
Location: Guadalupe River State Park, Texas
Posts: 373
Points: 30,242
Thanks: 75
Thanked 19 Times in 17 Posts
Thanks 4play. I will be checking the sender/switch. I hope that solves my problem.

Jakob

2004 5.9L/47rh Lariat FX4 Crew Cab Short bed. 213K miles 18" dbacks with nitto A/T grapplers, Zoodad mod, and 2000 turn signal mod. Limited Excursion bumpers front and back. Chrome grill, EGR delete, FICM delete, glow plug delete, HPOP delete, 2 cylinders delete, and 20 valves deleted

97 12v/47rh built by Garmon's



04lariatfx4crewcab is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cat 3116e: Fuel Temp Sensor & Boost Pressure Sensor probablecause Medium and Heavy Duty 0 02-03-2009 01:54 AM
EGT sensor location......... bwanajim 7.3L and 6.9 IDI (Pre 1994) 4 01-21-2008 06:03 AM
EGT sensor location........ bwanajim 7.3L and 6.9 IDI (Pre 1994) 0 01-20-2008 08:35 PM
Baro Sensor location? Pat M 2003-2007 6.0L Power Stroke 5 12-22-2007 02:44 PM
Boost sensor location killerbee Duramax 2004.5-2005(LLY) 8 10-19-2006 04:35 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome