battery/alternator/charging system - TheDieselGarage.com
Thread Details Posted by strokin6L, this thread has received 37 replies and been viewed 6303 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 38 (permalink) Old 11-18-2009, 06:23 PM Thread Starter
Senior Member
 
strokin6L's Avatar
 
Join Date: Dec 2008
Location: springville NY
Posts: 3,306
Points: 65,011
Thanks: 356
Thanked 198 Times in 189 Posts
battery/alternator/charging system

Well ran into a little issue. Tried putting the 64/71/70 turbo on today and well, when i was installing it i somehow rubbed one of the wires that goes to the connector on the alternator and it sparked and smoked a little. Now i have a battery light on my dash. I didn't check any fuses or tested the alternator yet. but just wondering what anyone thought.

2004 F-350 XLT SC 4x4: SCT, AFE stage II, autometer gauges(pyro, boost, tranny, fuel), edge insight, CFM large mouth intake elbow, spearco, snow performance water injection, 5" stacks, ARP's, fluidampr, hypermax fire rings, LIPD regulated return, FASS, fuelab, casserly 190's, 64/71/70 turbo(polished compressor housing)modded FICM(ID), Hellmann's sump, electirc fans
strokin6L is offline  
Sponsored Links
Advertisement
 
post #2 of 38 (permalink) Old 11-18-2009, 06:53 PM
Member Since Sept 2007
 
DevilDocTater's Avatar
 
Join Date: Jan 2009
Location: Festus, MO
Posts: 252
Points: 28,277
Thanks: 53
Thanked 22 Times in 17 Posts
Hmmmm hard to say, does the truck start and run Ok?? Might try disconnecting both batteries and turn the lights on for a bit then hook it back up and see if it throws the light again???

Just a pure guess......i know just enough to get me into trouble.....



-Wade

"The best Battlefield Medicine is firepower superiority and overwhelming violence!"

SLAPS Member #193
Singles Club #212

3rd Degree Master Mason

2004 F-350 6.0 6" suspension lift sitting on 35's 6spd MANUAL 4" Turbo Back Exhaust, AFE Air Box, (ARP Studs, New HG's and Complete EGR Delete by Josh at River City Diesel) Coolant Filter from Dfuser, Stainless Steel Up-Pipe from RCD, 4 gauge pillar with Autometer Phantom Series 1 gauges. Boost, Pyro, Fuel Pressure and Oil Temp. Shimmed FPR. Improved Banjo Bolts. Fabtechs all around with a Procomp steering stabilizer from RCD. SCT X3 tuned by RCD
DevilDocTater is offline  
The Following User Says Thank You to DevilDocTater For this addition to TDG:
strokin6L (11-18-2009)
post #3 of 38 (permalink) Old 11-18-2009, 07:01 PM
SLAPS President
 
teamroper60's Avatar
 
Join Date: Dec 2008
Location: Troy, MO
Posts: 3,027
Points: 32,289
Thanks: 163
Thanked 404 Times in 332 Posts
Images: 9
Garage
I'd be looking for a blown fuse first.....

2003 Toreador Red/Arizona Beige CC, DRW, Lariat, FX4, 6.0 PSD, Torqshift, born early Feb. 03; Silverline turbo-back dual exhaust; 155's from Full Force Diesel (Casserly); Di-Pricol gauges; ARP studs; Dfuser regulated return; AFE PG7;Tunes by Tony Wildman & IDP; B&W hitch; DIESELSITE Coolant filter; a whole bunch of "bling"; Connex 4300hp; Pioneer DEH6100BT radio; JL Audio 275w amp w/ 12" sub; Alpine door and rear seat speakers. pics
#43
Dually club member #76

SLAPS President and Webmaster

If you love wealth more than liberty, the tranquility of servitude better than the animating contest of freedom, depart from us in peace. We ask not your counsel nor your arms. Crouch down and lick the hand that feeds you. May your chains rest lightly upon you and may posterity forget that you were our countrymen. - quote by Samuel Adams

Political correctness is a doctrine fostered by a delusional, illogical minority, and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end
teamroper60 is offline  
The Following User Says Thank You to teamroper60 For this addition to TDG:
strokin6L (11-18-2009)
post #4 of 38 (permalink) Old 11-18-2009, 08:15 PM
Member
 
69cj's Avatar
 
Join Date: Dec 2008
Location: Riverside, S. Ca.
Posts: 789
Points: 17,269
Thanks: 0
Thanked 74 Times in 70 Posts
I 2nd the blown fuse and make sure that the wire or connector wasn't damaged and is still grounded. Then if you still have the light and the vehicle runs try resetting the codes with a scanner if there are any.
69cj is offline  
The Following User Says Thank You to 69cj For this addition to TDG:
strokin6L (11-18-2009)
post #5 of 38 (permalink) Old 11-18-2009, 08:57 PM Thread Starter
Senior Member
Threadstarter
 
strokin6L's Avatar
 
Join Date: Dec 2008
Location: springville NY
Posts: 3,306
Points: 65,011
Thanks: 356
Thanked 198 Times in 189 Posts
connector is fine there was a bare spot on one of the wires to it. I just put some electrical tape on it. I'll look for a blown fuse.

2004 F-350 XLT SC 4x4: SCT, AFE stage II, autometer gauges(pyro, boost, tranny, fuel), edge insight, CFM large mouth intake elbow, spearco, snow performance water injection, 5" stacks, ARP's, fluidampr, hypermax fire rings, LIPD regulated return, FASS, fuelab, casserly 190's, 64/71/70 turbo(polished compressor housing)modded FICM(ID), Hellmann's sump, electirc fans
strokin6L is offline  
post #6 of 38 (permalink) Old 11-19-2009, 12:01 AM
Senior Member
 
UpstateDieselGuy's Avatar
 
Join Date: Dec 2008
Posts: 2,821
Points: 44,853
Thanks: 55
Thanked 120 Times in 116 Posts
If the fuses all check out get the multimeter out and start checking for power with all associated connections. Make sure that you are getting power out of the alternator, etc. Chris

I'm a little more country than that...

2011 F-350 Extended Cab Short Box Lariat

SOLD
2004 F350 Regular Cab Long Box XLT; FX4, 6.0L and TorqShift; Manual Transfer Case and Hubs; Dark Shadow Grey Metallic; Keyless Entry; Factory Idle Control; 8 1/2' Fisher MMII; Factory 18" Wheels painted black with 305/70R18 Mickey Thompson ATZ's in the summer and XL Steel Wheels painted Black with 285/75R16 ProComp A/T's in the Winter; Rough Country 2.5" Leveling Kit; Isspro Pyrometer, Boost, and Transmission Temperature Gauges in an Overhead Pod; SCT by Innovative Diesel; Innovative Moderate FICM Tune; ARP Head Studs; '03 Turbo screaming through a 4" Turbo Back 409 MBRP System with both Deletes and 6" Tip.
UpstateDieselGuy is offline  
post #7 of 38 (permalink) Old 11-19-2009, 01:16 PM Thread Starter
Senior Member
Threadstarter
 
strokin6L's Avatar
 
Join Date: Dec 2008
Location: springville NY
Posts: 3,306
Points: 65,011
Thanks: 356
Thanked 198 Times in 189 Posts
fuses are all good. as for using a mulitimeter, haven't a clue what one of them are or even what to check for. i noticed in the manual that there is a relay for trailer tow/battery relay. i'm just not sure i'll hafta have my buddy check power at the alternator. truck runs and starts just fine other than a batter light on the dash.

2004 F-350 XLT SC 4x4: SCT, AFE stage II, autometer gauges(pyro, boost, tranny, fuel), edge insight, CFM large mouth intake elbow, spearco, snow performance water injection, 5" stacks, ARP's, fluidampr, hypermax fire rings, LIPD regulated return, FASS, fuelab, casserly 190's, 64/71/70 turbo(polished compressor housing)modded FICM(ID), Hellmann's sump, electirc fans
strokin6L is offline  
post #8 of 38 (permalink) Old 11-19-2009, 09:03 PM
Junior Member
 
105vegas's Avatar
 
Join Date: Apr 2009
Posts: 81
Points: 19,643
Thanks: 1
Thanked 11 Times in 10 Posts
i woul guess you fryed the voltage reg in the alt have it checked

05 f250 cc
RCD egr delete, SCT with RCD tunes
03 turbo
magana flow 4" no muff
105vegas is offline  
The Following User Says Thank You to 105vegas For this addition to TDG:
strokin6L (11-20-2009)
post #9 of 38 (permalink) Old 11-19-2009, 09:05 PM
Old Fart
 
dbennett48's Avatar
 
Join Date: Nov 2009
Location: Ukiah, Ca
Posts: 813
Points: 45,231
Thanks: 186
Thanked 169 Times in 145 Posts
Garage
Your alternator is not charging. It throws a battery light to indicate this.

Dave
dbennett48 is offline  
The Following User Says Thank You to dbennett48 For this addition to TDG:
strokin6L (11-20-2009)
post #10 of 38 (permalink) Old 11-20-2009, 12:38 PM Thread Starter
Senior Member
Threadstarter
 
strokin6L's Avatar
 
Join Date: Dec 2008
Location: springville NY
Posts: 3,306
Points: 65,011
Thanks: 356
Thanked 198 Times in 189 Posts
ok guys this is what i found. I tested the battery with the mulitmeter and it read 10.5. I then tested the alternator and it read 10.2. So maybe i fried the alternator then.

2004 F-350 XLT SC 4x4: SCT, AFE stage II, autometer gauges(pyro, boost, tranny, fuel), edge insight, CFM large mouth intake elbow, spearco, snow performance water injection, 5" stacks, ARP's, fluidampr, hypermax fire rings, LIPD regulated return, FASS, fuelab, casserly 190's, 64/71/70 turbo(polished compressor housing)modded FICM(ID), Hellmann's sump, electirc fans
strokin6L is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
charging system powerstroke3 1994-2003 7.3L Power Stroke 3 11-08-2009 12:53 AM
Battery Charging thompsd 2003-2007 6.0L Power Stroke 10 01-09-2009 12:13 AM
battery charging question Super Limo 1994-2003 7.3L Power Stroke 4 12-02-2007 11:58 PM
battery not charging steve s Duramax 2001-2004 (LB7) 2 06-11-2007 10:20 PM
Charging the trailer battery cdooguy Towing and Hauling 7 02-17-2006 05:06 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome