truck dies going down the road - TheDieselGarage.com
Thread Details Posted by BigWhite250, this thread has received 13 replies and been viewed 5556 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 02-03-2009, 03:20 AM Thread Starter
STROKIN' IT
 
Join Date: Dec 2005
Posts: 287
Points: 12,653
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to BigWhite250
truck dies going down the road

starting a week or so ago i was driving downtown and my truck just cut off... i pulled over and it started back up and then did it again about a mile down the road. it did this several times and one time didn't want to start back up but eventually did after about 10 mins. 1st thing i did was change fuel filter, crapload of water in that so i replaced that and drained water but its still doing it and i also added some diesel kleen to my fuel. the service engine light comes on but goes off when you start it back up and no codes can be found. any help would be greatly appreciated i reallllly need to get this taken care of before mowing starts back up. could it be the CPS? i got a recall notice for that but havent taken it in yet.,,,

2000 F-250 cc Super Duty, TS Performance 6 pos, Exhaust, AFE intake, in dash tv/dvd/mp3, Memphis 12" sub in ported box, 20x10" Mazzi Hulks with 305-55-20 Toyo Open Country A/T's, APC projector headlights, Chrome wheel-to-wheel nerf bars...uhmm plenty of other B/S! :evil:
BigWhite250 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 02-03-2009, 03:25 AM
Senior Member
 
pontiacross's Avatar
 
Join Date: Dec 2008
Location: Mexico, MO
Posts: 2,509
Points: 26,930
Thanks: 145
Thanked 82 Times in 79 Posts
sounds exactly like a cam position sensor problem.

Ross
Show-ME Smokers 2.6 modified street pulling truck "The Lone Stroke" My Videos
1996 f350, powerstroke, 4x4, 5-speed, 4.56 gears, Swamps 450/600 injectors, Swamps BFH turbo, Swamps Idm, Swamps tunes, BTS oil, SBC clutch, studs, springs, tubes, air to water intercooler, fuel system, factory rods!


Tow Rig
1997 f350, srw, reg cab, 4x4, 5 speed, 4.10 gears, 3in down pipe, straight pipe, mystery chip.

Becker Brothers Enterprises
pontiacross is offline  
post #3 of 14 (permalink) Old 02-03-2009, 03:25 AM
********* and Mafia #90
 
Bcarriveau's Avatar
 
Join Date: Jul 2007
Location: New Berlin, WI
Posts: 14,261
Points: 72,947
Thanks: 943
Thanked 1,330 Times in 983 Posts
Garage
Send a message via AIM to Bcarriveau Send a message via Yahoo to Bcarriveau
well i would start with that cant narrow anything down with a open recall

Bill Carriveau OFFICIAL POO HAULER

100K miles on 4/7/2010
2005 F250 FX4 Supercab Shortbed
ARP studs, sct, Leveling kit,Airdog set at 62psi with no factory pump, leveling kit,5" stacks, under cab lights, Large in the way Fan shroud Removed, bed Lights being Re-did. Large Alternator(250amps)(130 amps was so 2003). On 3rd set of Hgs(soon to be 4th), 2nd set of heads, 2nd tubro, egr cooler, FICM and more. When i Turn the Key it does return a Favor, not always in MY Favor.
Da Rules..Here

Windows 7 Takes the WIN!
Windows 8 might take that Win
http://www.bcarriveau.com/
Dear Tequila:
We had a deal. You were supposed to make me sexier, smarter and a better dancer. But I saw the video. And I think we need to talk..


How you name your Thread is Important. Read Here

The TDG TOTQ


Bcarriveau is offline  
post #4 of 14 (permalink) Old 02-03-2009, 03:32 AM Thread Starter
STROKIN' IT
Threadstarter
 
Join Date: Dec 2005
Posts: 287
Points: 12,653
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to BigWhite250
thanks i suppose ill take er in one day soon... if not soon itll prolly be totalled... its kinda scary on a country road in a curve and the truck just shuts off and you have to wrestle the wheel lol!

2000 F-250 cc Super Duty, TS Performance 6 pos, Exhaust, AFE intake, in dash tv/dvd/mp3, Memphis 12" sub in ported box, 20x10" Mazzi Hulks with 305-55-20 Toyo Open Country A/T's, APC projector headlights, Chrome wheel-to-wheel nerf bars...uhmm plenty of other B/S! :evil:
BigWhite250 is offline  
post #5 of 14 (permalink) Old 02-03-2009, 11:21 AM
Member
 
Join Date: Jan 2009
Location: Charlotte, NC
Posts: 40
Points: 707
Thanks: 10
Thanked 2 Times in 2 Posts
Mine did the same thing, stopped about 5 times in 700 miles,and I thought it was the CPS. I replaced it only to have cut off on me again. I then pulled out the chip and cleaned all of the contacts with laquor thinner and reinstalled the chip. Its been about 800 miles now and it has not cut off again. I was told that they get corroided, even though mine looked clean. A friend on mine had a chip go bad and had to have his replaced. Hope this helps.
crb478 is offline  
post #6 of 14 (permalink) Old 02-03-2009, 03:01 PM Thread Starter
STROKIN' IT
Threadstarter
 
Join Date: Dec 2005
Posts: 287
Points: 12,653
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to BigWhite250
Quote:
Originally Posted by crb478 View Post
Mine did the same thing, stopped about 5 times in 700 miles,and I thought it was the CPS. I replaced it only to have cut off on me again. I then pulled out the chip and cleaned all of the contacts with laquor thinner and reinstalled the chip. Its been about 800 miles now and it has not cut off again. I was told that they get corroided, even though mine looked clean. A friend on mine had a chip go bad and had to have his replaced. Hope this helps.
ok i bet thats what it is then... cuz my chip has been acting real funny lately, sometimes it wont change settings or anything for like 20 mins so ill try that. plus my truck gets alot of dust in it when im working since i do landscaping and lawn care. ill have to try that too

2000 F-250 cc Super Duty, TS Performance 6 pos, Exhaust, AFE intake, in dash tv/dvd/mp3, Memphis 12" sub in ported box, 20x10" Mazzi Hulks with 305-55-20 Toyo Open Country A/T's, APC projector headlights, Chrome wheel-to-wheel nerf bars...uhmm plenty of other B/S! :evil:
BigWhite250 is offline  
post #7 of 14 (permalink) Old 02-04-2009, 03:37 AM Thread Starter
STROKIN' IT
Threadstarter
 
Join Date: Dec 2005
Posts: 287
Points: 12,653
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to BigWhite250
called ts performance today and they said that they had never heard of such and the reason my chip was actin up was because my batts were below 12 volts an that makes sense since it only happens when its very cold outside. so it goes to the dealer friday mornin for the CPS recall..... Hope it fixes it!

2000 F-250 cc Super Duty, TS Performance 6 pos, Exhaust, AFE intake, in dash tv/dvd/mp3, Memphis 12" sub in ported box, 20x10" Mazzi Hulks with 305-55-20 Toyo Open Country A/T's, APC projector headlights, Chrome wheel-to-wheel nerf bars...uhmm plenty of other B/S! :evil:
BigWhite250 is offline  
post #8 of 14 (permalink) Old 02-04-2009, 11:19 AM
Member
 
Join Date: Jan 2009
Location: Charlotte, NC
Posts: 40
Points: 707
Thanks: 10
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by BigWhite250 View Post
called ts performance today and they said that they had never heard of such and the reason my chip was actin up was because my batts were below 12 volts an that makes sense since it only happens when its very cold outside. so it goes to the dealer friday mornin for the CPS recall..... Hope it fixes it!
If you still have the black CPS you might want to just change the CPS yourself. If the dealership does it they will keep the black one and there are many people on this board that believe the black one is better. You can buy the new gray one for about 25 dollars now and having a spare is always a good idea. It is hard to find a black one any more.

Also your batteries should have a full charge and really not be an issue since the truck is already running and they should be recharging while the alternater is providing the current.

Last edited by crb478; 02-04-2009 at 11:22 AM. Reason: additional
crb478 is offline  
post #9 of 14 (permalink) Old 02-04-2009, 02:31 PM
The Irishman
 
Caos56's Avatar
 
Join Date: Oct 2007
Location: West Palm Beach, FL
Posts: 68
Points: 3,399
Thanks: 5
Thanked 7 Times in 7 Posts
CPS, but mine died 5 times in 3 miles. Then I had to be towed home with my boat on the back. lol Also, I have Auto Ingenuity, and with the black and grey comparison, the pressure stayed normal, but the idle was rougher that a night in jail w/ the Grey one!
If you run it without the chip does it still do it?

97 F-250 4x4 4Dr Short Bed Tourmaline Green
New HPOP,1.0 Exhaust Housing,
7.3L IC W/ Banks Piping
Straight Piped 5in Grand Rocks,
IDM Mod, 10K Mod, New Body Mounts.

Finally Own!!!!!!!
91 C-350 Four Door Bronco


Billy O'Bryan
Caos56 is offline  
post #10 of 14 (permalink) Old 02-04-2009, 03:03 PM Thread Starter
STROKIN' IT
Threadstarter
 
Join Date: Dec 2005
Posts: 287
Points: 12,653
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to BigWhite250
it does it all the time whether the chip is on stock or my economy tune, and the chip only acts up when i first start it when its super cold out after it gets going it will work fine. the guy at ts said if its under 12volts it owuld likely do that so im guessing thats it.

as far as changing the CPS myself, lol no thanks i dont even know where it is, and the dealership will change it for free. and i dont think anyone would want a faulted sensor....

2000 F-250 cc Super Duty, TS Performance 6 pos, Exhaust, AFE intake, in dash tv/dvd/mp3, Memphis 12" sub in ported box, 20x10" Mazzi Hulks with 305-55-20 Toyo Open Country A/T's, APC projector headlights, Chrome wheel-to-wheel nerf bars...uhmm plenty of other B/S! :evil:
BigWhite250 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck Runs Then Dies 01CUMMINS24 5.9L Cummins (2003-2007.5) 5 12-03-2007 02:34 PM
03 Dmax dies while rolling down the road Dux2bux Duramax 2001-2004 (LB7) 0 10-20-2007 04:29 PM
Truck dies when I go into Drive WBV06CTD 5.9L Cummins (1998.5-2002) 3 01-27-2007 02:08 AM
Truck dies JamesF250 1994-2003 7.3L Power Stroke 3 10-19-2006 08:32 PM
Truck dies when put in reverse... belz 1994-2003 7.3L Power Stroke 10 12-12-2005 11:00 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome