wont start, need help with codes P0603 & P1660 - TheDieselGarage.com
Thread Details Posted by kamaleon, this thread has received 12 replies and been viewed 2054 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 03-08-2009, 01:43 AM Thread Starter
Junior Member
 
Join Date: Oct 2006
Posts: 8
Points: 167
Thanks: 0
Thanked 0 Times in 0 Posts
Question wont start, need help with codes P0603 & P1660

Hey guys, my truck slowly died the other day went from normal to lack of power to no power what so ever and eventually dies on the side of the road, this happened over a 400mile trip.

The truck now wont start and has two codes;

(P0603) = CONTINUOUS DTC P0603 INDICATES PCM HAS EXPERIENCED A POWER INTERRUPT IN KAM CIRCUIT. [KAM == Keep Alive Memory]

(P1660 OR P1661) = INDICATES THAT OUTPUT CIRCUIT CHECK IS HIGH OR LOW.POSSIBLE CAUSES ARE:HIGH SYSTEM
VOLTAGE, VREF CIRCUIT FAULT;

I don't understand what they mean or what where to do next.
kamaleon is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 03-08-2009, 03:40 AM
Super Moderator
 
John_G's Avatar
 
Join Date: Dec 2008
Location: Tyler, TX
Posts: 4,247
Points: 49,246
Thanks: 101
Thanked 406 Times in 347 Posts
Did you check ALL the fuses? It's relatively common for the fuel heater element to short out which causes the PCM fuse to fail. But, you get codes so that's good.

Do the WTS and Check Engine lights come on with the key? If so, that's VERY good.

Next, when you crank it, does the tach indicate RPM? If not, you may have simply a bad cam sensor.

P1660/1 indicates a short in an output circuit from the PCM, IPR valve and EBP solenoid are the two main ones and if one is dead shorted, that would keep it from starting.

'93 F-250 HD, 7.3L IDI, 5spd - FARM TRUCK
I Support: Trailer brakes an every axle over the towing vehicle's GVW; CDLs for RVers; Safety inspections for ALL vehicles and 6 axle trucks (97K GVW proposal).

Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote - Benjamin Franklin

I vote for LIBERTY!
John_G is offline  
post #3 of 13 (permalink) Old 03-08-2009, 03:09 PM
Senior Member
 
Join Date: Dec 2008
Posts: 862
Points: 22,323
Thanks: 2
Thanked 112 Times in 85 Posts
Sounds like a power/voltage issue, either external with the alternator or batteries, or internal with the PCM or wiring.
Pocket is offline  
post #4 of 13 (permalink) Old 03-09-2009, 03:25 AM
Junior Member
 
Join Date: May 2008
Posts: 1
Points: 710
Thanks: 0
Thanked 0 Times in 0 Posts
My 97 is popping the same code. I just had a Sniper chip, new valve cover gaskets, wiring harnesses under the valve covers, and a glow plug relay. It drove fine and now I have codes P0603, P1391 & P1393. Now my truck for start. It turns over good but I don't get a "Wait to Start" light and the glow plug relay doesn't click. I have checked all the fuses (ohms test) all are okay. Could it be the new Sniper chip?
Thanks,
Matt
LQHauler is offline  
post #5 of 13 (permalink) Old 03-10-2009, 07:15 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Oct 2006
Posts: 8
Points: 167
Thanks: 0
Thanked 0 Times in 0 Posts
A friend is comoing over today with a better scanner.. The ses light is not on but there are codes stored, we are going to erase those codes and start new.

From the research i done, code P0306 is not very important, power loss from batteries, i did had bad batteries two months ago but never saw any ses light then now now.

The next code is somewhat tricky as it could be a number of things, once i get to run more test later today i'll be able to zoom in into the actual problem(s)

The wait to start light is working fine, as is the ses light. Tach does move when cranking. I dont think its got to do with wiring, the truck slowly died in the course of 400 miles.
kamaleon is offline  
post #6 of 13 (permalink) Old 03-11-2009, 12:39 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Oct 2006
Posts: 8
Points: 167
Thanks: 0
Thanked 0 Times in 0 Posts
puzzled at a higher degree

I just ran a few test on it with a genesys system scanner with software v2.0

Injector Control pressure: peaked at 2600
Injector Press Reg duty Cycle %: when keywas at the on position it read 15% and raised to 39-44 when engine was cranking..

so, do i have a high oil pressure leak and also starving for fuel??

PS. i disconnected the batteries and removed the chip, the only code in the pcm was the 0306 related to power failure, once deleted from the pcm no code ever came up after cranking the truck for 5-6 times. So, i have no codes now?!? :
kamaleon is offline  
post #7 of 13 (permalink) Old 03-11-2009, 01:41 AM
Senior Member
 
Join Date: Dec 2008
Posts: 862
Points: 22,323
Thanks: 2
Thanked 112 Times in 85 Posts
Quote:
the truck slowly died in the course of 400 miles.
Quote:
Injector Control pressure: peaked at 2600
Injector Press Reg duty Cycle %: when keywas at the on position it read 15% and raised to 39-44 when engine was cranking..

so, do i have a high oil pressure leak and also starving for fuel??
Fuel, not oil. Oil pressure will rise like that when you are cranking, especially if there's no fuel.

Check to see if you have fuel in the bowl.
Pocket is offline  
post #8 of 13 (permalink) Old 03-11-2009, 03:24 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Oct 2006
Posts: 8
Points: 167
Thanks: 0
Thanked 0 Times in 0 Posts
there is fuel in the bowl and i can see the bowl fill up when key is on.
kamaleon is offline  
post #9 of 13 (permalink) Old 03-11-2009, 12:20 PM
Senior Member
 
Join Date: Dec 2008
Posts: 862
Points: 22,323
Thanks: 2
Thanked 112 Times in 85 Posts
Quote:
Originally Posted by kamaleon View Post
there is fuel in the bowl and i can see the bowl fill up when key is on.
Do you see smoke when cranking?
Pocket is offline  
post #10 of 13 (permalink) Old 03-11-2009, 12:29 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Oct 2006
Posts: 8
Points: 167
Thanks: 0
Thanked 0 Times in 0 Posts
nope, no smoke at all when cranking
kamaleon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wont start??? ccoxva 5.9L Cummins (Pre 1994) 1 02-25-2008 02:45 PM
need help wont start clay 5.9L Cummins (1998.5-2002) 12 01-22-2008 02:39 PM
97 wont start Fireguy 5.9L Cummins 12 Valve (1994-1998.5) 5 10-25-2007 11:32 AM
97 F-250 wont start Strokin05 1994-2003 7.3L Power Stroke 18 10-11-2006 09:02 PM
05 wont start twin_turbocummins05 5.9L Cummins (2003-2007.5) 11 04-21-2006 08:27 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome