tachometer not working '96 peterbilt - TheDieselGarage.com
Thread Details Posted by niceguypmp3, this thread has received 4 replies and been viewed 8448 times.

LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-28-2011, 01:56 PM Thread Starter
Junior Member
Join Date: Jan 2010
Posts: 30
Points: 20,934
Thanks: 13
Thanked 0 Times in 0 Posts
tachometer not working '96 peterbilt

We just bought a '96 Peterbilt 378 with a 435hp 3406e and 1.34 million miles. The valve cover says 435hp but we were told that the ecm says 500hp and verifies that many miles, but it doesn't run like 500hp. It seems that our '03 C15's with 425hp can outrun it by just a little bit. We have noticed that the tachometer doesn't work at all and it looks like they just replaced it with a brand new one. I pulled the dash panel out (which i love how easy that is to do on a pete) and wiggled the plug and even unplugged it and plugged it back in all while it was running and the gauge didn't move at all. Any ideas what could be looked at next? The pyro also doesn't work. It looks like there are two wires for that going to the sensor in the exhaust. Same thing, i wiggled the wires and nothing.

Other than that, with that many miles, it seems to run ok. The highest I could get the boost while pulling a load was about 22-23 psi if the boost gauge is reading correct. I'm assuming they have done an inframe with it at some point because it doesn't smoke at all and the head has no paint at all on it and the oil pan is squeaky clean.

Any info as to what to look for and maybe any thing else that is problematic on this year and model of Pete would be greatly appreciated. Thanks everyone!
niceguypmp3 is offline  
Sponsored Links
post #2 of 5 (permalink) Old 03-28-2011, 04:23 PM
Rogerstar1's Avatar
Join Date: May 2010
Location: Washington, DC
Posts: 979
Points: 54,420
Thanks: 1,603
Thanked 182 Times in 127 Posts
I'd pull the pyrometer sending unit, light a match underneath it and have 'stupid' watch the gauge to report what she sees happening. I'm not a mechanic but this approach seems logical to me.

Tachometer: I'd trouble shoot the sensor coming out the top of transmission and the wires running to it.

Last edited by Rogerstar1; 03-28-2011 at 04:27 PM.
Rogerstar1 is offline  
post #3 of 5 (permalink) Old 03-29-2011, 02:06 AM
Senior Member
Join Date: Dec 2008
Location: tulsa ok
Posts: 1,103
Points: 43,216
Thanks: 28
Thanked 222 Times in 190 Posts
theakerstwo is offline  
The Following 2 Users Say Thank You to theakerstwo For this addition to TDG:
niceguypmp3 (03-29-2011), Rogerstar1 (03-29-2011)
post #4 of 5 (permalink) Old 03-29-2011, 04:15 AM Thread Starter
Junior Member
Join Date: Jan 2010
Posts: 30
Points: 20,934
Thanks: 13
Thanked 0 Times in 0 Posts
Alright, thanks for the link! It gives me somewhere to start anyways. Anyone one else chime in on anything? Thanks!!
niceguypmp3 is offline  
post #5 of 5 (permalink) Old 03-29-2011, 04:26 AM
Senior Member
379Longhood's Avatar
Join Date: Oct 2009
Location: Alberta t0m0r0
Posts: 2,516
Points: 65,074
Thanks: 194
Thanked 691 Times in 515 Posts
the above link should cover the tach , the sensor is on the flywheel housing.
the pyrometer can be checked by disconecting the wire s and momentarily connecting a fairly dead 1.5 v battery, the needle should jump , don't contact long enough to peg the needle. if that works check for continuity to the sendor at the turbo if you have wire continuity the sendor is fubar, some where in one of the posts Mike from ISPRO posted the sendor output .

Canadian Club member 27
'88 379 exhd 3406C 15 40s 10 pete unimounts
'93 K3500 6.5 4L80 4" exh
'62 gmc shortbox 454 super t10 big brakes
JD 820 black dash
12V92 waitin' for a truck (mega ratrod)
pettibone s20 3306 pc
379Longhood is offline  
Sponsored Links
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tachometer recommendations mrduallyf350 7.3L and 6.9 IDI (Pre 1994) 0 05-09-2009 03:41 PM
1992 tachometer gon2sea 5.9L Cummins (Pre 1994) 5 03-16-2008 06:10 AM
Help No Tachometer fordrules 5.9L Cummins 12 Valve (1994-1998.5) 3 10-21-2007 05:01 AM
tachometer question osos57 7.3L and 6.9 IDI (Pre 1994) 0 06-29-2007 06:06 AM
tachometer sensor osos57 7.3L and 6.9 IDI (Pre 1994) 0 06-17-2007 06:43 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome