Dt466 oil/water light - TheDieselGarage.com
Thread Details Posted by idigdirt, this thread has received 3 replies and been viewed 2592 times.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-11-2011, 09:02 PM Thread Starter
Junior Member
 
idigdirt's Avatar
 
Join Date: Feb 2011
Posts: 29
Points: 20,409
Thanks: 1
Thanked 0 Times in 0 Posts
Dt466 oil/water light

I have a 94 international 4800 with a Dt466. The oil/water light and buzzer keeps coming on and after 30 seconds to a minute the engine shuts down. The light has come on in the past and I had added about 6 oz of collant and it would go out. Today however I can't get it to go out and I oerfilled the radiator with collant. It appears someone has messed with some of the wires from kysor box as they have butt connectors on them. So is it harmful to have to much coolant? Is the oil/water light just for the levels of those fluids? Can it detect if there is oil IN the water? Coolant is very clean and the oil is not milky or foamy. Just black like normal. No white smoke or any smoke out of the exhaust. Do those kysor boxes go bad? Should I start with the sensor on the coolant tank? There are wires that go from the kysor box to a senson on the top front of the engine. What sensor does what. Thanks for any help or advise.

1994 International 4800 bucket truck,14k Fabco front axle,Fabco t case,5.38's,Braden winch,Allison MT643 trans with a 37k gvw

IH 4X4 club member #3
idigdirt is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-11-2011, 09:50 PM
Junior Member
 
mathura's Avatar
 
Join Date: Jul 2011
Location: Guyana
Posts: 298
Points: 38,410
Thanks: 45
Thanked 30 Times in 29 Posts
That is an indication that water level or oil level is low. Could be a faulty connection to these sensors or the sensor itself is bad.
mathura is offline  
The Following User Says Thank You to mathura For this addition to TDG:
idigdirt (11-11-2011)
post #3 of 4 (permalink) Old 11-11-2011, 10:44 PM Thread Starter
Junior Member
Threadstarter
 
idigdirt's Avatar
 
Join Date: Feb 2011
Posts: 29
Points: 20,409
Thanks: 1
Thanked 0 Times in 0 Posts
If I disconnect the wire to the sensor would that tell me if the sensor is bad? I guess I should start with the one on the tank?

1994 International 4800 bucket truck,14k Fabco front axle,Fabco t case,5.38's,Braden winch,Allison MT643 trans with a 37k gvw

IH 4X4 club member #3
idigdirt is offline  
post #4 of 4 (permalink) Old 11-12-2011, 11:14 PM Thread Starter
Junior Member
Threadstarter
 
idigdirt's Avatar
 
Join Date: Feb 2011
Posts: 29
Points: 20,409
Thanks: 1
Thanked 0 Times in 0 Posts
I may have fixed it today. The connection was a little loose. The wire that goes to the connector had a bare spot due to rubbing the radiator support rod. The light is off now. It's leaking antifreeze out of the overflow tube now because I put so much in

1994 International 4800 bucket truck,14k Fabco front axle,Fabco t case,5.38's,Braden winch,Allison MT643 trans with a 37k gvw

IH 4X4 club member #3
idigdirt is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
water light yadaddy99 2003-2007 6.0L Power Stroke 5 08-09-2009 06:25 PM
oil/water light flashing on dt466 BossHogg Medium and Heavy Duty 5 04-29-2008 06:32 AM
water in the fuel light on fleedog 2003-2007 6.0L Power Stroke 7 04-07-2007 02:15 AM
oil/water light blinking DT466 Duke Medium and Heavy Duty 20 06-12-2006 12:54 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome