cat C7 problem 2 different engines - TheDieselGarage.com
TheDieselGarage.com
 

Home Forum Who's Online Today's Posts Vendors Advertise
Go Back   TheDieselGarage.com > Heavy, Medium, Work Trucks and Trailers > Heavy Duty

Thread Details Posted by acegreaser, this thread has received 15 replies and been viewed 27460 times.

TheDieselGarage.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 07-29-2010, 03:09 AM   #1
acegreaser
Junior Member
 
Join Date: Apr 2007
Posts: 166
Points: 39,569
Thanks: 6
Thanked 12 Times in 10 Posts
cat C7 problem 2 different engines

C7 #1 acting strange,complaint loss of power.They took it to dealer.Dealer changed injectors,high pressure pump,pistons and rings,crank,cam,boost sensors.They took it for road test everything running fine than it started to push white smoke.Shut truck off restarted truck running smooth than started pushing black smoke.Any thoughts?Thats the 1st engine.2nd C7 rebuilt 3 years ago has about 40k on rebuild.Rering and replaced injector cups and o rings because of coolant loss.Engines been fine,last week was told that it sounded like it was back firing,when they started it up in the morning.Driver brought it to the shop,not missing just complained that every once in while has no power when pulling away from a stop or when you want to accelerate while moving.This engine has always had alot fo blow by comming from breather ever since new.After rebuild cleared up now its back.Thanks for any help.
acegreaser is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-29-2010, 04:23 AM   #2
OTT
Junior Member
 
Join Date: Jul 2010
Location: Omaha Ne
Posts: 316
Points: 23,180
Thanks: 1
Thanked 31 Times in 31 Posts
the 2nd c7 sounds like the inj pump. The last one I worked on was doing kind of the same thing as the 2nd c7 and the pump was shot. Are you having any starting issues? The 1st c7 beats the **** out of me!
__________________
2011 389 c-16 stage 2 tune stage 2 injectors stage 3 cam stage 3 turbo Coming soon Twin turbos!
07 379x 625 mxs, stage1 pdi tune,pdi manifold
07 chevy 2500, efi tuned by the master Idaho Rob, 5" exhaust,Tranny built by myself with stage 4 suncoast parts tc1056
PDI dealer in Nebraska
"If I wanted a 7cz tune file I would buy a 7cz"!
The Name Is Dusty AKA Mr.Young Dealer
OTT is offline   Reply With Quote
Old 07-29-2010, 05:41 AM   #3
pichu2
Junior Member
 
pichu2's Avatar
 
Join Date: Feb 2010
Posts: 461
Points: 37,408
Thanks: 194
Thanked 76 Times in 64 Posts
it could be the kind of oil you used?CATERPILLAR IS RECALLING CERTAIN C7 ENGINES MANUFACTURED FROM MARCH 3, 2005 THROUGH JANUARY 6, 2009, INSTALLED AS ORIGINAL EQUIPMENT IN VARIOUS HEAVY TRUCKS AND BUSES. THE #5 AND #6 FUEL LINES MAY CRACK AT THE FASTENING POINT TO THE COMMON FUEL RAIL AND CAUSE A FUEL LEAK.Consequence:
A FUEL LEAK, IN THE PRESENCE OF AN IGNITION SOURCE, CAN RESULT IN A VEHICLE FIRE.Remedy:
CATERPILLER WILL NOTIFY OWNERS AND REPAIR THE VEHICLES FREE OF CHARGE. THE SAFETY RECALL IS EXPECTED TO BEGIN ON OR ABOUT SEPTEMBER 1, 2010. OWNERS MAY CONTACT CATERPILLAR TOLL-FREE AT 1-800-447-4986.
OWNERS MAY ALSO CONTACT THE NATIONAL HIGHWAY TRAFFIC SAFETY ADMINISTRATION'S VEHICLE SAFETY HOTLINE AT 1-888-327-4236 (TTY 1-800-424-9153), OR GO TO HTTP://WWW.SAFERCAR.GOV
pichu2 is offline   Reply With Quote
Old 07-29-2010, 06:13 AM   #4
Johnp3
Junior Member
 
Join Date: Nov 2009
Posts: 3,499
Points: 48,306
Thanks: 68
Thanked 638 Times in 564 Posts
The first truck I would do a back preasure reading, you could have a broken baffle, in the muffler.
The second one I would put it in the shop and remove the exhaust manifold, leave it sit for say 12 hours and then start it to find the cylinder, I would think you have a dribbling tip on at least one injector. That would give you fuel popping in the exhaust and pre ignition when trying to accelerate.
The blow-by, pressurise the Turbo outlet and I would be looking for worn valve guides.
__________________
1988 ford van fresh overhaul, 1991 nissan pick-up 1993 Caprice 2000 GMC S10 Blaser 2007 nbs 3500 GMC 4x4 crew-cab long box 17 inch single wheels Duramax Alison. BW turnover Ball. Furakawa FL35 loader. Retired, HD mechanic, worked on engines all my life. Fabricator welder. electrician. in the process of finishing my new shop. Live in Rock Creek B.C. Wife has a fruit stand.
Johnp3 is offline   Reply With Quote
The Following User Says Thank You to Johnp3 For this addition to TDG:
JT Napier (06-16-2012)
Old 07-30-2010, 02:07 AM   #5
acegreaser
Junior Member
Threadstarter
 
Join Date: Apr 2007
Posts: 166
Points: 39,569
Thanks: 6
Thanked 12 Times in 10 Posts
#2 has no injector lines just one from filter housing to front of head to supply the fuel to the fuel galley.Test drove truck today.When you mash throttle to floor engine will not increase in RPM just stumbles and bogs than gradually takes off.Checked fuel pressure between filter housing and head.60psi at idle and full RPM just barely 75psi.Isn't it supposed to be 105psi at full rpm.Going to check for air bubbles on the return tomorrow.No back fire when started and ran actually smooth.Just no acceleration at all just gradual.

Last edited by acegreaser; 07-30-2010 at 02:10 AM.
acegreaser is offline   Reply With Quote
Old 07-30-2010, 02:33 AM   #6
QUALITYTRUCK
Junior Member
 
Join Date: Apr 2009
Posts: 69
Points: 26,436
Thanks: 31
Thanked 20 Times in 19 Posts
johnp3 is on the right track.had 3 different c7,s come in the shop over the last year with the muffler all plugged up.they all looked almost brand new from outside.fell apart on inside.same issues that your having.good luck.
QUALITYTRUCK is offline   Reply With Quote
The Following User Says Thank You to QUALITYTRUCK For this addition to TDG:
JT Napier (06-16-2012)
Old 08-03-2010, 01:06 PM   #7
acegreaser
Junior Member
Threadstarter
 
Join Date: Apr 2007
Posts: 166
Points: 39,569
Thanks: 6
Thanked 12 Times in 10 Posts
Changed fuel and water seperator,and check valve on back of head.When truck was cold great throttle response and acceration.As soon as it started getting up above 150 degrees it started to stumble and fall flat.No acceleration just gradual.If you get kept the rpms up above 1400 it would accelerate fine when you hammered the gas.While i had gauge hooked up to fuel while this was going on fuel pressure would drop to 50 for a split second than right back up to 75.
acegreaser is offline   Reply With Quote
Old 10-21-2010, 09:14 PM   #8
LPGGUY
Junior Member
 
Join Date: Oct 2010
Posts: 1
Points: 214
Thanks: 0
Thanked 0 Times in 0 Posts
ace,
I have 2 c-7s with the same symptoms that you are describing. I have had the injection pump, injectors, and turbo replaced, and still no luck. any suggestions?
LPGGUY is offline   Reply With Quote
Old 03-13-2011, 08:22 PM   #9
oilytony
Junior Member
 
Join Date: Mar 2011
Posts: 2
Points: 5,122
Thanks: 0
Thanked 0 Times in 0 Posts
i have a 2004 freightliner with a cat c7 on it. Experiencing strange beavior it idles fine up until it gets to 150 degrees from than on there is no acceleration. any ideas? Already went crazy with it. Changed fuel pump, changed fuel lines and filters, changed injectors o rings and still no luck. Would appreciate any sugestions.

Last edited by oilytony; 03-13-2011 at 08:26 PM.
oilytony is offline   Reply With Quote
Old 03-13-2011, 08:39 PM   #10
leftlanetruckin
Member
 
Join Date: Mar 2011
Location: Mid Missouri
Posts: 71
Points: 18,542
Thanks: 0
Thanked 6 Times in 6 Posts
From the other 2 guys symptoms, I would do what has already been suggested, change the muffler. It's a @$70 part that does wear out and/or get plugged up.
Granted most of my engine experience comes from gas engines, but an engine is an engine after all That's why I get top $ for the Range Rover engines I rebuild and sell, for some reason everyone is scared of what is basically a pushrod V8

martin
leftlanetruckin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engines BIG C 2011+ 6.7L Power Stroke Diesel 5 01-02-2010 01:49 AM
Engines... wastedwagesracing Duramax 2001-2004 (LB7) 6 08-26-2009 02:13 PM
6.0 and 7.3 Engines JMS8800 Whats Been Sold 5 04-28-2007 05:47 PM
DT 466E exchanged engines - computer problem? Rent Able Heavy Duty 5 12-29-2006 08:33 PM
12v engines fordfreak84 5.9L Cummins 12 Valve (1994-1998.5) 2 06-15-2006 06:31 AM

New To Site? Need Help? TDG Specials

All times are GMT. The time now is 08:01 PM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.
vB.Sponsors
vBCredits v1.4 Copyright ©2007 - 2008, PixelFX Studios