Mazda RF diesel? - Page 3 - TheDieselGarage.com
TheDieselGarage.com
 

Home Forum Who's Online Today's Posts Vendors Advertise
Go Back   TheDieselGarage.com > Other Vehicles And Accessories > General Diesel

Thread Details Posted by elvis, this thread has received 29 replies and been viewed 41163 times.

TheDieselGarage.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 08-23-2010, 11:54 AM   #21
Gillig8V71
Junior Member
 
Join Date: Apr 2007
Location: Oak Grove, Oregon, US
Posts: 48
Points: 7,742
Thanks: 43
Thanked 1 Time in 1 Post
The 2.0L RF diesel engine was used in the Ford Escort/Mercury Lynx from 1984 to December 1986 and in the larger Ford Tempo/Mercury Topaz from 1984 to August 1986. Mazda used the same engine in the USA version of the 626 in the years 1984-85, but only in the Luxury trim 4-door notchback sedan.

The 2.2L RF diesel engine was used in the Ford Ranger pickup truck from 1982-84 (but, ironically, it was never offered in its predecessor, the Courier, which was an actual Mazda derivative sold in the years 1972-82) and was replaced by the Mitsubishi 2.3L turbo diesel for the years 1985-87. The Mitsu engine had also been used in the Dodge Ram 50 in the years 1983-86.

The Mazda B2200 Diesel truck was sold here (in the USA) from 1982-85.

~Ben
Gillig8V71 is offline   Reply With Quote
The Following User Says Thank You to Gillig8V71 For this addition to TDG:
Diesel Brad (08-24-2010)
Sponsored Links
Advertisement
 
Old 08-23-2010, 04:23 PM   #22
EmJay
Junior Member
 
Join Date: Jan 2010
Posts: 20
Points: 13,837
Thanks: 3
Thanked 4 Times in 4 Posts
Hate to say it, but the R2 diesel (the 2.2 that you are referring to) was never released in any production vehicle in the US. The diesel that you are thinking of is the Perkins S2 diesel which did come in some Ford Rangers and in the B2200 diesels. This was all cast construction, no aluminum. The RF and the R2 came with aluminum heads and was the cause of some issues. That is nice to know that the RF diesel came in the nicer models of the 626, i've never seen one in person in a Mazda and only 1 in an escort (the one that I have.)

for those that are following, I was able to source out a bellhousing that came from an overseas mazda bongo minivan, also in the process of doing a gear swap cuz they interchange. I also got a starter for an overseas Mazda 323 that fits the bellhousing properly. The flywheel from the Kia Sportage 2.0 dual cam works on this crank (the kia engine is a mazda FE3 design used between 95-02) and the clutch from my 86 B2000 works with this as well.
still need to redisassemble the block and get it o-ringed for the copper head gasket. I really want the better heat dissipation and had the block decked due to damage, the pistons stick up .025 above the surface. With the new valve seats and the heat treated head I should be good to go timing and funding permitting.
EmJay is offline   Reply With Quote
The Following User Says Thank You to EmJay For this addition to TDG:
Gillig8V71 (08-23-2010)
Old 08-24-2010, 04:28 AM   #23
Diesel Brad
Member
 
Diesel Brad's Avatar
 
Join Date: Nov 2007
Posts: 326
Points: 32,310
Thanks: 48
Thanked 17 Times in 15 Posts
Quote:
Originally Posted by Gillig8V71 View Post
The 2.0L RF diesel engine was used in the Ford Escort/Mercury Lynx from 1984 to December 1986 and in the larger Ford Tempo/Mercury Topaz from 1984 to August 1986. Mazda used the same engine in the USA version of the 626 in the years 1984-85, but only in the Luxury trim 4-door notchback sedan.

The 2.2L RF diesel engine was used in the Ford Ranger pickup truck from 1982-84 (but, ironically, it was never offered in its predecessor, the Courier, which was an actual Mazda derivative sold in the years 1972-82) and was replaced by the Mitsubishi 2.3L turbo diesel for the years 1985-87. The Mitsu engine had also been used in the Dodge Ram 50 in the years 1983-86.

The Mazda B2200 Diesel truck was sold here (in the USA) from 1982-85.

~Ben
OK, that clears one up I was curious about, I know a guy who was looking for the turbo diesel version, but thought it was a Mazda engine, but the only one I knoew of in thast era was the Mitsubishi engine.
Ive heard mixed opinions on the one put in the Tempo/626/Escort.
__________________
You know you live in a Country run by idiots if....
Hard work and success are rewarded with higher taxes
and government intrusion, while slothful, lazy behavior
is rewarded with EBT cards, WIC checks, Medicaid and
subsidized housing, and free cell phones.


2011 Ford F150 Ecoboost
1970 International Loadstar DV550
Diesel Brad is offline   Reply With Quote
The Following User Says Thank You to Diesel Brad For this addition to TDG:
Gillig8V71 (08-24-2010)
Old 08-24-2010, 09:10 AM   #24
Chief Tool
Junior Member
 
Join Date: Aug 2010
Posts: 6
Points: 450
Thanks: 0
Thanked 1 Time in 1 Post
there was no R2 turbo diesel ever made to my knowledge, but there are some RF turbo's out of the JDM.
There is the IDI version, the direct injection version, and the common rail one.

here is a pic of an IDI version found in JDM Mazda bongo vans.



I have heard of people fitting turbos to the R2, however the turbo motor has some stronger internals and a slightly lower C/R
Chief Tool is offline   Reply With Quote
The Following User Says Thank You to Chief Tool For this addition to TDG:
Gillig8V71 (08-24-2010)
Old 09-05-2011, 07:11 PM   #25
EmJay
Junior Member
 
Join Date: Jan 2010
Posts: 20
Points: 13,837
Thanks: 3
Thanked 4 Times in 4 Posts
I tried to get her running again today. Using the clear line to see what was going on I first tried to get her to crank using my electric lift pump. I learned that the pump is worn/old/clogged and not pumping anymore.

So next I tried removing the electric pump and just hook up my fuel supply directly to the IP. I used my hand vacuum pump to pull fuel from the tank to the pump (also seeing if I had a clog in the tank/lines) and I got some fuel up. Then I cranked her with the injector lines cracked at the injectors. I noticed that there was an air bubble in my supply line and it wasn't going away. I figured, eh, reconnected the injectors, and tried again. I believe that the internal lift pump does work as I saw fuel being lifted and flowing, I also earlier noticed that fuel was splashing from the injector lines (but not very much.)

Determined to try to get that air bubble out of my supply side at this point, I used my hand pump again at the return side and started pumping. I was getting fuel to flow into my collector but that air bubble was going NOWHERE. I then disconnected power to the fuel disconnect switch, removed the vacuum pump (which still held 22 in/hg) and I saw bubbles coming back up the fuel supply line!

Question here, if the disconnect isn't energized, shouldn't the fuel return being disconnected NOT allow air to go back to the supply line, or does it only cut fuel from going to the injector rails?

If that air bubble refuses to go inside the pump, wouldn't that indicate a weak internal lift pump?

With the injector lines cracked, shouldn't I see large splashes of fuel or little piddle splashes? (I'm talking a very little amount here, an empty spray bottle with a very small amount of liquid/mostly air in the tube sized splash.)

One more thing, when I was pumping with the hand pump, I saw a lot of little bubbles in the pump line. I figured some of it was due to the loose connection that the vacuum pump had on the return line (it was only a slip on connection, I didn't clamp it or make it secure.) I will try tomorrow using clamped hose nice and air tight to see if it goes away or if it's the same.

Will too much air in the IP make the lift pump seem weaker?
EmJay is offline   Reply With Quote
Old 10-10-2011, 03:05 AM   #26
GLXpress
Junior Member
 
Join Date: Jan 2011
Location: Eastern Iowa
Posts: 20
Points: 24,174
Thanks: 0
Thanked 0 Times in 0 Posts
Def. subscribing to this!! I love my 84 tempo diesel. The mazda engine is awesome.
GLXpress is offline   Reply With Quote
Old 12-10-2011, 07:46 AM   #27
Vacationtime247
Junior Member
 
Join Date: Dec 2011
Posts: 2
Points: 219
Thanks: 0
Thanked 0 Times in 0 Posts
I have a 1986 Ford Tempo with the Mazda 2.0 RF Diesel Engine with the 5 speed. It's not pretty, it was sitting in my uncles yard for 12 years out in the country before saving it. But it was given to me free. Wasn't even interested in the car until I found out it was diesel. Went through each wheel and fixed the brakes. Replaced the starter and cleaned it up. Been averaging over 50 mpg in it. Last fill was 362 miles and had to squeeze in 7 gallons.
VT247
Vacationtime247 is offline   Reply With Quote
Old 12-10-2011, 08:03 AM   #28
Vacationtime247
Junior Member
 
Join Date: Dec 2011
Posts: 2
Points: 219
Thanks: 0
Thanked 0 Times in 0 Posts
Here is a before and after pic of the engine. There were nuts stuffed everywhere under the hood. What a mess! Got it cleaned up and running. It's my daily driver, go over 400 miles before fueling up and average over 50mpg with a high of 54!
VT247
Attached Thumbnails
Click image for larger version

Name:	before.jpg
Views:	3967
Size:	199.9 KB
ID:	29616   Click image for larger version

Name:	after.jpg
Views:	1976
Size:	175.2 KB
ID:	29617  
Vacationtime247 is offline   Reply With Quote
Old 12-11-2011, 12:13 PM   #29
elvis
Junior Member
Threadstarter
 
elvis's Avatar
 
Join Date: Jan 2006
Posts: 44
Points: 2,496
Thanks: 3
Thanked 0 Times in 0 Posts
Smile

Quote:
Originally Posted by EmJay View Post
I tried to get her running again today. Using the clear line to see what was going on I first tried to get her to crank using my electric lift pump. I learned that the pump is worn/old/clogged and not pumping anymore.

So next I tried removing the electric pump and just hook up my fuel supply directly to the IP. I used my hand vacuum pump to pull fuel from the tank to the pump (also seeing if I had a clog in the tank/lines) and I got some fuel up. Then I cranked her with the injector lines cracked at the injectors. I noticed that there was an air bubble in my supply line and it wasn't going away. I figured, eh, reconnected the injectors, and tried again. I believe that the internal lift pump does work as I saw fuel being lifted and flowing, I also earlier noticed that fuel was splashing from the injector lines (but not very much.)

Determined to try to get that air bubble out of my supply side at this point, I used my hand pump again at the return side and started pumping. I was getting fuel to flow into my collector but that air bubble was going NOWHERE. I then disconnected power to the fuel disconnect switch, removed the vacuum pump (which still held 22 in/hg) and I saw bubbles coming back up the fuel supply line!

Question here, if the disconnect isn't energized, shouldn't the fuel return being disconnected NOT allow air to go back to the supply line, or does it only cut fuel from going to the injector rails?

If that air bubble refuses to go inside the pump, wouldn't that indicate a weak internal lift pump?

With the injector lines cracked, shouldn't I see large splashes of fuel or little piddle splashes? (I'm talking a very little amount here, an empty spray bottle with a very small amount of liquid/mostly air in the tube sized splash.)

One more thing, when I was pumping with the hand pump, I saw a lot of little bubbles in the pump line. I figured some of it was due to the loose connection that the vacuum pump had on the return line (it was only a slip on connection, I didn't clamp it or make it secure.) I will try tomorrow using clamped hose nice and air tight to see if it goes away or if it's the same.

Will too much air in the IP make the lift pump seem weaker?
Emjay,

So its now early December.
What happened with the air problem?
My guess is you've either got a cracked line or an ill-fitting line on the high pressure side, or you just haven't run enough fuel through the system.
Sometimes it can take a lot more than it would seem to, to get everything "on-the-square".


Elvis
elvis is offline   Reply With Quote
Old 12-11-2011, 12:16 PM   #30
elvis
Junior Member
Threadstarter
 
elvis's Avatar
 
Join Date: Jan 2006
Posts: 44
Points: 2,496
Thanks: 3
Thanked 0 Times in 0 Posts
Smile

Quote:
Originally Posted by Vacationtime247 View Post
I have a 1986 Ford Tempo with the Mazda 2.0 RF Diesel Engine with the 5 speed. It's not pretty, it was sitting in my uncles yard for 12 years out in the country before saving it. But it was given to me free. Wasn't even interested in the car until I found out it was diesel. Went through each wheel and fixed the brakes. Replaced the starter and cleaned it up. Been averaging over 50 mpg in it. Last fill was 362 miles and had to squeeze in 7 gallons.
VT247
362/7=51.7
Nice!
I had an '80 Rabbit Diesel between '87 and '92.
The best milage I ever got with that car was 58 mpg, but I usually averaged between 45-48.
Keep that Tempo runnin'. She sounds like a sweetie!


Elvis
elvis is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mazda diesel Q: smootboy5 General Diesel 6 01-04-2010 04:05 AM
mazda vs. cummins cope junkie Road Kill, Bench Racing 10 01-08-2008 02:15 AM
DIEHARDDIESEL sleeper LBZ vs. Mazda RX8 video mattofferdahl9 Road Kill, Bench Racing 6 12-21-2007 08:08 PM
Mazda diesel into RX7 stustev Diesel Conversion 0 11-09-2007 12:29 AM
lil 4 cylinder mazda 05dury Road Kill, Bench Racing 22 06-30-2007 01:50 AM

New To Site? Need Help? TDG Specials

All times are GMT. The time now is 06:34 AM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.
vB.Sponsors
vBCredits v1.4 Copyright ©2007 - 2008, PixelFX Studios