Cat intercooler leak - TheDieselGarage.com
TheDieselGarage.com
 

Home Forum Who's Online Today's Posts Vendors Advertise
Go Back   TheDieselGarage.com > Heavy, Medium, Work Trucks and Trailers > Heavy Duty

Thread Details Posted by claymore1500, this thread has received 8 replies and been viewed 3106 times.

TheDieselGarage.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 08-29-2012, 01:01 AM   #1
claymore1500
Junior Member
 
claymore1500's Avatar
 
Join Date: Dec 2011
Location: North coast, Ohio
Posts: 9
Points: 12,363
Thanks: 1
Thanked 0 Times in 0 Posts
Cat intercooler leak

One of the Peterbilt trucks in the fleet that I am in charge of keeping on the road seems to be having a problem with inter coolers, the original one started leaking about three weeks ago, I replaced that one and the truck made ONE trip.

When it got back I checked the cooler and found it leaking again, We sent it to a local Kenworth dealer, to have some injector work done, and they replaced the cooler again, now, about one week later it has started leaking again.

What I am looking for is ANY ideas as to what may be causing this.

Thanks in advance. Tom.
claymore1500 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-29-2012, 01:35 AM   #2
SledMan
Junior Member
 
SledMan's Avatar
 
Join Date: Jul 2009
Location: Siler City, NC
Posts: 1,640
Points: 48,061
Thanks: 15
Thanked 481 Times in 374 Posts
Quote:
Originally Posted by claymore1500 View Post
One of the Peterbilt trucks in the fleet that I am in charge of keeping on the road seems to be having a problem with inter coolers, the original one started leaking about three weeks ago, I replaced that one and the truck made ONE trip.

When it got back I checked the cooler and found it leaking again, We sent it to a local Kenworth dealer, to have some injector work done, and they replaced the cooler again, now, about one week later it has started leaking again.

What I am looking for is ANY ideas as to what may be causing this.

Thanks in advance. Tom.
Either it's overboosting (doubtful), or the radiator frame is twisted. I have seen KW's twisted and I had to shim the mounts so the bolts wouldnt draw it together and crack the solder joints.
__________________
2005 250 Super Duty Crew. White and Grey. ARP studs, EGR Delete, and SCT from Vivian. CCV re-route, and 4" Magnaflow turbo back.

Other trucks: 1979 Kenworth W900A reg hood, 1980 Ext hood, 1982 Kenworth Cabover Aerodyne (BJ and the Bear) 2000 and 2003 Kenworth W900's. All Caterpillar Power. My 2003 has an MBN I converted to 6NZ. Early 550 file, 211-3026 squirts. 800 cam. Acert twins via custom mount. ARP head bolts. 856 to the tires via Antrim Dyno.. with the tuned file.


Transporter and Operator of a Bauer Built Championship Unlimited Tractor Pulling Sled for the United Pullers of the Carolinas, Region IV affiliate of the National Tractor Pullers Association (NTPA), and damn proud of it!!!!
SledMan is offline   Reply With Quote
Old 08-29-2012, 01:36 AM   #3
379Longhood
Senior Member
 
379Longhood's Avatar
 
Join Date: Oct 2009
Location: Alberta t0m0r0
Posts: 2,310
Points: 52,866
Thanks: 179
Thanked 585 Times in 438 Posts
Poor workmanship either on the part of the cooler mfg of the guys that installed it, if the cooler isn't mounted right or the mount points are damaged it could cause problems, but the shop that installed it should check that kind of thing to avoid warranty hasssles.
__________________
Canadian Club member 27
'88 379 exhd 3406C 15 40s 10 pete unimounts
'93 K3500 6.5 4L80 4" exh
'62 gmc shortbox 454 super t10 big brakes
JD 820 black dash
12V92 waitin' for a truck (mega ratrod)
pettibone s20 3306 pc
379Longhood is offline   Reply With Quote
Old 08-29-2012, 09:51 AM   #4
claymore1500
Junior Member
Threadstarter
 
claymore1500's Avatar
 
Join Date: Dec 2011
Location: North coast, Ohio
Posts: 9
Points: 12,363
Thanks: 1
Thanked 0 Times in 0 Posts
Maybe I should have specified, This is the "Cat" part, it mounts on the engine between the turbo and the water pump.

Also: Cat, put the first one on when the engine was built, I installed the second one, and the third one was put on by a Kenworth dealer, so it seems unlikely that the installer is at fault.
claymore1500 is offline   Reply With Quote
Old 08-29-2012, 10:58 AM   #5
SmokinCAT
Senior Member
 
SmokinCAT's Avatar
 
Join Date: Feb 2007
Location: Hillsboro OH/ Adrian MI
Posts: 2,246
Points: 59,440
Thanks: 94
Thanked 423 Times in 332 Posts
If you would have specified what engine that would have helped, and that is actually a pre cooler to drop IAT to a reasonable level before it enters the air to air. Must be an ACERT, which that being said you don't hear of those leaking too often, where is the leak?
__________________
Cody.

79 KW W900A 3406B
79 KW K100C 400BC1
00 Freightliner Classic XL C15
83 KW K100C 400BC3
SmokinCAT is online now   Reply With Quote
Old 08-29-2012, 10:10 PM   #6
claymore1500
Junior Member
Threadstarter
 
claymore1500's Avatar
 
Join Date: Dec 2011
Location: North coast, Ohio
Posts: 9
Points: 12,363
Thanks: 1
Thanked 0 Times in 0 Posts
Please, forgive my lack of useable info, I started the thread at 1 AM, and I was half asleep,

That being said, It is in fact a C-13 acert, The part in question is the pre cooler and the leak is internal, meaning the coolant is going thru the air intake right into the engine, there is coolant trails from all of the turbo hose connections on both sides of the air charge cooler.

And like I said in the OP, this will be the forth one on the engine in about a month.
claymore1500 is offline   Reply With Quote
Old 08-30-2012, 10:12 AM   #7
C15
Junior Member
 
C15's Avatar
 
Join Date: Jul 2010
Location: Pennysylvania
Posts: 31
Points: 18,503
Thanks: 1
Thanked 8 Times in 7 Posts
precooler bypass valve is not letting coolant flow through,which causes the precooler to overheat ,creating the crack.the bypass valve is the thing that bolts to the side with the solenoid in it.replace that whole unit and it should solve the problem.good luck
C15 is offline   Reply With Quote
The Following User Says Thank You to C15 For this addition to TDG:
claymore1500 (09-07-2012)
Old 08-30-2012, 10:26 PM   #8
claymore1500
Junior Member
Threadstarter
 
claymore1500's Avatar
 
Join Date: Dec 2011
Location: North coast, Ohio
Posts: 9
Points: 12,363
Thanks: 1
Thanked 0 Times in 0 Posts
Quote:
precooler bypass valve is not letting coolant flow through,which causes the precooler to overheat ,creating the crack.the bypass valve is the thing that bolts to the side with the solenoid in it.replace that whole unit and it should solve the problem.good luck
Thank you, I believe the boss took the truck back to the Kenworth dealer where the last cooler was put on, I will check it when it get's back.
claymore1500 is offline   Reply With Quote
Old 09-07-2012, 12:13 AM   #9
claymore1500
Junior Member
Threadstarter
 
claymore1500's Avatar
 
Join Date: Dec 2011
Location: North coast, Ohio
Posts: 9
Points: 12,363
Thanks: 1
Thanked 0 Times in 0 Posts
Quote:
precooler bypass valve is not letting coolant flow through,which causes the precooler to overheat ,creating the crack.the bypass valve is the thing that bolts to the side with the solenoid in it.replace that whole unit and it should solve the problem.good luck
Good call, We had Kenworth check the valve, and they said that it was not working.


Thank you
claymore1500 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OK fuel leak stopped now oil leak Stacked6600 1994-2003 7.3L Power Stroke 7 01-27-2011 03:37 AM
intercooler ?;s Sabbath5.9 5.9L Cummins 12 Valve (1994-1998.5) 15 03-03-2010 05:11 AM
bank intercooler piping(with a stock style intercooler) install question Jjona5 1994-2003 7.3L Chips & Tuners Forum 1 09-13-2009 12:46 PM
intercooler ?s zpd307 7.3L and 6.9 IDI (Pre 1994) 2 04-09-2008 05:07 AM
Oil Leak Or Boost Pressure Leak At Hot Side Charge Air Cooler (cac) Duct PSDPlayer 2003-2007 6.0L Power Stroke 2 01-12-2007 04:17 AM

New To Site? Need Help? TDG Specials

All times are GMT. The time now is 12:36 AM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.
vB.Sponsors
vBCredits v1.4 Copyright ©2007 - 2008, PixelFX Studios