FL70 low air warning alarm - TheDieselGarage.com
TheDieselGarage.com
 

Home Forum Who's Online Today's Posts Vendors Advertise
Go Back   TheDieselGarage.com > Heavy, Medium, Work Trucks and Trailers > Heavy Duty

Thread Details Posted by LlamaKockLee, this thread has received 7 replies and been viewed 3662 times.

TheDieselGarage.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 05-18-2007, 11:23 PM   #1
LlamaKockLee
Junior Member
 
Join Date: Jan 2006
Posts: 7
Points: 269
Thanks: 0
Thanked 0 Times in 0 Posts
FL70 low air warning alarm

Hi Guys,

I seem to have a new issue and was wondering if anybody has had a similar experience. I have a 2001 FL70 with air brakes. The low air buzzer warning alarm is constantly on right now, however the low air indicator (circle with arrows around it) turns off when the pressure is above 70 psi about. Does anybody have any suggestions as to why the buzzer is going off? I have checked both pressure switches on the primary and secondary systems and both close correctly at the specified pressure. The light goes off, but it is just that dang alarm...

any suggestions?

thanks
LlamaKockLee is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-21-2007, 02:10 PM   #2
FordRacing200
Powered By Ford
 
FordRacing200's Avatar
 
Join Date: Jan 2007
Location: Boonville, NY (upstate)
Posts: 2,438
Points: 29,345
Thanks: 72
Thanked 56 Times in 47 Posts
if all else fails you could have the dealer look at it, sorry I couldn't be of any more help :shrug:
__________________
04 Silverado 2500HD LB7/Allison, EFI live by duramaxtuner.com with DSP5, 4" MBRP turbo back straight pipe, polished 5" tip, 5% tint, riding on 285 fierce attitudes, many more mods....
FordRacing200 is offline   Reply With Quote
Old 05-21-2007, 02:29 PM   #3
Duke
'Ol Builder guy
 
Duke's Avatar
 
Join Date: Dec 2008
Posts: 7,051
Points: 53,765
Thanks: 340
Thanked 99 Times in 73 Posts
Check to see if the buzzer itself hasn't grounded-out causing it to buzz all the time. I had a warning light for "water in fuel" on all the time, turns out the wire came off the sender and was grounding itself to nearby sheetmetal!

Let us know what it was when you get it fixed! Good luck!
Duke is offline   Reply With Quote
Old 05-22-2007, 07:07 PM   #4
LlamaKockLee
Junior Member
Threadstarter
 
Join Date: Jan 2006
Posts: 7
Points: 269
Thanks: 0
Thanked 0 Times in 0 Posts
thanks for taking the time to reply guys.


after further diagnosing the issue.. i have concluded that it is somethign in the dash panel that is shorted out and or busted. Unfortunately, taking the dash apart is a little more complicated as I need to get to the frontside of the dash circuit in order to see what drives the buzzer... for that I need to take the entire thing apart including removing the speedometer and tach needles.. something that isn't too easy.

for anybody who is interested, the buzzer can go off for a few reasons.. high engine temp, low oil pressure, parking brake on and speed excess of 2 mph, low air. any engine related issues would also trip the check engine light as well as shut down the engine in 30 seconds which doesn happen in my truck. So for now, i have a new buzzer hardwired to come on whenever the low air indicator comes on.


I asked the service manager and parts guys at freightliner and they agree that if the light goes off, then the (primary and secondary sensors are good) . They would just troubleshoot the wiring (at $105 an hour labor) and would most likely come up with the same conclusion which is a new dash panel @ approx $475 bucks. Of course the service manager would love to see me bring it in ( or at least that's what he says)

If any of you guys have any additional insight or suggestion, I'd be more than happy to hear them...

sorry for the novel.
LlamaKockLee is offline   Reply With Quote
Old 05-22-2007, 08:10 PM   #5
Duke
'Ol Builder guy
 
Duke's Avatar
 
Join Date: Dec 2008
Posts: 7,051
Points: 53,765
Thanks: 340
Thanked 99 Times in 73 Posts
Have you checked to confirm that no wires have come off your sending units and are grounding out?
Duke is offline   Reply With Quote
Old 05-22-2007, 08:55 PM   #6
LlamaKockLee
Junior Member
Threadstarter
 
Join Date: Jan 2006
Posts: 7
Points: 269
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Duke

Yup, I have checked those wires. If any of the wires on the 2 sending unit (primary and secondary) becomes unplugged, the low air indicator light lights up. (assuming that there is enough pressure in the system) If you reconnect them the light goes off, but the buzzer still stays on.

All this assumes that the 2 pressure switches on manifold (one with the 5/32 air tubes running to the dash gauges) behind the dash are the correct ones.. I could be missing something, like a different pressure switch in a different location.

thanks
LlamaKockLee is offline   Reply With Quote
Old 05-23-2007, 01:12 PM   #7
Duke
'Ol Builder guy
 
Duke's Avatar
 
Join Date: Dec 2008
Posts: 7,051
Points: 53,765
Thanks: 340
Thanked 99 Times in 73 Posts
Does the buzzer go "off" if you disconnect the wire for it from the sender?

If that's the case, then I'd guess you have a chaffing of the wire somewhere along the line.....
Duke is offline   Reply With Quote
Old 05-24-2007, 01:24 AM   #8
LlamaKockLee
Junior Member
Threadstarter
 
Join Date: Jan 2006
Posts: 7
Points: 269
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Duke,

Thats the thing... the buzzer never goes off. It is constantly buzzing even though the warning light turns off. It would make sense if there were different pressure sensors for the light and the buzzer, however I don't think there is.

Seems like there is some logic circuit in the dash which looks at different input signals and determines when to turn the buzzer on. Maybe something in the dash circuit itself that is wrong..


thanks
LlamaKockLee is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

New To Site? Need Help? TDG Specials

All times are GMT. The time now is 02:12 PM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.
vB.Sponsors
vBCredits v1.4 Copyright ©2007 - 2008, PixelFX Studios