Coolant Leak - TheDieselGarage.com
TheDieselGarage.com
 

Home Forum Who's Online Today's Posts Vendors Advertise
Go Back   TheDieselGarage.com > Dodge Diesel & Truck Discussion > 5.9L Cummins (2003-2007.5)

Thread Details Posted by Snowaholic, this thread has received 9 replies and been viewed 1320 times.

TheDieselGarage.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 07-09-2007, 04:31 PM   #1
Snowaholic
TDG Mafia - Booze Runner
 
Snowaholic's Avatar
 
Join Date: Jul 2005
Location: Bend, OR
Posts: 3,705
Points: 26,572
Thanks: 137
Thanked 135 Times in 111 Posts
Coolant Leak

Coolant Leak

For the past few weeks I’ve noticed a small puddle under my bell housing, which looked like water condensation that had been dripping…. It has been raining here so much that I really never thought much about it, until Saturday when for once it was dry for a change and I saw the small puddle again. I crawled under the truck to feel the liquid, and it was just a touch sticky, and had a very slight sweet smell to it, but was a very opaque red. Well I traced the moisture to a boot that connects the coolant lines together at the back of the engine just below the Heater Core…


My question is: Is there a better fix for this than getting it warranted? Has anyone else had this issue?
__________________
2007 Dodge 3500 MegaCab Laramie CTD 4x4 Patroit Blue Just a bunch of Go fast parts and programing
Snowaholic is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-09-2007, 09:53 PM   #2
WHITEPOWERstrok
Senior Member
 
Join Date: Dec 2008
Location: Brandon, FL
Posts: 409
Points: 27,971
Thanks: 6
Thanked 8 Times in 7 Posts
i had the same issue! i searched and searched where mine was comin from, but couldnt fine it. mine hasnt done it in a couple weeks, so i dunno....
__________________
2003 Ford F350 FX4 6.0L - 2007 Front Clip
16" Custom Lift/Dual Reservoir shocks/Traction Bars
42x15R20 Swamper SX2's/20x12 black XD Rockstars
Road Armor Stealth front-rear Bumpers/AMP Powersteps
Recon Smoked LED everything/Smoked LED 1 pc Headlights
SCT Xcal3 Tuned by DJ/Josh's 190cc injectors/DJ's Fuel Intensifier
ARP headstuds/Dfuser EGR delete/7" black stack

94 2500 12v - Reg cab 4x4
Wicked Diesel S300-S400 twins/Airdog Fuel pump
DDP fireringed head/DDP injectors/ARP headstuds
ATS manifold/MBRP exhaust/AFE filter
Garmon "whoop azz" trans, and lots more
WHITEPOWERstrok is offline   Reply With Quote
Old 07-17-2007, 01:32 AM   #3
pos dodge
Member
 
Join Date: Jun 2007
Posts: 85
Points: 188
Thanks: 0
Thanked 0 Times in 0 Posts
All you have to do is pressure check the coolant system. It is much easier to find a leak when the system is under pressure. The coolant should spooge everywhere if there is a leak. And if you want to start a leak just keep putting more pressure on the system.
__________________
06 cummins volant intake, ats arcflow, autometer gauges, banks cat back exhaust. mag hytec transmission pan, transgo shift kit, boost fooler, triple dog, 33 12.50 trxus sts, leveling kit, optional turbo silencer ring, fass system, VA C5.

ATS exhaust manifold and fluid damper coming this week.
pos dodge is offline   Reply With Quote
Old 11-12-2007, 02:14 PM   #4
chad_schieck
cschieck2002
 
Join Date: Nov 2007
Posts: 1
Points: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to chad_schieck
Question

Anymore to this Thread. My brother has an 07 Mega Cab with 15k on it that has just learned this trick. Had to add about 2 gallons of antifreeze in the last 2.5 months. The leak is intermitant. Just curious if I should be looking for other problems as well. He says there is no loss of power or blowing white smoke or anything like that.

Thanks for the help- this is my first post on this forum.
__________________
2000 F350 Crew Cab, Automatic, 6.5" Pro Comp lift, dual front shocks, dual front steering stailizers, 315x75x16 BFG AT KO, 16x10 black Helo Maxx 6 rims, 3" ATS fender flares, 3.73 stock gears, 5" turbo back exhaust w/ straight pipe, Zoodad, Cold Air Intake, Edge Juice w/ Attitude monuted on A Pillar stacked with Edge Evolution Programmer, Cyberdyne tranny temp guage on pillar.
chad_schieck is offline   Reply With Quote
Old 11-12-2007, 02:40 PM   #5
WHITEPOWERstrok
Senior Member
 
Join Date: Dec 2008
Location: Brandon, FL
Posts: 409
Points: 27,971
Thanks: 6
Thanked 8 Times in 7 Posts
i figured out that mine was the water pump, so the dealership replaced it under warranty...
__________________
2003 Ford F350 FX4 6.0L - 2007 Front Clip
16" Custom Lift/Dual Reservoir shocks/Traction Bars
42x15R20 Swamper SX2's/20x12 black XD Rockstars
Road Armor Stealth front-rear Bumpers/AMP Powersteps
Recon Smoked LED everything/Smoked LED 1 pc Headlights
SCT Xcal3 Tuned by DJ/Josh's 190cc injectors/DJ's Fuel Intensifier
ARP headstuds/Dfuser EGR delete/7" black stack

94 2500 12v - Reg cab 4x4
Wicked Diesel S300-S400 twins/Airdog Fuel pump
DDP fireringed head/DDP injectors/ARP headstuds
ATS manifold/MBRP exhaust/AFE filter
Garmon "whoop azz" trans, and lots more
WHITEPOWERstrok is offline   Reply With Quote
Old 11-12-2007, 06:00 PM   #6
Fiftygrit
Member
 
Join Date: Oct 2005
Posts: 91
Points: 305
Thanks: 0
Thanked 5 Times in 5 Posts
There is a common leak on the small hose, left hand side under the hood, heater hose I think, there is a small fitting, rubber hose off of a hard pipe, the clamps get loose and they leak, mine did it, and from all the forums, lots of them do it, try there first, feel around the connection if its wet, just snug up the clamps, stopped mine from leaking.
Fiftygrit is offline   Reply With Quote
Old 11-12-2007, 10:14 PM   #7
Snowaholic
TDG Mafia - Booze Runner
Threadstarter
 
Snowaholic's Avatar
 
Join Date: Jul 2005
Location: Bend, OR
Posts: 3,705
Points: 26,572
Thanks: 137
Thanked 135 Times in 111 Posts
I had the dealer fix it when they replaced my tranny. They said the same thing. I'm keeping an eye on it to see if it does it again. So far so good...
__________________
2007 Dodge 3500 MegaCab Laramie CTD 4x4 Patroit Blue Just a bunch of Go fast parts and programing
Snowaholic is offline   Reply With Quote
Old 11-12-2007, 11:23 PM   #8
catdude
Senior Member
 
Join Date: Feb 2007
Posts: 127
Points: 1,436
Thanks: 0
Thanked 0 Times in 0 Posts
I have 16k on mine and have the same leak on the little hose that connects the heater tubes issed:
__________________
07 Dodge 5.9 3500 DRW 4x4 QC 6spd:93C_peelo With a few mods.
catdude is offline   Reply With Quote
Old 11-13-2007, 05:48 PM   #9
Snowaholic
TDG Mafia - Booze Runner
Threadstarter
 
Snowaholic's Avatar
 
Join Date: Jul 2005
Location: Bend, OR
Posts: 3,705
Points: 26,572
Thanks: 137
Thanked 135 Times in 111 Posts
Quote:
Originally Posted by catdude
I have 16k on mine and have the same leak on the little hose that connects the heater tubes issed:
Mine was the bottom band clamp....
__________________
2007 Dodge 3500 MegaCab Laramie CTD 4x4 Patroit Blue Just a bunch of Go fast parts and programing
Snowaholic is offline   Reply With Quote
Old 11-14-2007, 10:09 PM   #10
SarahB
Member
 
Join Date: Sep 2007
Posts: 62
Points: 636
Thanks: 0
Thanked 0 Times in 0 Posts
Mine Too!

I found that mine only did it intermitten, but it was also the loose clamp.
__________________
Sarah
SarahB is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

New To Site? Need Help? TDG Specials

All times are GMT. The time now is 08:35 PM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.
vB.Sponsors
vBCredits v1.4 Copyright ©2007 - 2008, PixelFX Studios