Oil Pressure Sensor Location - TheDieselGarage.com
TheDieselGarage.com
 

Home Forum Who's Online Today's Posts Vendors Advertise
Go Back   TheDieselGarage.com > Ford Diesel & Truck Discussions > 2003-2007 6.0L Power Stroke

Thread Details Posted by 04lariatfx4crewcab, this thread has received 8 replies and been viewed 10626 times.

TheDieselGarage.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 07-07-2009, 05:03 PM   #1
04lariatfx4crewcab
Junior Member
 
04lariatfx4crewcab's Avatar
 
Join Date: May 2009
Location: Guadalupe River State Park, Texas
Posts: 373
Points: 28,465
Thanks: 75
Thanked 19 Times in 17 Posts
Oil Pressure Sensor Location

Ok, I give up. I can not find where the oil pressure sensor is located on my truck. I am still trying to figure this diesel thing out. Does anyone have a picture of where this sensor is located?

Thank you
__________________
Jakob

2004 5.9L/47rh Lariat FX4 Crew Cab Short bed. 213K miles 18" dbacks with nitto A/T grapplers, Zoodad mod, and 2000 turn signal mod. Limited Excursion bumpers front and back. Chrome grill, EGR delete, FICM delete, glow plug delete, HPOP delete, 2 cylinders delete, and 20 valves deleted

97 12v/47rh built by Garmon's



04lariatfx4crewcab is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-07-2009, 05:46 PM   #2
hpprose
Senior Member
 
hpprose's Avatar
 
Join Date: Feb 2007
Posts: 387
Points: 26,928
Thanks: 6
Thanked 82 Times in 54 Posts
Images: 2
The sensor for the low pressure is right next to the oil filter housing.

The sensor for the high pressure oil is on the passengers side valve cover right next to the glow plug controller (on 04's and newer)
__________________
My life is like my license plate.

Everything is right side up, but feels upside down.
hpprose is offline   Reply With Quote
Old 07-07-2009, 07:35 PM   #3
04lariatfx4crewcab
Junior Member
Threadstarter
 
04lariatfx4crewcab's Avatar
 
Join Date: May 2009
Location: Guadalupe River State Park, Texas
Posts: 373
Points: 28,465
Thanks: 75
Thanked 19 Times in 17 Posts
Thanks hpprose.

There are two?
wich one is for the oil pressure guage on the dash?
Also are they the same part number because I can only find one part number for an oil sensor it is F81Z-9278-AA.

Thanks for the reply.
__________________
Jakob

2004 5.9L/47rh Lariat FX4 Crew Cab Short bed. 213K miles 18" dbacks with nitto A/T grapplers, Zoodad mod, and 2000 turn signal mod. Limited Excursion bumpers front and back. Chrome grill, EGR delete, FICM delete, glow plug delete, HPOP delete, 2 cylinders delete, and 20 valves deleted

97 12v/47rh built by Garmon's



04lariatfx4crewcab is offline   Reply With Quote
Old 07-07-2009, 09:23 PM   #4
hpprose
Senior Member
 
hpprose's Avatar
 
Join Date: Feb 2007
Posts: 387
Points: 26,928
Thanks: 6
Thanked 82 Times in 54 Posts
Images: 2
Quote:
Originally Posted by hpprose View Post
The sensor for the low pressure is right next to the oil filter housing.

The sensor for the high pressure oil is on the passengers side valve cover right next to the glow plug controller (on 04's and newer)
The oil pressure gauge on your dash uses the sensor by the oil filter housing.



The sensor on the passengers side valve cover is the ICP which reads injection control pressure.
__________________
My life is like my license plate.

Everything is right side up, but feels upside down.
hpprose is offline   Reply With Quote
The Following User Says Thank You to hpprose For this addition to TDG:
04lariatfx4crewcab (07-08-2009)
Old 07-08-2009, 01:15 AM   #5
cb44473
Member
 
Join Date: Dec 2008
Posts: 169
Points: 3,178
Thanks: 1
Thanked 68 Times in 48 Posts
the oil pressure switch is the one with the single wire. the other with two wires is the oil temperature sensor. they are both located by the oil filter housing and screw into the oil cooler. the connector for the switch is black and the connector for the temp is grey. if you want the switch the part number you listed is correct. why are you wanting to change the switch.
__________________
Ford Diesel Engine Master Certified
Ford Senior Master Certified
Dodge Cummins Level 4 Certified
Cummins Certified
cb44473 is offline   Reply With Quote
The Following User Says Thank You to cb44473 For this addition to TDG:
04lariatfx4crewcab (07-08-2009)
Old 07-08-2009, 02:35 AM   #6
04lariatfx4crewcab
Junior Member
Threadstarter
 
04lariatfx4crewcab's Avatar
 
Join Date: May 2009
Location: Guadalupe River State Park, Texas
Posts: 373
Points: 28,465
Thanks: 75
Thanked 19 Times in 17 Posts
cb44473,
I just want to check the sensor see if it is working correctly or if the wire might be shorting or loose I keep getting a check guage light and the oil pressure guage dies some times it dies for a few seconds sometimes only a split second. the truck does not die no matter how long the guage is dead. it only ever happens when I slow for a stop. if I press the vertical pedal it will come back to life. I just want to make sure it is not the sensors or something easy before I tear into it looking for an HPOP problem.

Thanks for the reply.
__________________
Jakob

2004 5.9L/47rh Lariat FX4 Crew Cab Short bed. 213K miles 18" dbacks with nitto A/T grapplers, Zoodad mod, and 2000 turn signal mod. Limited Excursion bumpers front and back. Chrome grill, EGR delete, FICM delete, glow plug delete, HPOP delete, 2 cylinders delete, and 20 valves deleted

97 12v/47rh built by Garmon's



04lariatfx4crewcab is offline   Reply With Quote
Old 07-08-2009, 05:02 AM   #7
hpprose
Senior Member
 
hpprose's Avatar
 
Join Date: Feb 2007
Posts: 387
Points: 26,928
Thanks: 6
Thanked 82 Times in 54 Posts
Images: 2
When mine started doing that, my sensor had a small hole and it was filling the wiring up with oil.
__________________
My life is like my license plate.

Everything is right side up, but feels upside down.
hpprose is offline   Reply With Quote
Old 07-08-2009, 06:04 AM   #8
4play
Senior Member
 
4play's Avatar
 
Join Date: Dec 2008
Location: norman, ok
Posts: 1,700
Points: 28,060
Thanks: 55
Thanked 387 Times in 342 Posts
Quote:
Originally Posted by 04lariatfx4crewcab View Post
cb44473,
I just want to check the sensor see if it is working correctly or if the wire might be shorting or loose I keep getting a check guage light and the oil pressure guage dies some times it dies for a few seconds sometimes only a split second. the truck does not die no matter how long the guage is dead. it only ever happens when I slow for a stop. if I press the vertical pedal it will come back to life. I just want to make sure it is not the sensors or something easy before I tear into it looking for an HPOP problem.

Thanks for the reply.
your on the right track going after the sender, remember though its just a single wire switch with a brown/orange stripe wire. these senders are notorius for what you explained. this sender only indicates "low" pressure and not actual oil pressure. its basically and idiot light but with a guage. with normal oil pressure the sender grounds the wire to indicate good oil pressure and turn the light off. If you have a wiring concern you need to look for an open circuit. but i bet you will be fixed with a new sender/switch.
4play is offline   Reply With Quote
The Following User Says Thank You to 4play For this addition to TDG:
04lariatfx4crewcab (07-08-2009)
Old 07-08-2009, 01:07 PM   #9
04lariatfx4crewcab
Junior Member
Threadstarter
 
04lariatfx4crewcab's Avatar
 
Join Date: May 2009
Location: Guadalupe River State Park, Texas
Posts: 373
Points: 28,465
Thanks: 75
Thanked 19 Times in 17 Posts
Thanks 4play. I will be checking the sender/switch. I hope that solves my problem.
__________________
Jakob

2004 5.9L/47rh Lariat FX4 Crew Cab Short bed. 213K miles 18" dbacks with nitto A/T grapplers, Zoodad mod, and 2000 turn signal mod. Limited Excursion bumpers front and back. Chrome grill, EGR delete, FICM delete, glow plug delete, HPOP delete, 2 cylinders delete, and 20 valves deleted

97 12v/47rh built by Garmon's



04lariatfx4crewcab is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cat 3116e: Fuel Temp Sensor & Boost Pressure Sensor probablecause Medium Duty 0 02-03-2009 01:54 AM
EGT sensor location......... bwanajim 7.3L and 6.9 IDI (Pre 1994) 4 01-21-2008 06:03 AM
EGT sensor location........ bwanajim 7.3L and 6.9 IDI (Pre 1994) 0 01-20-2008 08:35 PM
Baro Sensor location? Pat M 2003-2007 6.0L Power Stroke 5 12-22-2007 02:44 PM
Boost sensor location killerbee Duramax 2004.5-2005(LLY) 8 10-19-2006 04:35 PM

New To Site? Need Help? TDG Specials

All times are GMT. The time now is 07:13 PM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.
vB.Sponsors
vBCredits v1.4 Copyright ©2007 - 2008, PixelFX Studios