Diesel Truck Forum - TheDieselGarage.com - View Single Post - Troybilt Briggs & Stratton generator
View Single Post
post #1 of (permalink) Old 01-26-2014, 03:30 PM Thread Starter
Weld engineer
Senior Member
 
Weld engineer's Avatar
 
Join Date: Apr 2012
Location: Middle of the Mitten, MI
Posts: 1,324
Points: 48,500
Thanks: 866
Thanked 506 Times in 401 Posts
Garage
Troybilt Briggs & Stratton generator

Just some info to help someone else from experiencing my frustration.

I have a 10HP B&S 5550W generator I use as backup for my house. Owned it now for about 10 years and it really is only used for backup if needed. I try to start and run it every 4-6 months just to make sure it is good to go when needed. We recently had some power outages in the area so I did my normal functionality test and of course it wouldn't start.

The generator has less than 25 hours on it so everything is pretty new in service hours. I always figured it was fuel related since our gas these days is junk pretty fast.

So I started to work and diagnose the basic issues.

I narrowed down that it didn't have any spark so no matter if there was a fuel or carb issue that didn't matter.

Did the usual put a new plug in but still no spark so I started tearing it apart to investigate.

The engine has a switch for oil level to shut down in the case it runs low on oil so I figured it may be related to that. I unplugged the sensor and still no spark. Must be the coil I thought so I bought a new one still nothing.

Getting pretty frustrated at that point so like all hobby mechanics pulled out the manual from the file cabinet (thanks to my wife the great organizer) and discovered hidden under the cover for the kill switch is a little module that the oil switch connects to THEN goes to the kill switch.

It is hidden and would never think the oil switch is connected to a little module with a small electronics board with several capacitors, resistors and such potted in an aluminum housing (I destructively inspected it with screwdriver and saw) Once I disconnected the little module - nice hot spark.

So I bought a new one on line and she starts again on the first pull just like when new. Too bad I took a hit on the coil since I couldn't return it. Someone on ebay got a heck of a deal.
Attached Thumbnails
Click image for larger version

Name:	IMG_2539.JPG
Views:	212
Size:	83.0 KB
ID:	34233   Click image for larger version

Name:	IMG_2540.JPG
Views:	210
Size:	103.1 KB
ID:	34241   Click image for larger version

Name:	IMG_2541.JPG
Views:	354
Size:	107.1 KB
ID:	34249  

Early 2004 F-250 4x4 CC 6.0


2nd owner, ARP studs 1 at a time, Some parts missing in the exhaust path, BD intercooler hoses, Blue spring, MC filters, Sinister coolant filter, Exhaust manifold gaskets, WARN lockouts, Gold coolant, zoodad mod, autometer boost gauge, high idle mod, Scangauge 2, SCT X3 tuned from KEM, autometer fuel pressure gauge, Archoil 6200 in the fuel, FICM by Ed w/ATLAS40, autometer pyro gauge,'08 Alum Rear Diff cover, 5w-40 Rotella T6 w/ Archoil 9100 in it, zert in the slip joint, harpooned fuel tank, 6.4 banjos


Not a diesel mechanic in real life but I play one on the Internet
Weld engineer is offline  
 
 
For the best viewing experience please update your browser to Google Chrome