Speedo quit - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by RWS31, this thread has received 10 replies and been viewed 1633 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 09-24-2009, 10:29 PM Thread Starter
Senior Member
 
RWS31's Avatar
 
Join Date: Dec 2008
Location: Cent Fl
Posts: 378
Points: 59,404
Thanks: 30
Thanked 42 Times in 30 Posts
Speedo quit

Went to leave work this morning and noticed that my speedo was not working and my ABS light and the BRAKE light were both lit up. Later the CHECK ENGINE light came on. Thinking it might be the speedo sensor in the trans, anybody ever seen this before? 2000 1500 4x4 318. Any help would be appreciated.

1999 4700 Started life as a reg chassis, then got dropped 4 inches and then raised 6 inches and 4X4 added and now in the Med duty 4X4 club.
Marmon Herrington 8000lb front axle and transfer case
TS Box
385/65/22.5 Goodyears on 22.5X12.25 Alcoas
Custom bed in the works
RWS31 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 09-25-2009, 01:52 AM
TDG Mafia
 
Jeffybuilt's Avatar
 
Join Date: Dec 2008
Location: North Liberty, IN
Posts: 651
Points: 21,983
Thanks: 162
Thanked 76 Times in 57 Posts


Quote:
Originally Posted by RWS31 View Post
Thinking it might be the speedo sensor in the trans.
Yes, although I have not seen it throw a CEL...but that was on my 2500. Sometimes (not always) the sensor in the trans gets covered in small metal shavings, as it is magnetic. Before you replace it, try pulling it and cleaning the metal off first. You may need to clear the codes since it set a CEL, but often times (again, from my experience with the RWL speed sensor on the 3/4 ton) the BRAKE and ABS lights should go off after driving a short distance.

My truck wants to be a semi when it grows up...
Singles Club #247

TDG Mafia Member


Thanks To:

Certified Transmission, Mishawaka, IN
http://www.certifiedtransmissiononline.com/home-6.html

State Line Diesel, Edwardsburg, MI
(269) 663-8571
Jeffybuilt is offline  
post #3 of 11 (permalink) Old 09-25-2009, 04:11 AM
Senior Member
 
4play's Avatar
 
Join Date: Dec 2008
Location: norman, ok
Posts: 1,700
Points: 41,526
Thanks: 55
Thanked 387 Times in 342 Posts
what he said above, but i am not sure about the 1/2 tons, if it has a sensor right in the top of the rear axle then that is probable the speed sensor for the speedo and ABS. usually the sensor in the trans is just for the trans shift op.

My motto: Be nice, be polite, but have have a plan to kill everyone that you meet.

94 F250 IDI turbo, auto 2wd.. ATS housing, 3" down, 4" exh, guages. 104k miles got totalled by a damn mustang (parts now).

98 12v, 4x4 quad cab. auto with BD T/C & V/B, Banks Big head, Exh brake, AFC modded, 16.5ish*, KDP gone, 60lb springs, 4K-GSK, BHAF, pyro, trans, and boost guages. 4" straight pipe,

72 AM General M35A2, LDT465-1C "Whistler" Turbo, PTO winch.
4play is offline  
post #4 of 11 (permalink) Old 09-25-2009, 04:19 AM
TDG Mafia
 
Jeffybuilt's Avatar
 
Join Date: Dec 2008
Location: North Liberty, IN
Posts: 651
Points: 21,983
Thanks: 162
Thanked 76 Times in 57 Posts


Quote:
Originally Posted by 4play View Post
what he said above, but i am not sure about the 1/2 tons, if it has a sensor right in the top of the rear axle then that is probable the speed sensor for the speedo and ABS. usually the sensor in the trans is just for the trans shift op.
Yea, I have a 1997 1/2 ton in addition to the Cummins, and the 1/2 ton dose not have a sensor in the rear end. I dont know about the newer one, like his 2000, but my 1/2ton only has the trans one. When the BRAKE and ABS lights were on in the 2500, it was my rear end speed sensor, like you said. Humm, let us know what you find out!

My truck wants to be a semi when it grows up...
Singles Club #247

TDG Mafia Member


Thanks To:

Certified Transmission, Mishawaka, IN
http://www.certifiedtransmissiononline.com/home-6.html

State Line Diesel, Edwardsburg, MI
(269) 663-8571
Jeffybuilt is offline  
post #5 of 11 (permalink) Old 09-25-2009, 09:43 AM Thread Starter
Senior Member
Threadstarter
 
RWS31's Avatar
 
Join Date: Dec 2008
Location: Cent Fl
Posts: 378
Points: 59,404
Thanks: 30
Thanked 42 Times in 30 Posts
Thanks for the info. I read somewhere else that the sensor in the rear axle is most likely the cause. Will pick one up today and post the results.

1999 4700 Started life as a reg chassis, then got dropped 4 inches and then raised 6 inches and 4X4 added and now in the Med duty 4X4 club.
Marmon Herrington 8000lb front axle and transfer case
TS Box
385/65/22.5 Goodyears on 22.5X12.25 Alcoas
Custom bed in the works
RWS31 is offline  
post #6 of 11 (permalink) Old 09-28-2009, 10:29 PM Thread Starter
Senior Member
Threadstarter
 
RWS31's Avatar
 
Join Date: Dec 2008
Location: Cent Fl
Posts: 378
Points: 59,404
Thanks: 30
Thanked 42 Times in 30 Posts
Bingo, that was the problem. Replaced the sensor on top of the rear diff and all the lights went out and the speedo is working. Gosh I love the internet.

1999 4700 Started life as a reg chassis, then got dropped 4 inches and then raised 6 inches and 4X4 added and now in the Med duty 4X4 club.
Marmon Herrington 8000lb front axle and transfer case
TS Box
385/65/22.5 Goodyears on 22.5X12.25 Alcoas
Custom bed in the works
RWS31 is offline  
post #7 of 11 (permalink) Old 09-30-2009, 06:21 AM
Senior Member
 
4play's Avatar
 
Join Date: Dec 2008
Location: norman, ok
Posts: 1,700
Points: 41,526
Thanks: 55
Thanked 387 Times in 342 Posts

My motto: Be nice, be polite, but have have a plan to kill everyone that you meet.

94 F250 IDI turbo, auto 2wd.. ATS housing, 3" down, 4" exh, guages. 104k miles got totalled by a damn mustang (parts now).

98 12v, 4x4 quad cab. auto with BD T/C & V/B, Banks Big head, Exh brake, AFC modded, 16.5ish*, KDP gone, 60lb springs, 4K-GSK, BHAF, pyro, trans, and boost guages. 4" straight pipe,

72 AM General M35A2, LDT465-1C "Whistler" Turbo, PTO winch.
4play is offline  
post #8 of 11 (permalink) Old 10-09-2009, 02:04 PM
SIXINAROWMAKES'EMGO
 
yoder519's Avatar
 
Join Date: Jun 2009
Location: Abingdon, VA
Posts: 271
Points: 25,314
Thanks: 36
Thanked 9 Times in 9 Posts
Quote:
Originally Posted by RWS31 View Post
Bingo, that was the problem. Replaced the sensor on top of the rear diff and all the lights went out and the speedo is working. Gosh I love the internet.
how much did that run you i fyou don tmind em askin. di dyou buy it at the dealership

07 Chevy 2500HD 4wd RCLB (FOR SALE)
95 Toyota on 37s

SOLD-98 ECSB 24V
yoder519 is offline  
post #9 of 11 (permalink) Old 10-09-2009, 04:20 PM
Junior Member
 
Ton Or None's Avatar
 
Join Date: Dec 2008
Location: Lakeland, Michigan
Posts: 28
Points: 520
Thanks: 0
Thanked 0 Times in 0 Posts
My ABS and brake light are on but my speedo works do you think that the sensor in the rear end is the problem?

1997 12V 3500 XCab Long Box Dually , 4'' down pipe, 5'' dual stacks, 100 plate, AFC FF, Gov springs tightened for now, HTS Trans, BHAF, 35'' tires with Alcoa wheels, 5'' lift, train horns.
Ton Or None is offline  
post #10 of 11 (permalink) Old 10-09-2009, 05:34 PM
Senior Member
 
PhilipR's Avatar
 
Join Date: Jun 2007
Location: Massillon, OH
Posts: 1,465
Points: 28,387
Thanks: 95
Thanked 166 Times in 142 Posts
Send a message via Yahoo to PhilipR
There is a good chance it is...I would pull it and clean it in your case. I think they are around 30-40 new from Napa.

-Phil-
98 2500 4x4,12V,47RE Suncoast Billet input shaft, Suncoast H/D Extreme Trans kit, Goerend Triple disc converter, FASS 150/90, FASS Suction tube, Amsoil Ea air and pre-filter, 100 plate, 4K GSK, 370's, AFC Mods, CoolerTubz intake, straight piped 4" DP to 5" stacks, BD-SBS, Autometer Z-series Pyro/Boost/Trans/FP, Amsoil Bypass system and Amsoil fluids bumper to bumper.
PhilipR is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Quit dipping Diesel Dog The Parking Lot 57 03-26-2009 10:02 AM
AC quit at 30k crosstx General Ford Truck and Excursion 4 01-19-2009 10:50 PM
want to quit my job RussK The Parking Lot 39 01-08-2009 10:51 PM
A/C quit working NCR 2003-2007 6.0L Power Stroke 4 03-20-2007 02:29 PM
I quit!!!! LargeCar The Parking Lot 3 10-27-2006 04:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome