Diesel Truck Forum - TheDieselGarage.com - View Single Post - 03 f550 no power at higher rpm
View Single Post
post #2 of (permalink) Old 04-09-2014, 01:32 AM
IdahoF350
Stuck in Commiefornia...
 
IdahoF350's Avatar
 
Join Date: Dec 2008
Location: Clearfield, Utah
Posts: 1,296
Points: 81,522
Thanks: 102
Thanked 447 Times in 315 Posts
Garage
Ok, so you're saying you're maintaining 2500rpm but the truck will slow from 70 to 5mph? There is something wrong with the transmission or the PCM or both. Have you checked the fluid level? Do you know much about the truck, like how many miles, could it have been services with the wrong fluid? The truck should have a trans temp gauge in the cluster. Also, there should be a check engine light on in the cluster. Pull codes with your SCT device from the truck in your signature, engine light of not.

The Current Truck (Oct-2013 to Present):
1999 (Early) F-350 Lariat, CCLB, SRW, Black/Tan

7.3L Powerstroke, 4R100, 4x4, 3.73, 37x13.50-18s, '05 Axle Swap, 6" Fabtech lift, GTP38 "D66" turbo upgrade, SCT 4-position chip with custom tuning by me, Straight Piped 4" down pipe through 5" dual stacks, N-Fab full length triple steps, Pro-Tech cab guard and tool box, louvered 5th wheel gate, Hella 500 Fog and Driving lamps, much more to come...
The one I'll miss, (Mar-2009 to Jan-2014):
2000 Excursion XLT 4x4

6.8L V-10, 4R100, 4.30, 285/75-18, 271whp / 388wtq
The one I won't, (Jul-2005 to Sep-2012):
2005 F-350 XLT, CCLB, SRW, 4x4 FX4

6.0L PSD, ZF-6S650, 3.73, 35x12.5-18, 4.5" Lift
IdahoF350 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome