Edge Comp Bugs? - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by JMeier, this thread has received 10 replies and been viewed 3127 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 06-25-2010, 01:03 PM Thread Starter
Junior Member
 
Join Date: Apr 2009
Posts: 7
Points: 638
Thanks: 5
Thanked 0 Times in 0 Posts
Edge Comp Bugs?

About three months after I installed an edge comp I was driving to work and the petal went dead. This lasted about 5 seconds and then the truck sputtered the CEL came on and the truck went to running fine. Over a period of three months this would happen periodically, and each time the CEL light would go off on its own after two or three cycles. The other night I was driving home and the lift pump quit running. My fuel pressure dropped to zero and I limped the truck home (less than 1/8 mile). The next morning I unplugged the comp and everything has been running fine since. I bought the comp box used so I dont know anything about it. Has anyone else had this happen?

2001 3500 Dually Flatbed, 24v 5 speed, 3.55 gears.
JMeier is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 06-25-2010, 01:26 PM
milkin cowboy
 
MILKINGCOWBOY's Avatar
 
Join Date: Aug 2007
Location: HEBRON, CT
Posts: 182
Points: 36,329
Thanks: 10
Thanked 12 Times in 12 Posts
Send a message via AIM to MILKINGCOWBOY
sounds like an bad apps or more likely with the lift pump gone an injection pump. Could also be the Edge like you said but I would lean towards the vp44 goin,good luck

2002 3500 6 speed ex. cab 4x4 custom flatbed farm truck 9,120 lbs. light weight ALL WAYS HAULIN HAY, CATTLE OR A-$-$!!!! BHAF,4" OPEN STACKS,EDGE JUICE WITH ATTITUDE, AIR DOG II 100,SOUTH BEND CLUTCH
1982 IH Transtar Eagle 4370 turned up 400 Cummins big cam, straight 6" bull haulers one hell of a
Jake and 13 speed od

White 2-105 tractor with 354 Perkins
White 2-135 tractor with 478 White/Hercules

KEEP ON KEEPIN ON

SUPPORT AMERICAS DAIRY FARMS

http://i17.tinypic.com/4u2drv8.jpg


http://profile.myspace.com/index.cfm...ndid=137814954


MILKINGCOWBOY is offline  
The Following User Says Thank You to MILKINGCOWBOY For this addition to TDG:
JMeier (06-25-2010)
post #3 of 11 (permalink) Old 06-25-2010, 03:48 PM
Senior Member
 
Join Date: Jan 2009
Location: Shingletown ca
Posts: 1,189
Points: 50,950
Thanks: 4
Thanked 63 Times in 59 Posts
Garage
if you have the factory lift pump they will do that work and not work etc. I would get a better lift pump before your left buying a better lift pump and a vp44. the apps can do crazy things when they start going out. Mine went out I would be driving along in cruise and the truck would slow down speed up slow down really quick it was a fun drive home.

01 quad cab 4x4, edge drag comp, 4" exhaust, fass 150, 250 ddps, Jefferson State compounds 683hp so vp 11.91. AMSOIL front to rear. now back to stock 95 fummins in the works
01quadcab is offline  
The Following User Says Thank You to 01quadcab For this addition to TDG:
JMeier (06-25-2010)
post #4 of 11 (permalink) Old 06-25-2010, 07:17 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Apr 2009
Posts: 7
Points: 638
Thanks: 5
Thanked 0 Times in 0 Posts
Spoke too soon!!!!!

FML!! I spoke too soon. I was driving home from work and the same thing happened again. The truck stalled at idle for 5 seconds and then came back to life and the CEL came on. This time it did it twice in less than 10 minutes. My fuel pressure never dropped. I whipped into autozone and had the codes read and P0121 came up. They only wanted $411 for the throttle position sensor. Any recommendations on where to buy one cheaper? Is this a complicated procedure? Thanks for the help so far!

2001 3500 Dually Flatbed, 24v 5 speed, 3.55 gears.
JMeier is offline  
post #5 of 11 (permalink) Old 06-25-2010, 07:24 PM
Senior Member
 
JLWelding's Avatar
 
Join Date: Dec 2008
Posts: 214
Points: 38,544
Thanks: 9
Thanked 11 Times in 11 Posts
Get your apps from Timbo approx. 165.00

My truck: 01 Dully - Skirted Flatbed Welding Trk - SA 200 Lincoln - Weight 9900 - Edge Ez - Boost Elbow - Pricol Optix -Fuel - Boost - Egt Gauges - Bhaf - 5 Inch Diamond Eye - Airdog 100 - Two Stroke Oil - RV 275 Injectors - BD Intake - Amsoil - Southbend Clutch - Grid Heater MIA - 224k - Heaviest Load 32900k - jlweldingtx.com
JLWelding is offline  
The Following User Says Thank You to JLWelding For this addition to TDG:
JMeier (06-25-2010)
post #6 of 11 (permalink) Old 06-25-2010, 08:21 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Apr 2009
Posts: 7
Points: 638
Thanks: 5
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by JLWelding View Post
Get your apps from Timbo approx. 165.00
Thanks! Got one on its way!! And thanks to mopar1973man and his insight on his site!

2001 3500 Dually Flatbed, 24v 5 speed, 3.55 gears.
JMeier is offline  
post #7 of 11 (permalink) Old 06-26-2010, 03:38 AM
2nd Gen Guru
 
Mopar1973Man's Avatar
 
Join Date: Dec 2008
Location: New Meadows, Idaho
Posts: 2,641
Points: 54,791
Thanks: 9
Thanked 140 Times in 131 Posts
Garage
Send a message via Yahoo to Mopar1973Man
Thanks...

But there is only 2 things that cause dead pedal...

1. Bad/failing APPS
2. Bad/failing VP44

But the answer is just as close a OBD II scanner away... Just check the error codes and the code will tell you the story...

Michael Nelson - 2002 Dodge Cummins & 1996 Dodge Ram 5.9L Gasser
116K Miles On My VP44 - 4 Years of 2 Cycle Oil Diet! - Mixed at 128:1 Ratio - 25.3 MPG maxed out!
Mopar1973Man is offline  
post #8 of 11 (permalink) Old 06-28-2010, 11:15 AM
Junior Member
 
Join Date: Jan 2009
Posts: 71
Points: 20,635
Thanks: 7
Thanked 3 Times in 3 Posts
Quote:
Originally Posted by Mopar1973Man View Post
Thanks...

But there is only 2 things that cause dead pedal...

1. Bad/failing APPS
2. Bad/failing VP44

But the answer is just as close a OBD II scanner away... Just check the error codes and the code will tell you the story...
You have forgotten more than I will ever know about this truck but; I recently got back from another four thousand mile trip and my third Edge problem. The truck coasted to a stop still running but would not respond to the throttle. After disconnecting the Edge and the negative battery cables I got it back on the road. This is like I said problem number three and also my second Edge because they replaced it once at no cost to me. The thing that all three issues had in common is many hours of driving in hot conditions with the A/C on and not ever shutting it down on stops. So the plan is to send it in again and then relocate the control box where it cant get heat soaked . I like my Edge but if it happens again after that I am done!
road runner is offline  
post #9 of 11 (permalink) Old 07-02-2010, 12:17 AM
Senior Member
 
Join Date: Jan 2009
Location: Shingletown ca
Posts: 1,189
Points: 50,950
Thanks: 4
Thanked 63 Times in 59 Posts
Garage
Quote:
Originally Posted by road runner View Post
You have forgotten more than I will ever know about this truck but; I recently got back from another four thousand mile trip and my third Edge problem. The truck coasted to a stop still running but would not respond to the throttle. After disconnecting the Edge and the negative battery cables I got it back on the road. This is like I said problem number three and also my second Edge because they replaced it once at no cost to me. The thing that all three issues had in common is many hours of driving in hot conditions with the A/C on and not ever shutting it down on stops. So the plan is to send it in again and then relocate the control box where it cant get heat soaked . I like my Edge but if it happens again after that I am done!
this is where the comp box is better it's inside the truck not under the hood. I like my comp way more than I did my juice. hopefully by next weekend my truck should be 7xx doing a few more mods but keeping the factory so pump

01 quad cab 4x4, edge drag comp, 4" exhaust, fass 150, 250 ddps, Jefferson State compounds 683hp so vp 11.91. AMSOIL front to rear. now back to stock 95 fummins in the works
01quadcab is offline  
The Following User Says Thank You to 01quadcab For this addition to TDG:
road runner (07-03-2010)
post #10 of 11 (permalink) Old 07-03-2010, 11:11 AM
Junior Member
 
Join Date: Jan 2009
Posts: 71
Points: 20,635
Thanks: 7
Thanked 3 Times in 3 Posts
Ya in the cab is what I was thinking this time around. If that won't solve the problem a different system is not out of the question. I know that if I give up on the Edge;I will miss the 2-4 mpg and the throttle response- that just seems nicer to drive than stock.
road runner is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
edge comp or edge juice w/attidue fitz1985 5.9L Cummins (1998.5-2002) 13 10-03-2007 01:43 AM
Edge comp STROKER SMOKER 5.9L Cummins (1998.5-2002) 4 07-03-2007 08:19 PM
Edge Drag Comp vs. Edge Juice/Attitude lbdodge24v 5.9L Cummins (1998.5-2002) 12 03-08-2007 08:31 PM
edge juice and edge comp??? masonjo 24 Valve Performance 19 01-23-2007 11:51 PM
stacked my edge comp with my drag comp today, it hauls butt OFFRODEN 5.9L Cummins (1998.5-2002) 22 11-30-2006 06:43 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome