5.9 problems in 2001 Freightliner FL60 - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by msherrilljr, this thread has received 5 replies and been viewed 9691 times.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-10-2011, 07:28 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Posts: 71
Points: 17,911
Thanks: 14
Thanked 0 Times in 0 Posts
5.9 problems in 2001 Freightliner FL60

I recently had an oil leak fixed. It was between the block and the spacer that holds the timing gears (not the cover but where the spacer mates to the block so the shop had to remove the cam). Now...Since then, when you start the truck from sitting overnight, it will come up to temp and go pass the normal operating temp to about 230 deg. The check engine light will come on for a min or so and the temp goes back to operating temp to around 180-190. It only does it when engine is cold. I am also losing about 1 gal of coolant over a 220 mile run. NO water in the oil and NO leaks visible on the outside of block. Recently (pass weeks run) after about 150 miles the truck starts missing and I can smell strong exhaust fumes in truck. No warning indicator lights come on. Truck has 410K miles on it and runs extremely well for the first 150 miles of a run. Oil pressure is good.

What is the problem?
Help!


Thanks
msherrilljr is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-10-2011, 08:56 PM
Member
 
IDImonsterstack's Avatar
 
Join Date: Dec 2007
Posts: 322
Points: 31,761
Thanks: 2
Thanked 2 Times in 2 Posts
well if your loosing coolant and you don see is coming out anywhere did they by any chance do a head gasket at all? could be a leaking head gasket. as for the temp gauge that sounds like electrical problems. get a heat gun with a laser deal on it and when the guage says 180-190 check it same as when i says 230 or so. and for the missing they may have the timing a tooth off. i would take it back and make them tear it all back apart and do it agian

2001 CC LB 2500 48RE with TQlockup CAI, 5"TBE,Quadzilla Adrenaline with V2,and BD pulse XXX 100hp stix, phatshaft 66mm .leveled on 305/70/16's
under the knife for rebuild
IDImonsterstack is offline  
post #3 of 6 (permalink) Old 04-16-2011, 05:34 PM
Junior Member
 
Join Date: Nov 2009
Posts: 3,533
Points: 70,107
Thanks: 69
Thanked 655 Times in 578 Posts
First thing you want to test is the radiator cap, be sure it holds pressure. And look at the tube coming of the surge tank if it is wet you could have a blown head gasket and would want to do a bottle test.
When you park it at night, look at the back of the head between the cab and head also check the frost plug below the gasket. look for stain.
The infrared temp gauge is a very good idea to check the temperature, you can do that at the same time you do the bottle test. Check the temperature at the oil cooler housing it is possible the thermostat is sticking, also possible the water pump is not putting out enough pressure.
The infrared temp gun should be a mandatory tool for every driver, you can check your hubs brakes everything then when one is abnormal you will be able to get it fixed before it shuts you down and really costs you money.

1988 ford van fresh overhaul, 1991 nissan pick-up 1993 Caprice 2000 GMC S10 Blaser 2007 nbs 3500 GMC 4x4 crew-cab long box 17 inch single wheels Duramax Alison. BW turnover Ball. Furakawa FL35 loader. Retired, HD mechanic, worked on engines all my life. Fabricator welder. electrician. in the process of finishing my new shop. Live in Rock Creek B.C. Wife has a fruit stand.
Johnp3 is offline  
post #4 of 6 (permalink) Old 05-15-2011, 04:10 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Mar 2008
Posts: 71
Points: 17,911
Thanks: 14
Thanked 0 Times in 0 Posts
Thanks Guys, The temp problem was the thermostat sticking. I'm still having problems with is missing. Its almost like a bad fuel problem until yesterday it wouldn't run over 25mph. I had to get towed.
From sitting overnight you can get in the truck and drive it 100 miles or so until the miss starts. When it starts missing,,,I can smell strong exhaust fumes in the cab. My original thought was injectors but explain why they work sometimes and not other times. A bad injector is a bad injector...Right? Truck is down for now. My mechanic is stumped. He's gonna start replacing injectors. Hummmmmm.

Thanks for the help...
msherrilljr is offline  
post #5 of 6 (permalink) Old 05-15-2011, 05:34 PM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,834
Points: 55,314
Thanks: 302
Thanked 691 Times in 599 Posts
Garage
On the VP trucks if the timing gear is off to much it will through a code for timing as the VP Electronics control timing. ( You can advance timing like a p-pump but there is more to it than the p-pump)

I would start by checking lift pump press. Also does it have any codes thrown?

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air
Optima Redtop 34Rs


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2016 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
post #6 of 6 (permalink) Old 05-16-2011, 12:08 AM
Junior Member
 
Join Date: Nov 2009
Posts: 3,533
Points: 70,107
Thanks: 69
Thanked 655 Times in 578 Posts
The lift pump on the VP equipped Freightliners only stay on for 15 seconds, there is a screen in the pump that can plug and restrict fuel delivery, it is a good idea to check the pressure and restriction of the fuel system before the filter.
The pump is timed with a key so unless the gear is out of time the pump is OK.
If the pass threw tube is cracked it can cause a misfire, and will usually leak externally.
Wash the motor off very clean and then when it starts missing look for a leak past the pass threw nut on the fuel delivery line to the injector.

1988 ford van fresh overhaul, 1991 nissan pick-up 1993 Caprice 2000 GMC S10 Blaser 2007 nbs 3500 GMC 4x4 crew-cab long box 17 inch single wheels Duramax Alison. BW turnover Ball. Furakawa FL35 loader. Retired, HD mechanic, worked on engines all my life. Fabricator welder. electrician. in the process of finishing my new shop. Live in Rock Creek B.C. Wife has a fruit stand.
Johnp3 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
94 Freightliner FL60 clutch pedal problem Gwold Medium and Heavy Duty 3 03-25-2011 11:09 PM
Freightliner FL60 dash warning light Opi Medium and Heavy Duty 6 08-11-2010 01:48 AM
Buying a 2001 any problems blackcloud 1994-2003 7.3L Power Stroke 11 05-05-2009 04:44 PM
2001 Problems SCRecovery Duramax 2001-2004 (LB7) 6 04-01-2008 04:35 AM
2001 7.3 problems Dirt Farmer 1994-2003 7.3L Power Stroke 14 02-09-2006 04:21 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome