cummins died HELP!! please - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by coreyk, this thread has received 16 replies and been viewed 2728 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 05-28-2011, 10:26 PM Thread Starter
Junior Member
 
Join Date: Aug 2007
Posts: 25
Points: 16,485
Thanks: 0
Thanked 0 Times in 0 Posts
cummins died HELP!! please

I have a 01 cummins, I was driving yesterday and my water in fuel light came on, after about 70 miles after the light came on, the truck quit. I had it towed and I removed the filter, and there was about a 1/2" of sludgey **** at the base, I drained the fuel tank and cleaned it out and put fresh fuel in. The truck will not fire now. I do not have the right fuel pressure tester, but I took the line off the filter from the lift pump and when I turn the key the pump runs and takes a second to squirt. When it does squirt it seems to have good pressure but its only a short burst of fuel, also is the pump supposed to run everytime I turn the key? I also noticed at the feed line to the injection pump when I turn the key on there isn't much pressure at the releif valve when I push it in... Doesalso I took a line off a injector and cranked the engine over and I have fuel but not a lot of pressure. What does it sound like is wrong?
coreyk is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 05-29-2011, 01:49 AM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,834
Points: 55,321
Thanks: 302
Thanked 691 Times in 599 Posts
Garage
Check for codes by cycling the key on and off 3 times w/o starting the truck. Leave key in on position on 3rd time. Your codes will be displayed in the odometer.

From the sounds of it you have lost your lift pump and possibly VP44 injection pump. Post up any codes present.

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air
Optima Redtop 34Rs


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2016 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
post #3 of 17 (permalink) Old 05-29-2011, 02:31 AM
Senior Member
 
Join Date: Dec 2008
Posts: 2,063
Points: 84,022
Thanks: 43
Thanked 150 Times in 146 Posts


Check the codes, you may get lucky but more than likely you need a new VP. Diesel is all the pump has for lube and some of the tolerances are very close ... so, no lube no pump.
later is offline  
post #4 of 17 (permalink) Old 05-29-2011, 12:22 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Aug 2007
Posts: 25
Points: 16,485
Thanks: 0
Thanked 0 Times in 0 Posts
Codes present are P 1693 and then it says P done. I also put my scan tool on it and found nothing.suposebly the truck had a "monster" vp injection pump in it according to the guy I bought it from. Could there be air in the system?
coreyk is offline  
post #5 of 17 (permalink) Old 05-29-2011, 01:52 PM
Junior Member
 
Join Date: Feb 2009
Posts: 96
Points: 3,667
Thanks: 8
Thanked 13 Times in 13 Posts
Crack the injector lines while someone is cranking. I usually crack the one and 3 lines to bleed the lines. You probably just have air, hopefully!
hin0031 is offline  
post #6 of 17 (permalink) Old 05-29-2011, 04:45 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Aug 2007
Posts: 25
Points: 16,485
Thanks: 0
Thanked 0 Times in 0 Posts
I Got a fuelpressure guage. I hooked it up tthat goes into the filter, turn the key it barely builds 2psi. I crank it over and barely 2psi, turn the key off and the pump runs and builds about 18psi and then shuts off and looses pressure. I hooked it up at the feed line at the injection pump and I'm getting no psi. I cracked the lines at the injectors and crank it over and I do get fuel from the lines, almost a steady stream. Bad lift pump?
coreyk is offline  
post #7 of 17 (permalink) Old 05-29-2011, 06:42 PM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,834
Points: 55,321
Thanks: 302
Thanked 691 Times in 599 Posts
Garage
Try a lift pump first FASS and Airdog both make good pumps. There may be a chance your vp is still ok but the more you try to start the truck or run it with a bad lift pump fge bigger then chance of it will die. You can try the lift pump and the if needed go to the the vp. A good lift pump and fuel pressure gauge would be a start.

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air
Optima Redtop 34Rs


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2016 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
post #8 of 17 (permalink) Old 05-29-2011, 08:33 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Aug 2007
Posts: 25
Points: 16,485
Thanks: 0
Thanked 0 Times in 0 Posts
Ok, where do you recomend I get one, and should I get just the pump or the pump with a filter setup on it?if I get one with a filter on it do I still use the stock filter setup I was looking at the fass platinum 90gph with the filter is that a good setup? And where do you recomend hooking the fuel pressure guage up to?

Last edited by coreyk; 05-29-2011 at 08:41 PM.
coreyk is offline  
post #9 of 17 (permalink) Old 05-30-2011, 03:29 AM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,834
Points: 55,321
Thanks: 302
Thanked 691 Times in 599 Posts
Garage
Post in the Vendors section here with what you want. And tell them plans and uses of the truck and what mods are done and planning to be done and they will suggest a pump.

That is correct with any of the AD/ FASS pumps with filter you do not reuse the factory filter.

You can also click the green link in my sig that says Support the Vendors who Support TDG and it will take you to the vendors section.

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air
Optima Redtop 34Rs


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2016 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
post #10 of 17 (permalink) Old 06-04-2011, 02:05 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Aug 2007
Posts: 25
Points: 16,485
Thanks: 0
Thanked 0 Times in 0 Posts
Bad news truck still wont start. Put a new lift pump in i went with a FASS. i got fuel at all the injectors, i did not get a fuel pressure guage hooked up yet. Do you think my vp could have taken a turn for the worst? it just cranks and wont fire, but i dont have fuel at all the injectors, and its a good amount coming out.
coreyk is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C died need help keystone cop 1994-2003 7.3L Power Stroke 3 11-25-2009 02:23 AM
6.5 died again imported_Prodiesel 6.5L Diesel Engine 8 11-24-2007 12:41 AM
Possible ECM died now.. 02sprtcumns 5.9L Cummins (1998.5-2002) 2 01-14-2007 11:07 PM
96 PSD died Slacker 1994-2003 7.3L Power Stroke 9 06-05-2006 12:50 AM
it died.. AGAIN!!! DSI 2003-2007 6.0L Power Stroke 0 02-13-2006 04:46 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome