Engine Overheating - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by rwhite, this thread has received 5 replies and been viewed 1062 times.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-29-2008, 01:11 AM Thread Starter
Senior Member
 
Join Date: Dec 2008
Location: Daniel, WY/Laramie, WY
Posts: 237
Points: 23,119
Thanks: 4
Thanked 7 Times in 7 Posts
Engine Overheating

Week before last the thermostat never opened and the truck overheated. Tried to baby the truck to work but to no avail. Ended up taking the thermostat out on the side of the road (-10F) and after putting everything back together, thermostat opened. 2 days later w/ new thermostat same thing, but eventually opened on own before I got the check engine light. What would cause this?: Also, @ both of these times the in cab heater never kicked on the whole 20+ miles to town. Are these things coincidence or are they linked together? Sorry for the long post. Thanks.
rwhite is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-29-2008, 01:27 AM
What are sparkplugs
 
ICEMAN3005's Avatar
 
Join Date: Dec 2008
Location: Jonesville, MI
Posts: 147
Points: 27,089
Thanks: 8
Thanked 4 Times in 4 Posts
maybe your heater core is clogged?

2002 dodge 2500 4x4
Edge Juice W/Attitude
Hot Rod VP-44 stage 2
200 H.P. Injectors
HX-40 turbo(Silencer Ring MIA)/ BHAF
FASS 150/150
billet trans/TC 1600 stall (rebuilt myself) parts supplied by DUNERITETORQUECONVERTERS
2" leveling front kit
TRUCK SOLD

Two 84 chevy 1 1/2 ton pickups 6.2L Diesel (stock)
Turbo400, NP208 transfer case, Dana 60 front, GM 14 bolt rear W/Locker
89 Chevy K-5 Blazer 350/700r4/np241/gm10bolt rear dana44 front
ICEMAN3005 is offline  
post #3 of 6 (permalink) Old 12-29-2008, 02:20 AM
2nd Gen Guru
 
Mopar1973Man's Avatar
 
Join Date: Dec 2008
Location: New Meadows, Idaho
Posts: 2,641
Points: 54,970
Thanks: 9
Thanked 140 Times in 131 Posts
Garage
Send a message via Yahoo to Mopar1973Man
Water pump impeller wasted???

Heater core plugged???

Radiator blocked (Internally and/or externally)???

Coolant mixture fresh??? (Less than 30K miles)

Michael Nelson - 2002 Dodge Cummins & 1996 Dodge Ram 5.9L Gasser
116K Miles On My VP44 - 4 Years of 2 Cycle Oil Diet! - Mixed at 128:1 Ratio - 25.3 MPG maxed out!
Mopar1973Man is offline  
post #4 of 6 (permalink) Old 12-30-2008, 07:49 PM Thread Starter
Senior Member
Threadstarter
 
Join Date: Dec 2008
Location: Daniel, WY/Laramie, WY
Posts: 237
Points: 23,119
Thanks: 4
Thanked 7 Times in 7 Posts
Yeah, everything is good. Prior to the incident it had a full radiator flush & new coolant & distilled water max 3K miles before. After those two times, everything has been fine.?

'99 2500 4X4 5spd 104K miles Ext Cab, longbed, Banks exhaust, Exhaust Brake, BHAF, comp, Raptor 150, gauges, 100 hp sticks.

#23 B.O.M.B. Squad[/B]
rwhite is offline  
post #5 of 6 (permalink) Old 01-01-2009, 01:40 AM
Professional Grouch
 
Live Oak's Avatar
 
Join Date: Dec 2008
Location: Turnbow Hollow, Tennessee
Posts: 18
Points: 414
Thanks: 0
Thanked 4 Times in 4 Posts
What does to coolant level look like? Have you had to add any coolant lately? You may have a trapped pocket of air in the system.

Mine-2002 2500 SLT Laramie, 4x4, ETH/DEE, F1 Mach 1.6 injectors, Edge EZ, Cummins eBrake, Air Dog 150, ISSPRO Gauges,BHAF, Outterware Prefilter, heat shield, DSS, Dark Garnet Red, 3.54 diff. gears, Westin Sportsman Brush Guard, Westin Sportsman Nerf Bars, Rhino Liner, White Night backup Light, 295/75R-16's, Passport 8500i radar/laser detector. NRA Benefactor Life Member, NAHC, NSSA, NSCA Life Member, RWVA Member

Hers-2001.5 2500 SLT Laramie, 4x4, ETH/DEE, 3.54 diff. gears, Vulcan 1/2" Big Line Kit w/frame relocated Aertex lift pump, ISSPRO fuel pressure gauge, Side Trax Nerf Bars, Bed Liner, B&W Turnover Ball Hitch, Delta Aluminum Bed Box, Design Tech 50 watt backup lamps.
Live Oak is offline  
post #6 of 6 (permalink) Old 01-02-2009, 09:39 PM Thread Starter
Senior Member
Threadstarter
 
Join Date: Dec 2008
Location: Daniel, WY/Laramie, WY
Posts: 237
Points: 23,119
Thanks: 4
Thanked 7 Times in 7 Posts
coolant level is fine now. I don't think I had any trapped air, had driven 400 miles w/ 10k on night before this started. Everything is good now so hopefully no more problems.

'99 2500 4X4 5spd 104K miles Ext Cab, longbed, Banks exhaust, Exhaust Brake, BHAF, comp, Raptor 150, gauges, 100 hp sticks.

#23 B.O.M.B. Squad[/B]
rwhite is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome