hello everyone - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Grannygear, this thread has received 7 replies and been viewed 482 times.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-24-2007, 03:14 AM Thread Starter
 
Join Date: Dec 2008
Posts: 51
Points: 1,719
Thanks: 0
Thanked 1 Time in 1 Post
hello everyone

i am new to this whole forum thing. i have been reading alot of the threads and i am learning alot. so figured i would join in. thanks for having me! i have a 2001 dodge 2500 4x4 24 valve 6 speed. i love it. well maybe not as much right now. it is giving me some trouble. i recently installed a quadzilla xzillaraidar xzt+ (timing + fuel) module. for the first week i loved it. it gave great throttle response and smoked just enough to tell others i'm making power. well after a week i started hearing and extra tap/knock above all the other knocking going on. then the engine started to vibrate more than normal, i felt it in the shifter, like a higher frequency vibration. then it got worse and i felt it in the truck and steering wheel and the noise got louder. to this date i checked codes (none found), valve lash, lift pump preasure, and replaced fuel filter. i think i may have a bad injector. using a screw driver and my ear, it sounds to be in the back of the engine. any help would be great.:shrug:
Grannygear is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-24-2007, 03:37 AM
Senior Member
 
Join Date: Nov 2007
Posts: 307
Points: 5,833
Thanks: 1
Thanked 0 Times in 0 Posts
Welcome.
There are lots of people that can help you out on this forum, however I'm not one of them, I'm still learning myself. But this site is awesome there is an unlimited wealth of info in the heads of these guys, as soon as some of the other people on this site read this I feel certain that they will have many answers for you.

99 2500 dodge cummins, HTS auto trans, quadzilla/edge ez, edge stage 2 nozzles, HX40,special X pump, big line kit, custom dual filter intake, custom exhaust, holley blue, adjustable boost elbow, new intercooler boots, t/c lock up switch, suncoast t/c, leveling kit, new 285 bfg's, all the gauges. New TPS


SINGLES CLUB MEMBER #44
iwannagofast is offline  
post #3 of 8 (permalink) Old 11-24-2007, 05:16 AM
 
Join Date: Jan 2009
Posts: 2,045
Points: 3,395
Thanks: 0
Thanked 7 Times in 7 Posts
did yhou try turning the timing down a little? that could help, just too aggresive with what you have set up right now
cajuncummins is offline  
post #4 of 8 (permalink) Old 11-24-2007, 12:40 PM Thread Starter
Threadstarter
 
Join Date: Dec 2008
Posts: 51
Points: 1,719
Thanks: 0
Thanked 1 Time in 1 Post
timing

i know that the quadzilla said it changes timing, that is why timing is a good thought. however, after checking valve lash, fuel preasure, and replacing filter, i disconnected the module completely and on the test drive the niose seemed worse, however the vibration didn't. could the mudule have changed the timing permanetly and even with it not hooked up its still to much. this module only plugs in to the map sensor and to the three wire flat diagnostic connector near the computer under the filter. it does not tap into the pump wire. this is why i liked this module. i was to scared to tap the pump wire. thanks for the help.
Grannygear is offline  
post #5 of 8 (permalink) Old 11-24-2007, 05:38 PM
 
Join Date: Jan 2009
Posts: 2,045
Points: 3,395
Thanks: 0
Thanked 7 Times in 7 Posts
well if it is worse towards the back cylinders it could very well be an injector, i can't imagine the timing has stayed advanced, but the box could've caused the problem, how about the clutch? how is it acting, is tere any power loss in the engine? maybe the clutch is slipping causing the vibration?
cajuncummins is offline  
post #6 of 8 (permalink) Old 11-24-2007, 09:26 PM Thread Starter
Threadstarter
 
Join Date: Dec 2008
Posts: 51
Points: 1,719
Thanks: 0
Thanked 1 Time in 1 Post
there is only slight power lose, it does feel like it lost some top end, but no extreme lose. there is no abnormal smoke. the clutch seems fine, i don't think its a clutch issue cause i feel the vibration just sitting there idling. i was thinking of pulling the injectors and having them tested. even if they are good (which would suck cause then my injector theary goes out the window), i could at least get them tuned so they are matched better right?
Grannygear is offline  
post #7 of 8 (permalink) Old 11-24-2007, 10:08 PM
 
Join Date: Jan 2009
Posts: 2,045
Points: 3,395
Thanks: 0
Thanked 7 Times in 7 Posts
yeah, that would be the easiest way, it could be the ip, i know you've replaced the checked the lp, but even with that insurance it might be you ip havin issues, but if there's no codes it might be the maechanics in the pump, the box could just have added the pressure on the pump to push it over the edge
cajuncummins is offline  
post #8 of 8 (permalink) Old 11-24-2007, 10:38 PM Thread Starter
Threadstarter
 
Join Date: Dec 2008
Posts: 51
Points: 1,719
Thanks: 0
Thanked 1 Time in 1 Post
i guess doing the work to pull the injectors is alot cheaper and easier than dealing with the ip at this point. do you need the special tools to pull the injector tubes and injectors, or can it be done without these tools? i am pretty good at making my own tools for stuff. i read the colume that bluechip wrote, the one that says "everyone with a 24 valve should read", about adding a module and then something going wrong and blaming it on the module, when it really is something else that the module just put more preasure on. so i guess i can't blame the box at this point.
Grannygear is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome