Truck problem - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by gearhead87, this thread has received 2 replies and been viewed 481 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-19-2007, 04:45 PM Thread Starter
 
Join Date: Dec 2007
Posts: 10
Points: 202
Thanks: 0
Thanked 0 Times in 0 Posts
Truck problem

OK folks, here's the problem: When I start my truck, it sounds like it's misfiring when revved, blows gray smoke, and has NO power (tops out at 30mph on level ground, decelerates going uphill at 2000 rpm) until the engine gets up to operating temp. The problem is def. heat-related. I've done the lift pump, replacing the ECT sensor today, and I am at my wit's end here. I was showing a 0216 code which I think was caused by low fuel pressure from the lift pump. Other than that, there's no signs that it could be VP44 failure. Anybody go through this or have any thoughts? I have already had a few near misses because of this, so anything you have to say, please speak up! Thank you!
gearhead87 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-19-2007, 06:25 PM
 
Join Date: Dec 2008
Posts: 2,189
Points: 44,821
Thanks: 0
Thanked 0 Times in 0 Posts
The P0216 is a injection pump timing advance code. But I think about anythign will trigger it. Get your fuel replaced/upgraded. Some people say you can make the code go away if you get it replace early enough. Some peoples results just from replaceing a GOOD STOCK PUMP are unbelieveable. One guy was doing like 10 at idle and 0 at WOT. He just replaced his fuel pump just to upgrade to the FASS, not because anything was wrong. After he was done he got 18 a idle (I think) and 10 at WOT. I don't know if those are the actual numbers but it was big.


Also keep in mind your timing advance is dependent on fuel pressure.
Smokem is offline  
post #3 of 3 (permalink) Old 12-20-2007, 01:26 PM
2nd Gen Guru
 
Mopar1973Man's Avatar
 
Join Date: Dec 2008
Location: New Meadows, Idaho
Posts: 2,641
Points: 54,832
Thanks: 9
Thanked 140 Times in 131 Posts
Garage
Send a message via Yahoo to Mopar1973Man
Just for the information aspect...

I'm running a Vulcan Big Line Kit and a Carter Campaign Pump... With these two I'm getting the 14 @ idle and 11 @ WOT. I'm push out 381/826 in power.

I don't see any reason for jumping to a $400+ dollar pump. There is many other products out there that cost much less.

As for getting both the VP44 and Lift pump happy... Give them a dose of 2 cycle oil to keep them lubed. So far I've had wonderful life and performance from my pumps without the headache or the price!

Michael Nelson - 2002 Dodge Cummins & 1996 Dodge Ram 5.9L Gasser
116K Miles On My VP44 - 4 Years of 2 Cycle Oil Diet! - Mixed at 128:1 Ratio - 25.3 MPG maxed out!
Mopar1973Man is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome