Edge acting up - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by blazd88, this thread has received 2 replies and been viewed 492 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-27-2008, 06:49 PM Thread Starter
Junior Member
 
Join Date: Nov 2006
Posts: 23
Points: 346
Thanks: 0
Thanked 0 Times in 0 Posts
Edge acting up

Just finished installing my new Valair clutch, put everything back together(batteries and such) and My edge is acting funny. I have a stealth pump cover so the wire is tapped but it acts like one that isnt. Also my egts are way off. At idle im at like 600 where 350 is more the norm. Anyone ever had this prob. I know thermos are know for going bad but normally they jump around when they are bad and mine doesnt. Another thing is my fuel pressure at startup is way high(so it says) it stays at 32psi for a min then goes to the normal 14. Anyone?

1998.5 Dodge 3500 Ext Cab dually
24v/nv4500
Super B Special
200hp sticks
Edge Juice Attitude *HOT*/Stealth cover
in tank LP/Vucan big line kit w/ lp on frame/ATS relay
MBRP 6" Mitres/ AFE stage 2
Valair 13" 650hp clutch THANX DAN!!!
blazd88 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-28-2008, 02:44 AM
2nd Gen Guru
 
Mopar1973Man's Avatar
 
Join Date: Dec 2008
Location: New Meadows, Idaho
Posts: 2,641
Points: 54,970
Thanks: 9
Thanked 140 Times in 131 Posts
Garage
Send a message via Yahoo to Mopar1973Man
Quote:
Originally Posted by blazd88
Just finished installing my new Valair clutch, put everything back together(batteries and such) and My edge is acting funny. I have a stealth pump cover so the wire is tapped but it acts like one that isnt. Also my egts are way off. At idle im at like 600 where 350 is more the norm. Anyone ever had this prob. I know thermos are know for going bad but normally they jump around when they are bad and mine doesnt. Another thing is my fuel pressure at startup is way high(so it says) it stays at 32psi for a min then goes to the normal 14. Anyone?
I gather this is displayed from the Edge Juice right? If so I would say you going to need to double check all you wiring connections including gorund leads.

I know the only way to idle at 600*F is to 3cylinder high idle going...:

Michael Nelson - 2002 Dodge Cummins & 1996 Dodge Ram 5.9L Gasser
116K Miles On My VP44 - 4 Years of 2 Cycle Oil Diet! - Mixed at 128:1 Ratio - 25.3 MPG maxed out!
Mopar1973Man is offline  
post #3 of 3 (permalink) Old 02-29-2008, 04:51 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Nov 2006
Posts: 23
Points: 346
Thanks: 0
Thanked 0 Times in 0 Posts
Checked them all, pump wire is tapped. Think my box could have gone bad? I wouldnt think just those few things would be affected by it going bad if that were the case. Ill keep searching!

1998.5 Dodge 3500 Ext Cab dually
24v/nv4500
Super B Special
200hp sticks
Edge Juice Attitude *HOT*/Stealth cover
in tank LP/Vucan big line kit w/ lp on frame/ATS relay
MBRP 6" Mitres/ AFE stage 2
Valair 13" 650hp clutch THANX DAN!!!
blazd88 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome