Hard pedal - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by RobVG, this thread has received 5 replies and been viewed 959 times.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-21-2009, 07:12 PM Thread Starter
Junior Member
 
Join Date: Jun 2009
Location: Seattle
Posts: 26
Points: 12,821
Thanks: 11
Thanked 3 Times in 2 Posts
Hard pedal

2001 170,000mi
Not my truck

Replaced rear rotors, calipers and pads. Bled calipers.

Truck stops good but pedal feels hard to me. It almost feels like there's no power assist.

What could I have done wrong?
RobVG is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-22-2009, 01:31 AM
Senior Member
 
bmoeller's Avatar
 
Join Date: Dec 2008
Location: NW IL
Posts: 4,827
Points: 67,651
Thanks: 158
Thanked 392 Times in 331 Posts
Garage
Did you open up the bleeder screws when you pressed the caliper pistons back in?

Power steering working fine?

"Some people are educated beyond their intelligence."

'93 W350 CC, LE, 5spd, HTT modded H1C, 4" DE

Sold- '99 3500 Q/C, SO CTD, 4x4, 5spd.

Traded off- '97 3500 C/C, 4x4, CTD

'92 W250, LE, CC, CTD w/ tweaked pump (SOLD)


"Obama = Hoax and Chains"

If Obama is the answer, it must have been a stupid question.
bmoeller is offline  
The Following User Says Thank You to bmoeller For this addition to TDG:
RobVG (11-22-2009)
post #3 of 6 (permalink) Old 11-22-2009, 01:50 PM
Member
 
cowboytw13's Avatar
 
Join Date: Dec 2008
Location: Clarion, PA
Posts: 157
Points: 6,203
Thanks: 1
Thanked 5 Times in 5 Posts
Mine did the same thing when I replaced the master cylinder, then one day it just started working right. took about two weeks I think. But you're right, it seemed like there wasn't any power assist.

2004 Silverado 2500 LLY Duramax
cowboytw13 is offline  
The Following User Says Thank You to cowboytw13 For this addition to TDG:
RobVG (11-22-2009)
post #4 of 6 (permalink) Old 11-22-2009, 11:45 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Jun 2009
Location: Seattle
Posts: 26
Points: 12,821
Thanks: 11
Thanked 3 Times in 2 Posts
Thanks for the responses.

The calipers were new (reman) in the box so the pistons were already seated.
PWR steering works fine.
RobVG is offline  
post #5 of 6 (permalink) Old 11-25-2009, 02:35 PM
2nd Gen Guru
 
Mopar1973Man's Avatar
 
Join Date: Dec 2008
Location: New Meadows, Idaho
Posts: 2,641
Points: 54,832
Thanks: 9
Thanked 140 Times in 131 Posts
Garage
Send a message via Yahoo to Mopar1973Man
ABS sensors? If a front sensor is going out and and mis-reading speed signals it will actually push against you for brakes causing a hard pedal.

Another causes is debris in the power steering fluid and it plugged on of the port in the Hydro-booster. You'll need to pull it off and clean and replace. PS fluid is suppose to be changed every 30K miles!

Brake fluid what color is it? If its dark it suppose to be change too.. Brake fluid should be changed every 30K miles too.

Michael Nelson - 2002 Dodge Cummins & 1996 Dodge Ram 5.9L Gasser
116K Miles On My VP44 - 4 Years of 2 Cycle Oil Diet! - Mixed at 128:1 Ratio - 25.3 MPG maxed out!
Mopar1973Man is offline  
The Following User Says Thank You to Mopar1973Man For this addition to TDG:
RobVG (11-28-2009)
post #6 of 6 (permalink) Old 11-28-2009, 06:59 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Jun 2009
Location: Seattle
Posts: 26
Points: 12,821
Thanks: 11
Thanked 3 Times in 2 Posts
Problem is, I think it was working ok before I changed the calipers. Haven't heard any feedback from the driver, will see him Monday.
RobVG is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard Brake Pedal but No Brakes!! Help! DINOONE 2008-2010 6.4L Power Stroke 11 07-02-2009 01:25 PM
tps pedal testing camojeeper 1994-2003 7.3L Chips & Tuners Forum 2 01-10-2009 03:58 AM
the dead pedal MOOSE 04 5.9L Cummins (1998.5-2002) 9 12-19-2007 12:56 AM
OBS pedal mod stroker_baldy 1994-2003 7.3L Power Stroke 4 04-27-2007 05:10 PM
Cruise control not releasing until I push brake pedal REALLY HARD imported_Arkapigdiesel 2003-2007 6.0L Power Stroke 23 05-30-2006 03:35 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome