2002 dodge 2500 5.9 cummins running poorly - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by budman2002, this thread has received 11 replies and been viewed 10886 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-08-2010, 08:41 PM Thread Starter
budman2002
 
Join Date: Mar 2010
Posts: 3
Points: 1,898
Thanks: 4
Thanked 0 Times in 0 Posts
Unhappy 2002 dodge 2500 5.9 cummins running poorly

My 2002 dodge truck began to get some wierd symptoms. Water in fuel light on, check engine light on, temp gauge going up and back down, fuel pedal loss of accelleration and no power. The engine will start and idle but the pedal is dead when trying to rev the engine. The transfer pump was reeplaced due to finding some aluminum flakes in the filter and the tank. No sign of water and the light is still on. What is happening? Has anyone had this situation happen or heard of anything so bizzarre? HELP!
budman2002 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-08-2010, 10:51 PM
Senior Member
 
Join Date: Jan 2009
Location: Shingletown ca
Posts: 1,189
Points: 50,995
Thanks: 4
Thanked 63 Times in 59 Posts
Garage
whats your fuel pressure at? could be apps

01 quad cab 4x4, edge drag comp, 4" exhaust, fass 150, 250 ddps, Jefferson State compounds 683hp so vp 11.91. AMSOIL front to rear. now back to stock 95 fummins in the works
01quadcab is offline  
post #3 of 12 (permalink) Old 03-08-2010, 11:56 PM
Junior Member
 
JDolezal's Avatar
 
Join Date: Mar 2009
Location: Maybee, MI
Posts: 97
Points: 3,707
Thanks: 22
Thanked 6 Times in 6 Posts
Garage
Hate to say it but i've had all of those symptoms....bad ECM. Thats what happened to our 02 anyhow

91.5 Dodge 250, rclb, 4x4, Getrag, little extra fuel and timing, straight pipe

94 Dodge 2500, rclb, 4x4, NV4500, little extra fuel and timing, straight pipe

95 Dodge 2500, rclb, 4x4, auto, gasser.

02 Dodge 2500, rclb, 4x4, NV4500, Edge EZ, straight pipe
JDolezal is offline  
post #4 of 12 (permalink) Old 03-09-2010, 01:08 AM
Junior Member
 
Join Date: Feb 2009
Posts: 96
Points: 3,672
Thanks: 8
Thanked 13 Times in 13 Posts
Mine did the same thing and the ecm was bad.
hin0031 is offline  
post #5 of 12 (permalink) Old 03-09-2010, 02:12 AM
Senior Member
 
sstockton's Avatar
 
Join Date: Jan 2009
Posts: 3,514
Points: 69,209
Thanks: 3
Thanked 64 Times in 60 Posts
Yep, I'm right with these guys. That sounds like an ECM issue for sure.
Sean

2000 2500 reg. cab 4x4 auto 577hp
09 6.7L QC LB stick, 4x4.

TOTAL PERFORMANCE DIESEL 707-545-FUEL (3835)
www.totalperformancediesel.com
sstockton is offline  
post #6 of 12 (permalink) Old 03-09-2010, 11:27 AM
Senior Member
 
bmoeller's Avatar
 
Join Date: Dec 2008
Location: NW IL
Posts: 4,827
Points: 67,657
Thanks: 158
Thanked 392 Times in 331 Posts
Garage

"Some people are educated beyond their intelligence."

'93 W350 CC, LE, 5spd, HTT modded H1C, 4" DE

Sold- '99 3500 Q/C, SO CTD, 4x4, 5spd.

Traded off- '97 3500 C/C, 4x4, CTD

'92 W250, LE, CC, CTD w/ tweaked pump (SOLD)


"Obama = Hoax and Chains"

If Obama is the answer, it must have been a stupid question.
bmoeller is offline  
The Following User Says Thank You to bmoeller For this addition to TDG:
budman2002 (03-14-2010)
post #7 of 12 (permalink) Old 03-09-2010, 02:15 PM
2nd Gen Guru
 
Mopar1973Man's Avatar
 
Join Date: Dec 2008
Location: New Meadows, Idaho
Posts: 2,641
Points: 54,838
Thanks: 9
Thanked 140 Times in 131 Posts
Garage
Send a message via Yahoo to Mopar1973Man
Quote:
Originally Posted by JDolezal View Post
Hate to say it but i've had all of those symptoms....bad ECM. Thats what happened to our 02 anyhow
Quote:
Originally Posted by sstockton View Post
Yep, I'm right with these guys. That sounds like an ECM issue for sure.
Sean
Check for error codes I bet you got a bunch of high volt sensor codes (IAT, MAP, APPS, etc) and then you might find a P0606 (ECM Failure)

Yeah I got a truck down the road from me with the same issues...

x3 Yeap its a bad ECM...

Michael Nelson - 2002 Dodge Cummins & 1996 Dodge Ram 5.9L Gasser
116K Miles On My VP44 - 4 Years of 2 Cycle Oil Diet! - Mixed at 128:1 Ratio - 25.3 MPG maxed out!
Mopar1973Man is offline  
The Following User Says Thank You to Mopar1973Man For this addition to TDG:
budman2002 (03-14-2010)
post #8 of 12 (permalink) Old 03-10-2010, 07:47 PM Thread Starter
budman2002
Threadstarter
 
Join Date: Mar 2010
Posts: 3
Points: 1,898
Thanks: 4
Thanked 0 Times in 0 Posts
Bad ECM


As luck would have it.... Thanks for the info. all. I have the truck at the dealer to decipher the codes I couldn't read but all things point to the #@%#[email protected]# thing, I guess.... :-( Are the modules readily repairable???? I talked with the Cummins folks and they want $3,000.00 for the one for my serial number engine. Moving forward is going to be painful.
budman2002 is offline  
post #9 of 12 (permalink) Old 03-10-2010, 08:17 PM
2nd Gen Guru
 
Mopar1973Man's Avatar
 
Join Date: Dec 2008
Location: New Meadows, Idaho
Posts: 2,641
Points: 54,838
Thanks: 9
Thanked 140 Times in 131 Posts
Garage
Send a message via Yahoo to Mopar1973Man
I've seen rebuilder shops for much cheaper. Send it in and they rebuild it, reflash it, and send it back...

Michael Nelson - 2002 Dodge Cummins & 1996 Dodge Ram 5.9L Gasser
116K Miles On My VP44 - 4 Years of 2 Cycle Oil Diet! - Mixed at 128:1 Ratio - 25.3 MPG maxed out!
Mopar1973Man is offline  
The Following User Says Thank You to Mopar1973Man For this addition to TDG:
budman2002 (03-14-2010)
post #10 of 12 (permalink) Old 03-11-2010, 01:14 AM
Junior Member
 
Join Date: Feb 2009
Posts: 96
Points: 3,672
Thanks: 8
Thanked 13 Times in 13 Posts
I had mine rebuilt. cost about 500. can also buy remans on the internet as well. turned out very well.
hin0031 is offline  
The Following User Says Thank You to hin0031 For this addition to TDG:
budman2002 (03-14-2010)
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
running poorly when tuned jeffro22 2003-2007 6.0 Tuner Forum 4 04-29-2009 09:29 PM
2002 Dodge Ram 2500 4x4 Lifted! Cheap! Nice! NCcummins Whats Been Sold 8 12-31-2008 04:07 PM
2002 Dodge Ram 2500 NCcummins 5.9L Cummins (1998.5-2002) 2 12-24-2008 03:03 AM
Help with problem (no codes) but running poorly ict03x 2003-2007 6.0L Power Stroke 2 04-01-2008 05:12 AM
2002 Dodge Cummins 2500 4x4 parttimepuller Whats Been Sold 0 10-23-2007 05:34 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome