Changed both batteries and now absolutely nothing works. - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Chuckster513, this thread has received 3 replies and been viewed 1057 times.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-29-2011, 05:04 PM Thread Starter
Junior Member
 
Join Date: Oct 2011
Posts: 2
Points: 306
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Changed both batteries and now absolutely nothing works.

Went to start my truck and found that the batteries were dead. 3 1/2 years old in Arizona is pretty normal. Changed out both batteries and absolutely nothing works. No dash lights, no dome lights, it is as if the batteries were not connected. My first thought was I hooked them up wrong. Double checked and they are correct. Kept looking and found that the passenger seat will move up and back and the mirrors will fold up and back out. The mirrors will not extend, doors will not lock and nothing else works. What the .....
Has anyone heard anything like this? I can't even get it out of park.
Chuckster513 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-29-2011, 11:33 PM
Senior Member
 
pyro2nite's Avatar
 
Join Date: Dec 2008
Location: Sacramento CA
Posts: 606
Points: 40,246
Thanks: 52
Thanked 64 Times in 63 Posts
If nothing worked, then I would check the conections. Might want to start checking the fuse box. I assume you cleaned the conectors before you hooked the new bats.

2008 FX4 3:73 ZF-6 SC SB Transfer Flow
Singles club member 166 H&S Mini, KEM Tunes, S&B intake
pyro2nite is offline  
post #3 of 4 (permalink) Old 10-30-2011, 01:59 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Oct 2011
Posts: 2
Points: 306
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
HAH!!! Found the culprit. I first contacted the dealer and the only tip they could provide was to bring it in for diagnostic checks. Read 2 1/2 ton of money.
Started checking everything I could think of with a DVOM. The main distribution fuse panel located under the hood had voltage to it and showed a minimal current draw and voltage drop when the passenger seat was actuated, so that in itself proved the batteries good. The inside fuse panel had no voltage and there was no main fuse or bus relay. Started checking all connections and found a large (maybe #2 AWG) with a bent lug that was not connected. When I de-termed the battery, I had to de-term one of the cables in order to get clearance to remove the battery. This cable had fallen underneath the lug connection in the exact position as if it were connected. Re-connected the cable and all is good.
Chuckster513 is offline  
post #4 of 4 (permalink) Old 11-04-2011, 02:51 PM
TDG Mafia Member #25
 
adrianspeeder's Avatar
 
Join Date: May 2005
Location: Harrisburg PA / Dover AFB DE
Posts: 1,433
Points: 77,572
Thanks: 3
Thanked 117 Times in 74 Posts
Eh, we've all done similar type things. At least you found it yourself.

Mine is a stick, so I can't check, but all the older fords you were able to turn the key to off position and then drop down to neutral if needed.

Adrianspeeder
adrianspeeder is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
changed batteries A/c blowing hot woodyh61 Duramax 2001-2004 (LB7) 3 07-21-2009 12:06 AM
It works!! hccumminssmoke The Parking Lot 10 01-08-2009 07:57 PM
Yay, it works! Magnus Testing 0 03-26-2008 03:55 PM
Absolutely Amazing Bouncer The Parking Lot 1 10-15-2007 11:30 PM
Terrible door handle engineeering... absolutely ridiculous imported_Hanging_Heels 2008-2010 6.4L Power Stroke 20 05-06-2007 04:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome