Cr@p I got a CEL !! - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by onebadf150, this thread has received 10 replies and been viewed 1021 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 01-11-2008, 07:14 PM Thread Starter
TDG MAFIA MEMBER #85
 
onebadf150's Avatar
 
Join Date: Dec 2008
Location: New Orleans
Posts: 1,683
Points: 34,392
Thanks: 46
Thanked 54 Times in 40 Posts
[email protected] I got a CEL !!

It happen today about 650miles since I added the airaid I feel like laugh . I was wondering does it screw with the regen process since the light is on? I have no way of telling what the codes are b/c I don't have a livewire yet so I guess monday the credit card will get a little more heavy :splat who has intakes on here that had cel issues does it change anything with the light on or does it just throw soft codes?

:thanks:

Nick
onebadf150 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 01-11-2008, 07:23 PM
MAFIA #8
 
hhrecovery's Avatar
 
Join Date: Dec 2008
Location: Pulaski, VA
Posts: 5,567
Points: 89,978
Thanks: 104
Thanked 223 Times in 209 Posts
Images: 1
Garage
why dont you just run down to your local advance, pepboys, autozone etc... and have them read the code for free... maybe it is just something minor and has something to doo w/ the intake like some people had w/ the 6.0s and aftermarket intakes... I would also call airaid and see if it has ever happened to anyone else..

Aaron - 2004 F350 "Offroad Edition"

2003 F250 "Pulling Truck"
hhrecovery is offline  
post #3 of 11 (permalink) Old 01-11-2008, 07:26 PM
Member
 
BeauxPete's Avatar
 
Join Date: Dec 2006
Location: Shreveport, La
Posts: 288
Points: 31,736
Thanks: 13
Thanked 10 Times in 9 Posts
I have a CAI also but have Livewire.. My truck seems to throw CEL alot but they are all soft. Clear them out and a couple of weeks later, the same ones again...

Spartan 310 and KEM 345
Elite Head Studs
Rudy's EGR delete kit with wastegate and CFM
AFE CAI
Powerstroker's 5" Exhaust, MagnaFlow Tail Section with 6" Tip and Stroker's 4" downpipe
Cold Side Intercooler tube
ChromeMoly pushrods
Suncoast Transmission to come!!!!!!
BeauxPete is offline  
post #4 of 11 (permalink) Old 01-11-2008, 07:32 PM
 
Join Date: Oct 2006
Posts: 635
Points: 29,148
Thanks: 0
Thanked 0 Times in 0 Posts
Thats the down side of a brand new motor, the computers will pick-up any change and throw a code. Just because it threw a code over the intake does not mean it's causing problems, it's just the new pcm creepin on you..... It looks like we need custom tuning for these cel lights.
Rainman is offline  
post #5 of 11 (permalink) Old 01-11-2008, 08:08 PM Thread Starter
TDG MAFIA MEMBER #85
Threadstarter
 
onebadf150's Avatar
 
Join Date: Dec 2008
Location: New Orleans
Posts: 1,683
Points: 34,392
Thanks: 46
Thanked 54 Times in 40 Posts
I think custom tuning will fix this issue I was hoping that my truck wouldn't throw a code. livewire will be ordered monday !
onebadf150 is offline  
post #6 of 11 (permalink) Old 01-11-2008, 09:12 PM Thread Starter
TDG MAFIA MEMBER #85
Threadstarter
 
onebadf150's Avatar
 
Join Date: Dec 2008
Location: New Orleans
Posts: 1,683
Points: 34,392
Thanks: 46
Thanked 54 Times in 40 Posts
The CEL is off now ???

***** The weird thing is I just got into the truck to chase down the garbage man who is picking up christmas trees and the CEL light is off and I'm like WTF WOo HOo I don't understand ******
onebadf150 is offline  
post #7 of 11 (permalink) Old 01-12-2008, 01:10 PM
Ford 6.4 it's just cooler
 
trapit's Avatar
 
Join Date: Dec 2008
Location: Augusta Ga
Posts: 673
Points: 27,799
Thanks: 4
Thanked 18 Times in 18 Posts
Its a code thats reading too much air...I got a code 8,000 miles ago and it regens the same as before. Mine sometimes goes off right before a regeneration, kinda like the filter is making more backpressure which puts the air reading back in the safe zone. Hurry up with some freaking custom tunes!!!

Paul Alewine
2008 F-250 King Ranch AFE Stage II MBRP Duals and Spartan 310 Tuned
2" BDS Lift on 35" Toyo M/T's

Singles Club #74
American Club #13
trapit is offline  
post #8 of 11 (permalink) Old 01-12-2008, 08:41 PM
Member
 
Join Date: Jun 2007
Posts: 45
Points: 19,844
Thanks: 0
Thanked 0 Times in 0 Posts
There are alot of possibilities. Here are two that happend to me:

1. After I added an AFE intake, got a CEL and had to replace egr valve. Luckily it was under warranty. Haven't had any more problems with that and been a few thousand miles since.

2. I got a CEL the other day, it was only on for a short time, then went off, dealer read the code and said it was the thermostat is reading a wrong temperature, but the temp was really fine. Dealer said Ford is starting to have a problem with this code. We will watch and see what happens.

Good Luck,
Kevin

2008 F-350 Crew Cab Short Bed 6.4 rollin on 20's
2007 Chevy Tahoe loaded up and rollin on 20's--wife's vehicle--
F350Kevin is offline  
post #9 of 11 (permalink) Old 01-12-2008, 09:40 PM Thread Starter
TDG MAFIA MEMBER #85
Threadstarter
 
onebadf150's Avatar
 
Join Date: Dec 2008
Location: New Orleans
Posts: 1,683
Points: 34,392
Thanks: 46
Thanked 54 Times in 40 Posts
Quote:
Originally Posted by F350Kevin
There are alot of possibilities. Here are two that happend to me:

1. After I added an AFE intake, got a CEL and had to replace egr valve. Luckily it was under warranty. Haven't had any more problems with that and been a few thousand miles since.

2. I got a CEL the other day, it was only on for a short time, then went off, dealer read the code and said it was the thermostat is reading a wrong temperature, but the temp was really fine. Dealer said Ford is starting to have a problem with this code. We will watch and see what happens.

Good Luck,
Kevin
cool awesome info !
onebadf150 is offline  
post #10 of 11 (permalink) Old 01-13-2008, 01:13 AM
 
Join Date: Mar 2006
Posts: 1,592
Points: 53,198
Thanks: 0
Thanked 1 Time in 1 Post
ill bet your cel is coming on from the maf sensor reading a higher air flow.
the pcm will use the maf and other sensors to confirm a regen, the pcm reads the maf sensor feedback then confirms there is no need for a cold idal/regen/bcp or pto engagement and turns the light on. then you do a key cycle (turn it off then start it again) the maf reads right and no light until the maf reads a higher than expected value again.
imported_diesel71 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome