Mack E7-350 - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Provo, this thread has received 0 replies and been viewed 204 times.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-11-2017, 03:43 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 6
Points: 468
Thanks: 0
Thanked 0 Times in 0 Posts
Mack E7-350

We have just fitted a new injector pump, the engine is running, but it not idle, it "surges" high to low

Anyone have any ideas on the problem?
Provo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mack E6-350 timing nevrenufhp Medium and Heavy Duty 4 10-01-2016 02:20 PM
Mack EM6 Engines 300 and 350 cumminsdude2001 Medium and Heavy Duty 25 04-12-2009 03:48 PM
350 Mack engine. Info M123KT-450 Medium and Heavy Duty 39 03-10-2009 02:52 AM
350 Mack jforce05 Medium and Heavy Duty 4 05-03-2007 11:21 PM
93 Mack E7 350 water in oil 2006copperPSD Medium and Heavy Duty 21 12-31-2006 03:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome