Turbo Boots - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by broth, this thread has received 2 replies and been viewed 1066 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-08-2011, 04:09 PM Thread Starter
Member
 
Join Date: Jan 2009
Posts: 278
Points: 24,551
Thanks: 33
Thanked 10 Times in 10 Posts
Turbo Boots

Tore another boot towing this weekend. I have 08 with spartan tune. I run the 210 tune. I have had terrible time with boots. Stock ones did alright but blew several off and tore two of them. I tried the dieselsite boots those blew off and tore. Got a set of Riffraff ones those have held the best but tore one this weekend. I have double clamped and tried using tie wire to help hold the pipe in place. I just don't understand why I am having so many problems. I honestly don't even run the truck that hard try not to ever boost over 30 PSI when I am towing but many guys claim they are seeing over 50 PSI. I do tow a 40' heavy 5th wheel tow hauler and my truck is lifted with 37's but plenty of guys run the same set up. I am at a lost. Love the truck but this is about my 10th boot and it is getting old. Of course it always happens at the worst time and leaves you stranded until you get a new boot on there.

Any ideas?
broth is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-11-2011, 01:28 AM
Junior Member
 
Join Date: Dec 2010
Posts: 17
Points: 49,062
Thanks: 0
Thanked 0 Times in 0 Posts
Broth I'm not sure what the problem with the intercooler boots may be I run the 250 tune with 35's and have never had a problem I have the bd intercooler pipe on my truck as well and upgraded the clamps when I put the intercooler pipe on I'm sure your already using the the good stainless steel clamps but check your torque on them when you get a chance, I would also check the intercooler for loose mounts, just my two cents, do the boots always blow off when ur under heavy load or will it happen anytime no matter what boost your at?
squamishf350 is offline  
post #3 of 3 (permalink) Old 03-11-2011, 03:53 PM Thread Starter
Member
Threadstarter
 
Join Date: Jan 2009
Posts: 278
Points: 24,551
Thanks: 33
Thanked 10 Times in 10 Posts
Only under a heavy load and has happen with as little as 30 PSI boost while towing heavy only. I check the clamps each time before I tow to make sure they are tight because I have had such a problem. I will check the intercooler as well.
broth is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo boots broth 2008-2010 6.4L Engine Tuner Forum 30 09-14-2010 11:21 PM
Where Can I find some good turbo boots? strawboss Diesel Conversion 2 05-28-2009 03:39 PM
Turbo boots 2tonePSD 1994-2003 7.3L Power Stroke 11 10-15-2007 02:41 PM
ipr and turbo boots marckluever Supporting Vendors Forum 1 07-06-2007 04:11 PM
Where can I order turbo boots? Southern4x4 1994-2003 7.3L Power Stroke 1 05-02-2007 03:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome