Hey guys new here. - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by s.stoker, this thread has received 10 replies and been viewed 1316 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 03-19-2010, 03:57 AM Thread Starter
Junior Member
 
Join Date: Mar 2010
Posts: 5
Points: 351
Thanks: 0
Thanked 0 Times in 0 Posts
Hey guys new here.

I have an '09 6.4. Bought the truck with 62k miles on it. Has a sparton and a dpf delete. The truck was running great. But the last two days it starts and dies. Will not restart unless its reflashed or if it sits for a couple of hours.
Never throws and codes. Any ideas?
Thanks Steve.
s.stoker is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 03-19-2010, 04:17 AM
I Eat Rice
 
forcefed6.4ford's Avatar
 
Join Date: Dec 2008
Location: next door to you
Posts: 2,155
Points: 51,502
Thanks: 29
Thanked 190 Times in 157 Posts
crawl under the truck and check all the exhaust sensors. Usually when the go out the throw a code. But stranger things have happened.

How are the battaries?

Lets just say not quite stock.
Slower than some. Faster than most.
Canadian Club Member #10.
Ridin High Club Member #24
Singles Club Member #469

"There is no try. Only do... That is why you fail" Yoda. The wisest green piece of rubber ever created.

2008 King Ranch/Harley mix. Spartan tuned. Elite studs, Cobbs EGR delete plates. FabTech 6" 4 link with dual 2.25" remote shocks. 18" 778 Monsters 35-12.5-18 Toyo MT's DDM 35w HID's 6000K hi/lo and fogs.
forcefed6.4ford is offline  
post #3 of 11 (permalink) Old 03-19-2010, 04:53 AM
Educated Amateur
 
JYFarmer's Avatar
 
Join Date: Oct 2005
Location: SE Missouri
Posts: 90
Points: 3,119
Thanks: 15
Thanked 1 Time in 1 Post
Garage
Does it die going down the road? I heard its pretty hard for this truck to just shut off. Flash your truck back to stock and the read your Fuel Rail Pressure on your DD.

EGR Delete, Hedstuds, and Rudy's BOV/Intake Elbow ordered!

Pics coming soon.

If really interested go here https://thedieselgarage.com/forums/dt...ehicle_id=1426

Special thanks to Rudys, and Spartan.... not so much with Recon.

If your gonna do it, do it right the first time
"You can polish a turd up all you want, its still a piece of $hi%"-me.

To quote a guy on here, "If Obama is the answer, it was a dumb ### question".

OIF III vet......... Love my country, but if we had to fight WW2 with my generation, we'd loose and it pisses me off to high hell!

Open to critiques/advice. PM me

Singles Club member #258
JYFarmer is offline  
post #4 of 11 (permalink) Old 03-19-2010, 11:39 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Mar 2010
Posts: 5
Points: 351
Thanks: 0
Thanked 0 Times in 0 Posts
All the sensors ohm out at 215ohms. I have tried to reflash to stock. Same thing it starts idles for a little while than dies. While idling it make 5400-6200 psi rail pressure than falls off and dies. I can't be a pump issue. If it was it wouldn't come back alive after a reflash. Something has to be telling it to die.
I thought it might be the batts so I replaced them with red tops and no change. I bought the truck right due to Ford already voided its warranty. The owner was a dumb***** and brought it in with everthing on it.

I ran a lift pump check and it make 9psi and holds it while it runs for the little while it runs.

I can't tell you if it will die going down the road. It won't stay running long enough to put it in gear.
s.stoker is offline  
post #5 of 11 (permalink) Old 03-20-2010, 02:54 AM
Junior Member
 
Join Date: Feb 2009
Location: Jay,OK
Posts: 26
Points: 3,633
Thanks: 15
Thanked 0 Times in 0 Posts
MY truck did the same recently, it ran fine the day before,next day I go to leave and it would start but would die after just a few seconds.It would not run enough to even back out of my driveway. My truck is stock with 43k mileage. Towed it to the dealer and they replaced the EGR valve,DPF,and CAT. I wonder with your truck if it could be the EGR valve.
OK RHINO is offline  
post #6 of 11 (permalink) Old 03-22-2010, 01:35 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Mar 2010
Posts: 5
Points: 351
Thanks: 0
Thanked 0 Times in 0 Posts
I'm sorry I should have put this in. It also has a full egr delete kit on it.

I noticed something today. While cranking after it dies. It throws white smoke. I believe its fuel. Also everyonce in awhile when I can get it to start it fuel knocks. With out going to the dealer how can a guy test the injectors? Or do a fuel return test?
s.stoker is offline  
post #7 of 11 (permalink) Old 03-22-2010, 02:57 AM
Junior Member
 
SpartanTechII's Avatar
 
Join Date: Feb 2010
Posts: 2
Points: 16,317
Thanks: 0
Thanked 0 Times in 0 Posts
Chances are the EGR valve needs to be replaced.
SpartanTechII is offline  
post #8 of 11 (permalink) Old 03-22-2010, 03:03 AM
Senior Member
 
Join Date: Dec 2008
Location: Little Smoky
Posts: 1,415
Points: 38,125
Thanks: 42
Thanked 105 Times in 104 Posts
he says his egr is deleted. can you get someone to crank it for you next time possibly and smell the smoke?

2008 F-350 Lariet 6.4L 170,000 km spartan tuned 275 daily
2006 yamaha Vmax
2003 F-350 XLT 6.0L just bought 215,000 km all stock for now.
2003 suzuki 1000 GSX-R
1993 F-250 460
1978 F-150 stock waiting for a paint job

Near GP alberta.

CC#58
budtoh3zo is offline  
post #9 of 11 (permalink) Old 03-22-2010, 03:07 AM
Junior Member
 
SpartanTechII's Avatar
 
Join Date: Feb 2010
Posts: 2
Points: 16,317
Thanks: 0
Thanked 0 Times in 0 Posts
Monitor your fuel rail pressure when cranking.
SpartanTechII is offline  
post #10 of 11 (permalink) Old 03-22-2010, 01:24 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Mar 2010
Posts: 5
Points: 351
Thanks: 0
Thanked 0 Times in 0 Posts
If the truck sits over night it gose right up to 5200+ and fires off. When it kills it will make and kinds off different numbers. I've seen 100 psi and not change I've seen 1000psi and not go up while cranking. It seems to stay at whatever it was when it died.

My thoughts are if when cranking there is no resistance against the injection pump it can not build up pressure. I'm wondering about injectors.
s.stoker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hey 6.7 Guys! hccumminssmoke 6.7L Cummins (2007.5-2011) 8 04-28-2009 03:00 PM
need help guys! imported_7inchstack 5.9L Cummins 12 Valve (1994-1998.5) 7 04-28-2008 04:19 AM
hey, guys what might cause this? dieselboy04' Duramax 2004.5-2005(LLY) 6 04-26-2008 01:44 AM
Hey guys NCdieselguy Introductions 10 05-25-2006 11:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome