05 international 9200I - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by rickyd, this thread has received 0 replies and been viewed 845 times.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-18-2016, 10:01 PM Thread Starter
Junior Member
 
Join Date: Sep 2016
Posts: 2
Points: 315
Thanks: 0
Thanked 0 Times in 0 Posts
05 international 9200I

changed the rod bearings, main bearings and rings on pistons. we chaged injector tubes with new o rings on injectors. unhooked batteries for 3 weeks. runs good but has no power cant hear the turbo whistle and no pull power in the tenth gear. what could it be?
rickyd is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
International Laser45v Introductions 0 07-21-2016 12:01 AM
9200i speedometer calibration 2001 International garymack53 Medium and Heavy Duty 1 08-22-2013 01:59 AM
86 International FatPipes Heavy Duty Rebuilds / Rides 10 03-29-2010 12:31 AM
My first International CrowsSynthetics The Parking Lot 21 04-25-2009 12:55 PM
New International KWT800 Medium and Heavy Duty 18 02-20-2008 02:32 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome