Rough idle - troubleshoot ideas needed - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by eco-rich, this thread has received 12 replies and been viewed 1930 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 04-14-2014, 11:56 PM Thread Starter
Junior Member
 
Join Date: Mar 2011
Location: Gig Harbor WA / Cave Creek AZ
Posts: 66
Points: 12,218
Thanks: 12
Thanked 19 Times in 16 Posts
Garage
Rough idle - troubleshoot ideas needed

Well it just started today.
Feels like a spark plug misfire at idle.
It began during nice warm weather, 'bout 80 degrees here in Phoenix area.
Truck was already warmed up from earlier run this morning.

Power is good. . .just at idle does it rough up.
This is a new tank of fuel. . .I filled it yesterday when it was almost empty - so that tank of fuel is getting to it now.

I have the ScanGuage II installed but don't know what readings to look for.
Can anyone provide any ideas?

eco-rich is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 04-15-2014, 02:46 AM
Senior Member
 
Weld engineer's Avatar
 
Join Date: Apr 2012
Location: Middle of the Mitten, MI
Posts: 1,324
Points: 48,513
Thanks: 866
Thanked 506 Times in 401 Posts
Garage
How do your FICM voltages look?

Do you run Archoil or Rev-x? How many miles on the oil change?

Not sure if the SGII can be programmed for cylinder contribution but the auto enginuity can. This would tell you which injector is possibly the issue.

Early 2004 F-250 4x4 CC 6.0


2nd owner, ARP studs 1 at a time, Some parts missing in the exhaust path, BD intercooler hoses, Blue spring, MC filters, Sinister coolant filter, Exhaust manifold gaskets, WARN lockouts, Gold coolant, zoodad mod, autometer boost gauge, high idle mod, Scangauge 2, SCT X3 tuned from KEM, autometer fuel pressure gauge, Archoil 6200 in the fuel, FICM by Ed w/ATLAS40, autometer pyro gauge,'08 Alum Rear Diff cover, 5w-40 Rotella T6 w/ Archoil 9100 in it, zert in the slip joint, harpooned fuel tank, 6.4 banjos


Not a diesel mechanic in real life but I play one on the Internet
Weld engineer is offline  
post #3 of 13 (permalink) Old 04-15-2014, 03:33 AM
Stuck in Commiefornia...
 
IdahoF350's Avatar
 
Join Date: Dec 2008
Location: Clearfield, Utah
Posts: 1,296
Points: 81,427
Thanks: 102
Thanked 447 Times in 315 Posts
Garage
Check the FICM voltage in your scan gauge II, also check ICP (injection control pressure). If FICM voltage is 48v+ at idle and ICP is 600+psi it's likely just bad fuel. If you want to verify, remove the fuel filter on top of the engine and give it a good look for water droplets and a good smell to see if it smells abnormal like kerosene, jet fuel, or gasoline. Sudden change though and I'm going to stick with bad fuel. Run the tank down or drain it, change both filters and fill with fuel from a trusted source.

The Current Truck (Oct-2013 to Present):
1999 (Early) F-350 Lariat, CCLB, SRW, Black/Tan

7.3L Powerstroke, 4R100, 4x4, 3.73, 37x13.50-18s, '05 Axle Swap, 6" Fabtech lift, GTP38 "D66" turbo upgrade, SCT 4-position chip with custom tuning by me, Straight Piped 4" down pipe through 5" dual stacks, N-Fab full length triple steps, Pro-Tech cab guard and tool box, louvered 5th wheel gate, Hella 500 Fog and Driving lamps, much more to come...
The one I'll miss, (Mar-2009 to Jan-2014):
2000 Excursion XLT 4x4

6.8L V-10, 4R100, 4.30, 285/75-18, 271whp / 388wtq
The one I won't, (Jul-2005 to Sep-2012):
2005 F-350 XLT, CCLB, SRW, 4x4 FX4

6.0L PSD, ZF-6S650, 3.73, 35x12.5-18, 4.5" Lift
IdahoF350 is offline  
The Following User Says Thank You to IdahoF350 For this addition to TDG:
eco-rich (04-15-2014)
post #4 of 13 (permalink) Old 04-15-2014, 03:34 AM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,060
Thanks: 1,507
Thanked 990 Times in 755 Posts
1. make sure the x-gauge commands are programmed into your ScanGauge
2. check for fault codes
3. check ficm main power voltage...47-49v (like Weld mentioned)
4. check your fuel...smell the fuel cap and make sure no gasoline is in the fuel...some stations have accidently filled the diesel tanks with gasoline, has happened more often than you think.

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
post #5 of 13 (permalink) Old 04-15-2014, 03:35 AM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,060
Thanks: 1,507
Thanked 990 Times in 755 Posts
Idaho beat me to it!

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
The Following User Says Thank You to harry6.0 For this addition to TDG:
IdahoF350 (04-15-2014)
post #6 of 13 (permalink) Old 04-15-2014, 02:12 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Mar 2011
Location: Gig Harbor WA / Cave Creek AZ
Posts: 66
Points: 12,218
Thanks: 12
Thanked 19 Times in 16 Posts
Garage
FICM volts are good all the time.
I have not checked the ICP - yet.

Oil change is approximately 3000 miles ago.
I run Archoil - and have for almost two years now.
Fuel filters were changed a few thousand miles ago.

I forgot to ask. . .if it is a bad injector, will it get worse? Slowly or quickly?

eco-rich is offline  
post #7 of 13 (permalink) Old 04-16-2014, 03:17 AM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,060
Thanks: 1,507
Thanked 990 Times in 755 Posts
If it's a failed injector and it's bad enough to cause a consistant misfire, then it will most likely not get better. Should throw an injector-cylinder contribution fault code if it's a bad misfire.

Weird though that it's fine off idle, usually when an injector goes out it misfires at all rpm's.

Icp pressures should hold fairly steady at idle, maybe just try unplugging the icp sensor and see if it smooths out.

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
post #8 of 13 (permalink) Old 04-16-2014, 02:33 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Mar 2011
Location: Gig Harbor WA / Cave Creek AZ
Posts: 66
Points: 12,218
Thanks: 12
Thanked 19 Times in 16 Posts
Garage
Yesterday morning it started and ran smoothly at idle.
ICP was over 600 at idle.

As it warmed up it quickly began the rough idle again.
The roughness could (barely) be felt all the way up to about 2000 rpm where it became undetectable.

Ran a few miles, up to 55 mph, did a few errands and returned home.
I noticed that when coasting to a stop (engine basically at idle during that time) the ICP would drop to 585.

Weirder yet, got it home in the driveway and the idle had smoothed out to normal.
Anyway - I've nothing new to add and will look at the icp sensor and fuel filter later today.

Thank you all for the pointers.

eco-rich is offline  
The Following User Says Thank You to eco-rich For this addition to TDG:
harry6.0 (04-18-2014)
post #9 of 13 (permalink) Old 04-19-2014, 12:26 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Mar 2011
Location: Gig Harbor WA / Cave Creek AZ
Posts: 66
Points: 12,218
Thanks: 12
Thanked 19 Times in 16 Posts
Garage
It's going into the Ford shop on Monday.
We drove it today about 40 miles - both freeway and surface streets.
The idle smoothed out, but now it smokes like a coal fired industrial plant.
No tailgaters drive behind me now.

The smoke looks a lot like the truck in this video:
https://www.youtube.com/watch?v=5ngEOi3jcC0

eco-rich is offline  
post #10 of 13 (permalink) Old 04-19-2014, 03:14 AM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,060
Thanks: 1,507
Thanked 990 Times in 755 Posts
If the whiteish smoke smells like raw diesel fuel and smokes as bad as the video you posted, then I wouldn't drive it except to get it in for repair. Certainly don't want a hydro-lock situation. Have had a few members over the years lose an injector tip and boom, that was it.

Good luck on the repair outcome, hopefully it's just one injector, but may consider doing the whole bank if they are all originals.

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle up, No idle up any ideas? SMN 1994-2003 7.3L Power Stroke 0 01-23-2012 02:18 AM
08 6.4 rough idle 6L strokin 2008-2010 6.4L Engine Tuner Forum 26 07-07-2010 02:28 PM
rough idle Dozer 2003-2007 6.0L Power Stroke 13 03-23-2009 04:16 AM
another weird idle ?, rough idle oh3_6oh 2003-2007 6.0L Power Stroke 3 01-09-2008 05:48 AM
got the rough idle StuckinMud 2003-2007 6.0L Power Stroke 0 10-03-2006 10:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome