6.0 turbo problems - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by UnderpressureNM, this thread has received 16 replies and been viewed 1842 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 06-06-2014, 10:42 PM Thread Starter
Underpressure76nm
 
Join Date: May 2014
Location: Northern New Mexico
Posts: 31
Points: 22,554
Thanks: 18
Thanked 6 Times in 5 Posts
Garage
Thumbs down 6.0 turbo problems

Truck sucks off the jump (literally) once up to second turbo kicks in,,but remembering back this truck could spin my tires if I held the brake. These days it won't, ford put a turbo under warranty (years ago)or did they?,, anyways yesterday went into limp mode and I found a small tear on the map senser hose but I'm also feeling air leaking from the turbo clamp holes on the manifold? Is this right?

Last edited by UnderpressureNM; 06-06-2014 at 10:46 PM.
UnderpressureNM is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 06-06-2014, 11:51 PM
Old Fart
 
dbennett48's Avatar
 
Join Date: Nov 2009
Location: Ukiah, Ca
Posts: 889
Points: 53,641
Thanks: 194
Thanked 180 Times in 155 Posts
Garage
No. You have at least one leak in the turbo to intercooler to engine lines. All of these connections need to be air tight. There are several large hose clamps that may be leaking. Try to tighten these up and see if this solves your problem. Replace the MAP sensor hose. By the way, what are you trying to fix? Add this information to your signature by going to the USER CP.

Dave

2004 Ford F-350 Regular cab with 6.0.
Completely Stock.

KK6TNI - HAM Radio

http://bennettlaneshopping.com/ - Our Outdoor/Garden and Kitchen Ware store
dbennett48 is offline  
The Following User Says Thank You to dbennett48 For this addition to TDG:
UnderpressureNM (06-07-2014)
post #3 of 17 (permalink) Old 06-07-2014, 01:22 AM Thread Starter
Underpressure76nm
Threadstarter
 
Join Date: May 2014
Location: Northern New Mexico
Posts: 31
Points: 22,554
Thanks: 18
Thanked 6 Times in 5 Posts
Garage
I checked everything all clamps I'm going to put new ones but they all look good, except the smallest one turbo to intercooler had some fraying in it and hairline cracks so I'm replacing it. sorry it's a 2004 powerstroke 6.0, just got it running put egr delete and new oil cooler while I was in there all new gaskets, new oil coolant ect, ran good then just no power I've blown boots off before but the truck doesn't even want to shift(barely at 3300) into second and third. I replaced map hose and nothing,

2004 6.0 king ranch 350 adt egr delete, adt egr cooler, scanguage 2, k&n intake and filter,blue spring upgrade,banks exhaust from turbo back 4" 5th wheel and wood hauler
UnderpressureNM is offline  
post #4 of 17 (permalink) Old 06-07-2014, 03:14 AM
Senior Member
 
Weld engineer's Avatar
 
Join Date: Apr 2012
Location: Middle of the Mitten, MI
Posts: 1,324
Points: 48,511
Thanks: 866
Thanked 506 Times in 401 Posts
Garage
I'd suggest some aftermarket boots and clamps. I like the BD ones I put on never blown a boot off since.

Dbennett is referring to your truck info in your signature. It eliminates the guessing game.

Early 2004 F-250 4x4 CC 6.0


2nd owner, ARP studs 1 at a time, Some parts missing in the exhaust path, BD intercooler hoses, Blue spring, MC filters, Sinister coolant filter, Exhaust manifold gaskets, WARN lockouts, Gold coolant, zoodad mod, autometer boost gauge, high idle mod, Scangauge 2, SCT X3 tuned from KEM, autometer fuel pressure gauge, Archoil 6200 in the fuel, FICM by Ed w/ATLAS40, autometer pyro gauge,'08 Alum Rear Diff cover, 5w-40 Rotella T6 w/ Archoil 9100 in it, zert in the slip joint, harpooned fuel tank, 6.4 banjos


Not a diesel mechanic in real life but I play one on the Internet
Weld engineer is offline  
The Following 2 Users Say Thank You to Weld engineer For this addition to TDG:
dbennett48 (06-07-2014), UnderpressureNM (06-07-2014)
post #5 of 17 (permalink) Old 06-07-2014, 04:18 AM Thread Starter
Underpressure76nm
Threadstarter
 
Join Date: May 2014
Location: Northern New Mexico
Posts: 31
Points: 22,554
Thanks: 18
Thanked 6 Times in 5 Posts
Garage
Thanks for the replies

All hoses look good the truck takes forever to shift also like it's not building pressure? I just put new ipr in and two days later it was junked up(screen). Put new ipr ran okay for two more days now no power, I also found oil right before the intake elbow in the hose,

2004 6.0 king ranch 350 adt egr delete, adt egr cooler, scanguage 2, k&n intake and filter,blue spring upgrade,banks exhaust from turbo back 4" 5th wheel and wood hauler
UnderpressureNM is offline  
post #6 of 17 (permalink) Old 06-07-2014, 04:21 AM Thread Starter
Underpressure76nm
Threadstarter
 
Join Date: May 2014
Location: Northern New Mexico
Posts: 31
Points: 22,554
Thanks: 18
Thanked 6 Times in 5 Posts
Garage
Lightbulb

But the turbo is leaking from the housing clamp holes why is that

2004 6.0 king ranch 350 adt egr delete, adt egr cooler, scanguage 2, k&n intake and filter,blue spring upgrade,banks exhaust from turbo back 4" 5th wheel and wood hauler
UnderpressureNM is offline  
post #7 of 17 (permalink) Old 06-07-2014, 04:33 AM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,055
Thanks: 1,507
Thanked 990 Times in 755 Posts
Quote:
Originally Posted by UnderpressureNM View Post
But the turbo is leaking from the housing clamp holes why is that
Can you point out the leak location from any of these pics...

http://www.backglass.org/duncan/ps60...l/ps60_031.jpg

http://www.backglass.org/duncan/ps60...l/ps60_034.jpg

http://www.backglass.org/duncan/ps60...l/ps60_036.jpg

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
The Following User Says Thank You to harry6.0 For this addition to TDG:
UnderpressureNM (06-07-2014)
post #8 of 17 (permalink) Old 06-07-2014, 05:57 AM Thread Starter
Underpressure76nm
Threadstarter
 
Join Date: May 2014
Location: Northern New Mexico
Posts: 31
Points: 22,554
Thanks: 18
Thanked 6 Times in 5 Posts
Garage
There's tiny holes if your looking at the Vgt solenoid there's a clamp that goes around the turbo housing it has a couple tiny holes one on each side of the turbo a little smaller than a ballpoint pen I'm getting air from those

2004 6.0 king ranch 350 adt egr delete, adt egr cooler, scanguage 2, k&n intake and filter,blue spring upgrade,banks exhaust from turbo back 4" 5th wheel and wood hauler
UnderpressureNM is offline  
post #9 of 17 (permalink) Old 06-07-2014, 06:00 AM Thread Starter
Underpressure76nm
Threadstarter
 
Join Date: May 2014
Location: Northern New Mexico
Posts: 31
Points: 22,554
Thanks: 18
Thanked 6 Times in 5 Posts
Garage
{\rtf1\ansi\ansicpg1252
{\fonttbl\f0\fnil\fcharset0 HelveticaNeue;}
{\colortbl;\red255\green255\blue255;\red34\green34 \blue34;}
\deftab720
\pard\pardeftab720\qc\partightenfactor0

\f0\fs30 \cf2 \expnd0\expndtw0\kerning0
\outl0\strokewidth0 \strokec2 \
}

2004 6.0 king ranch 350 adt egr delete, adt egr cooler, scanguage 2, k&n intake and filter,blue spring upgrade,banks exhaust from turbo back 4" 5th wheel and wood hauler
UnderpressureNM is offline  
post #10 of 17 (permalink) Old 06-07-2014, 06:02 AM Thread Starter
Underpressure76nm
Threadstarter
 
Join Date: May 2014
Location: Northern New Mexico
Posts: 31
Points: 22,554
Thanks: 18
Thanked 6 Times in 5 Posts
Garage
If you look up [picture of Vgt solenoid on 6.0 diesel) you can see a picture by diesel power of the little holes where I'm getting air from on google search appreciate your guys help very much

2004 6.0 king ranch 350 adt egr delete, adt egr cooler, scanguage 2, k&n intake and filter,blue spring upgrade,banks exhaust from turbo back 4" 5th wheel and wood hauler
UnderpressureNM is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo problems??? BrianHonda629 2003-2007 6.0L Power Stroke 14 09-11-2010 08:48 PM
Turbo problems again StrokingForFun 2003-2007 6.0L Power Stroke 5 12-17-2009 02:31 PM
turbo problems sawmillman Duramax 2004.5-2005(LLY) 0 02-29-2008 02:06 AM
Turbo Problems Rusty-Carlton 1994-2003 7.3L Power Stroke 11 03-29-2007 04:28 AM
01 7.3 turbo problems Rave 1994-2003 7.3L Power Stroke 16 09-15-2006 01:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome