Tranny Codes / Request Advice - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by pstrang, this thread has received 36 replies and been viewed 13502 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 37 (permalink) Old 10-22-2014, 04:55 AM Thread Starter
Member
 
Join Date: Dec 2008
Location: In my truck.
Posts: 444
Points: 60,422
Thanks: 105
Thanked 47 Times in 44 Posts
Tranny Codes / Request Advice

Tranny *seems* to be working normally (temperature, forward, and reverse). However, when I engage Tow/Haul mode, after the 1st shift, the Tow/Haul light begins flashing. Everything still seems to work nominally (reverse, low range, tow/haul) except I think I'm starting in 2nd gear from a stop.

Here are the codes I read:

P0771 - Powertrain
Shift Solenoid "E" Performance or Stuck Off
P2704 - Powertrain
Trans Friction Element E Apply Time Range/Ref

Solenoid E is for low/reverse. Reverse works, although it engages a bit more harsh than before, but nothing anyone else would notice. Low range seems fine.

This started when I returned to my DD SCT Innovative tune after removing the TowMax SCT Innovative tune during the summer season. Things I've tried: disconnect batteries/drained KAM; reflashed, checked fluid and level; all clean and good.

Advice? Should I drop the pan and replace SSPC-E solenoid? Pressure switch? Should I swap the DD SSPC-D solenoid for an aftermarket one while I'm in there? TFT sensor?

Thank you!

2005-6L/PSD F-250 Lariat CC/SB/4x4:
- MBRP 4" turbo back, Dieselsite coolant bypass filter, Frantz oil bypass filter, X-monitor, Fluidampr, fuel x-over line, intake elbow, EGR cooler delete, wrapped headers and turbo, ARP studs, OEM gaskets, ported heads and manifolds to match, Hot FICM w/ ID Flash, 08+ tranny pan/filter.
pstrang is offline  
Sponsored Links
Advertisement
 
post #2 of 37 (permalink) Old 10-22-2014, 02:09 PM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,022
Thanks: 1,507
Thanked 990 Times in 755 Posts
If the transm is still acting up with a different tune loaded, then your approach of dropping the pan and replacing solenoids and sensor is probably a good idea. The inside bottom of the pan once dropped is always a good indicator of transm health, slight metallic and minimal dark fine clutch material is normal, but if you find any chunks of debri or large metallic flakes, then that could spell teardown.

You can also remove the bypass canister transm filter up under the passenger side radiator area and see what is looks like inside, and of course replace it as well.

My tow haul wires shorted out in my shift lever-column last summer, but that blew the fuse for the instrument cluster and the transm still shifted normal but had no tow haul function.

It is kinda coincidental that this all happened after reloading your DD tune, but maybe the higher power tune enhanced an issue that was already lurking.

Good luck and keep us posted.

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
The Following User Says Thank You to harry6.0 For this addition to TDG:
pstrang (10-22-2014)
post #3 of 37 (permalink) Old 10-23-2014, 03:15 PM Thread Starter
Member
Threadstarter
 
Join Date: Dec 2008
Location: In my truck.
Posts: 444
Points: 60,422
Thanks: 105
Thanked 47 Times in 44 Posts
Returned to stock tune. As before, tranny runs perfectly normal until I select Tow/Haul mode. Then once it shifts into 2nd, Tow/Haul starts blinking and when I stop, it stays in 2nd gear. Only difference now is the truck runs in limp mode. With the ID tune, it didn't limp, just flash Tow/Haul. Same error codes.

I ordered parts and will update when I get the pan dropped.

Thanks.

2005-6L/PSD F-250 Lariat CC/SB/4x4:
- MBRP 4" turbo back, Dieselsite coolant bypass filter, Frantz oil bypass filter, X-monitor, Fluidampr, fuel x-over line, intake elbow, EGR cooler delete, wrapped headers and turbo, ARP studs, OEM gaskets, ported heads and manifolds to match, Hot FICM w/ ID Flash, 08+ tranny pan/filter.
pstrang is offline  
The Following User Says Thank You to pstrang For this addition to TDG:
harry6.0 (10-24-2014)
post #4 of 37 (permalink) Old 11-01-2014, 04:22 AM Thread Starter
Member
Threadstarter
 
Join Date: Dec 2008
Location: In my truck.
Posts: 444
Points: 60,422
Thanks: 105
Thanked 47 Times in 44 Posts
Update

Parts finally all arrived.

1) Dropped the pan. It could not have been more clean! (attached picture) Good news.
2) Replaced TFT sensor, SSPC-E, pan filter, and bypass filter.
3) Installed a PTP Modified Direct Clutch Solenoid in place of SSPC-D.
4) Filled with new Mercon SP.

However, the problem still exists. In Tow/Haul mode, when it shifts into 2nd, Tow/Haul starts blinking and it doesn't shift below 2nd when I stop. Tow/Haul seems to work when I turn it on in 6th gear; downshifts normally. But when I stop and start again in Tow/Haul, the problem pops up.

Also, I expected I would need to adjust my ID tune shift pressures down with the PTP solenoid. But I can't really tell the modified solenoid difference in shifting.

Thanks for any further advice!
Attached Thumbnails
Click image for larger version

Name:	IMG_20141029_205052.jpg
Views:	426
Size:	1.06 MB
ID:	36962  

2005-6L/PSD F-250 Lariat CC/SB/4x4:
- MBRP 4" turbo back, Dieselsite coolant bypass filter, Frantz oil bypass filter, X-monitor, Fluidampr, fuel x-over line, intake elbow, EGR cooler delete, wrapped headers and turbo, ARP studs, OEM gaskets, ported heads and manifolds to match, Hot FICM w/ ID Flash, 08+ tranny pan/filter.
pstrang is offline  
The Following User Says Thank You to pstrang For this addition to TDG:
harry6.0 (11-02-2014)
post #5 of 37 (permalink) Old 11-01-2014, 08:04 PM Thread Starter
Member
Threadstarter
 
Join Date: Dec 2008
Location: In my truck.
Posts: 444
Points: 60,422
Thanks: 105
Thanked 47 Times in 44 Posts
More testing....

I found that when I start in Tow/Haul mode and accelerate from a stop, the problem does *not* exhibit itself. It's when I'm in Tow/Haul and coast downhill that it fails when shifting into 2nd gear. My house is on a little hill so the downhill deal is my typical run.

Wire chafing somewhere? Steering column? Under the truck?
SSPC-E pressure switch (which I did not replace)?
I hope it isn't the tranny fluid pump. That's deep in the tranny.

Same error codes as in the OP.

Thanks for any advice or suggestions anybody can offer.

2005-6L/PSD F-250 Lariat CC/SB/4x4:
- MBRP 4" turbo back, Dieselsite coolant bypass filter, Frantz oil bypass filter, X-monitor, Fluidampr, fuel x-over line, intake elbow, EGR cooler delete, wrapped headers and turbo, ARP studs, OEM gaskets, ported heads and manifolds to match, Hot FICM w/ ID Flash, 08+ tranny pan/filter.

Last edited by pstrang; 11-01-2014 at 08:06 PM.
pstrang is offline  
The Following User Says Thank You to pstrang For this addition to TDG:
harry6.0 (11-02-2014)
post #6 of 37 (permalink) Old 11-02-2014, 01:37 AM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,022
Thanks: 1,507
Thanked 990 Times in 755 Posts
Nice and clean pan, but I'm sorry the repair was unsucessful.

You could check the column harness wires like I found here...
https://www.thedieselgarage.com/forum...d.php?t=143657
on my truck, but mine would blow the fuse when shifting into low.

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
The Following User Says Thank You to harry6.0 For this addition to TDG:
pstrang (11-02-2014)
post #7 of 37 (permalink) Old 11-03-2014, 01:45 AM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,022
Thanks: 1,507
Thanked 990 Times in 755 Posts
I found this info below here, even though you probably have already found it too...
https://www.motorcraftservice.com/vd...BDSM804_64.pdf
it's for the 6.4L, but it has a ton of info about the 5R110W starting on page 54.

I copied the section with your codes below...

Low/Reverse Clutch (SSE) P2704 Transmission Friction Element E apply time range/performance.
P0771 Shift Solenoid E Performance or Stuck Off
P0772 Shift Solenoid E Stuck On
Gears are enabled/disabled based on clutch faults. Example: if the OD clutch is failed off, all gears requiring the ODC to
be on are disabled (2nd, 4th, and 6th gear). If the OD clutch is failed on, only gears with the ODC on are commanded
(only 2nd, 4th, or 6th gear will be commanded, 1st, 3rd, and 5th will be disabled).

It's weird how this is all only triggered after tow haul usage. We have speed sensor failures on our MBZ transm's, they are integrated into the electronic conductor plate that all the solenoids are mounted onto. Not sure if the 5R110W is even remotely similar. But it causes intermittent limp home conditions which keeps it in second gear until you pull over and cycle the key on-off and start driving again.

So after rereading your last post, it occurs only after tow haul downshifts to second, correct?

I'll try to find out more, and maybe someone else on here will chime in with some helpful info too.

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)

Last edited by harry6.0; 11-03-2014 at 02:00 AM. Reason: added a sentence
harry6.0 is offline  
The Following User Says Thank You to harry6.0 For this addition to TDG:
pstrang (11-03-2014)
post #8 of 37 (permalink) Old 11-03-2014, 03:43 PM Thread Starter
Member
Threadstarter
 
Join Date: Dec 2008
Location: In my truck.
Posts: 444
Points: 60,422
Thanks: 105
Thanked 47 Times in 44 Posts
Big thanks!

The document does contain good info. I hope we can assume the TCM in our trucks operates similarly. In my case (from page 61):

Code:
Low/Reverse Clutch System (functional test of SSE):

DTCs
P2704 Low Reverse Clutch Failed On or Off
P0771 Low Reverse Clutch Failed Off
P0772 Low Reverse Clutch Failed On

Monitor execution
LRC failed off  detected in 1M or 2M.
LRC failed on  detected during upshifts from 1st or 2nd to any higher gear, tested in 1st or 2nd after a bad shift event.

Monitor Sequence
Tested in the steady state gear listed above, then after each bad event the clutch is cycled and tested again

Sensors OK
ISS, OSS

Monitoring Duration
3 bad events
In Tow/Haul mode, it uses the LRC (SSE). I'm getting P0771 "Low Reverse Clutch Failed Off". So it's detected in 1M or 2M. I'm not sure what the 'M' means, but I suspect this is just in 1st or 2nd gear.

To detect this, it's using the ISS and OSS sensors. Since the tranny *seems* to shift normally, this would indicate bad feedback from the ISS or OSS sensors.

However, if that's the case, why aren't I getting the DTCs for either the ISS or OSS?

Thanks again!!

2005-6L/PSD F-250 Lariat CC/SB/4x4:
- MBRP 4" turbo back, Dieselsite coolant bypass filter, Frantz oil bypass filter, X-monitor, Fluidampr, fuel x-over line, intake elbow, EGR cooler delete, wrapped headers and turbo, ARP studs, OEM gaskets, ported heads and manifolds to match, Hot FICM w/ ID Flash, 08+ tranny pan/filter.
pstrang is offline  
post #9 of 37 (permalink) Old 11-04-2014, 02:28 AM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,022
Thanks: 1,507
Thanked 990 Times in 755 Posts
Just to clarify so we stay on the same page, the problem surfaces during the 3-2 downshift only in tow-haul, but does not do it when not using tow-haul.

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
post #10 of 37 (permalink) Old 11-05-2014, 07:58 PM Thread Starter
Member
Threadstarter
 
Join Date: Dec 2008
Location: In my truck.
Posts: 444
Points: 60,422
Thanks: 105
Thanked 47 Times in 44 Posts
Quote:
Originally Posted by harry6.0 View Post
Just to clarify so we stay on the same page, the problem surfaces during the 3-2 downshift only in tow-haul, but does not do it when not using tow-haul.

Harry
It surfaces only in tow/haul, and when it coasts in 2nd gear. I've found when I accelerate in tow/haul passed 2nd, it doesn't do it. Only when I try to use engine braking in 2nd gear.

Once the tow/haul starts blinking, the tranny never shifts back to 1st when stopped. Other than that, there are no other noticeable limitations (although stock tune puts me in limp mode).

Thanks!

2005-6L/PSD F-250 Lariat CC/SB/4x4:
- MBRP 4" turbo back, Dieselsite coolant bypass filter, Frantz oil bypass filter, X-monitor, Fluidampr, fuel x-over line, intake elbow, EGR cooler delete, wrapped headers and turbo, ARP studs, OEM gaskets, ported heads and manifolds to match, Hot FICM w/ ID Flash, 08+ tranny pan/filter.
pstrang is offline  
The Following User Says Thank You to pstrang For this addition to TDG:
harry6.0 (11-06-2014)
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oasis report /buying advice request alaskapablo Ford Oasis requests 2 12-28-2011 07:27 AM
03 2500 Throwing 4 DTC codes...need advice. cowboy70 5.9L Cummins (2003-2007.5) 1 09-09-2011 04:22 PM
vendors advice and expert advice needed silverpeteok 5.9L Cummins (1998.5-2002) 11 01-25-2009 11:08 PM
Need advice on what tranny to buy. coreystroke02 1994-2003 7.3L Power Stroke 26 06-28-2007 07:47 AM
need tranny advice dondiesel444 Medium and Heavy Duty 12 08-19-2006 05:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome