Running rough when cruising - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by mabynack, this thread has received 2 replies and been viewed 803 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-30-2014, 07:28 PM Thread Starter
Junior Member
 
Join Date: Oct 2014
Location: Panama City, FL
Posts: 79
Points: 18,345
Thanks: 17
Thanked 17 Times in 14 Posts
Running rough when cruising

I'm having a problem with my truck that has stumped the mechanics. The truck seems to run rough when cruising at light throttle. It feels like I'm randomly tapping on the brake. At first it only happened when ambient temps were over 90. Now it does it any time. I bought a scan gauge and FICM voltages are between 47.5 and 48.5. Injector pressure is between 580 and 3800. It's not throwing any error codes.

It could be a brake problem, but I checked the brake temps and they're all running about 150 degrees after it happened.

One mechanic suggested that it might be transmission problems, but in my experience most transmission problems start with slipping when you start off from a stop or when backing.

The truck is currently in the shop for new head bolts and they're going to check the injectors. In the meantime, I'm a little nervous about taking on a trip.

____________

2006 F-250HD 6.0 Powerstroke
mabynack is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-31-2014, 04:17 AM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,019
Thanks: 1,507
Thanked 990 Times in 755 Posts
I hope they are putting ARP headstuds in and not the oem bolts?

While in there, now is a good time to upgrade all your high pressure oil systems weak links with new...STC HPOP Fitting Update Kit....Oil Rail Stand Pipes...Oil Rail Dummy Plugs.

Your cruising speed stumbling issue could be turbo related or even high pressure oil leakage related. At this point you'll have to wait and see how it runs after it's back together.

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
The Following User Says Thank You to harry6.0 For this addition to TDG:
mabynack (10-31-2014)
post #3 of 3 (permalink) Old 10-31-2014, 05:34 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Oct 2014
Location: Panama City, FL
Posts: 79
Points: 18,345
Thanks: 17
Thanked 17 Times in 14 Posts
New Studs

Yes. New ARP studs, OEM gaskets, new OEM Oil Cooler, Coolant Filter, EGR Cooler Bypass, new oil lines for the turbo.

The turbo was cleaned last year, so hopefully that isn't a problem.
mabynack is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
rough running Dieseldemon61 5.9L Cummins 12 Valve (1994-1998.5) 5 03-09-2009 01:51 AM
running rough droolinforparts 2003-2007 6.0L Power Stroke 4 04-01-2008 02:21 AM
rough running '02 tommy vestrat 1994-2003 7.3L Power Stroke 1 03-30-2008 03:13 AM
rough running 97mt 1994-2003 7.3L Power Stroke 4 03-16-2006 02:13 AM
12 v running rough Whitemare 5.9L Cummins 12 Valve (1994-1998.5) 5 09-24-2005 03:10 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome