2004 Excursion just Dies, HELP? - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by 04EX, this thread has received 1 replies and been viewed 613 times.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-03-2016, 02:59 AM Thread Starter
NEB_EX
 
04EX's Avatar
 
Join Date: Jul 2016
Location: Grand Island, Nebraska
Posts: 2
Points: 589
Thanks: 0
Thanked 0 Times in 0 Posts
2004 Excursion just Dies, HELP?

First post here so be gentle!

2004 late build 6.0, just drove it 2000 miles on a fishing trip, and the day after I got back this started. Went out to get a movie and about 2 miles down the road it just quit/died, coasted to a stop, put it in park and it fired back up. However, as soon as I touch the throttle it dies, sometimes when I lift my foot it will re-fire but other times I have to go to neutral and hit the starter. After a couple weeks of tinkering with it I am still at square 1, It will run ok until its warm then it dies. here are the AE readings at idle.

ICP volts: 0.85
IPR: 22-23%
FICM in:12v
FICM out: 48v (58 Volt Sinister, reads 58v output on the FICM itself)
ICP press: 580-600
FICM sync: yes
Cam/Crank sync: yes and no (goes in and out but never loses FICM sync)
Fuel Press: 72 idle 68 WOT

I have an EGR delete, FASS 150 system, 58v sinister FICM, Coolant filter, Bulletproof Diesel Oil cooler relocation kit, SCT ITSX tuner (returned to stock), Gryphon FICM programmer (returned to stock), AFE intake.

I have replaced: all 3 fuel filters and checked for water, bubbles and filling of the housing with KOEO. New cam position sensor and pigtail. New ICP and pigtail. Batteries test good. wiggled wires but cannot duplicate the stall.

all of the above readings look normal up to WOT on the AE, but i need to graph it instead of just the digital readout.

I am going to run a graph to try and see what happens first to cause the stall tonight, but in the mean time can someone point me in a new direction? I am not so sure about the cam/crank sync going in and out, I have a new crank sensor but rpms are steady and it does not seem to bother it while just idling. One weird thing that does happen, sometimes when I get it started it will kind of run slowly then jump up to idle. Also, twice now when it died, I lost all syncs and had to unplug the ECM and plug it back in to reset them, then started back up. I am so lost. please help!![/SIZE][/SIZE][/SIZE]
04EX is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-08-2016, 02:32 PM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,017
Thanks: 1,507
Thanked 990 Times in 755 Posts
So no fault codes at all ?

Check + clean all battery cable ground points if not already done.

Could be engine wiring harness chaffing issue.

All the values given show a healthy high pressure oil system, however, that doesn't mean all is good, as your truck runs ok until warm could indicate a loose connection or oring failing somewhere in the hp oil system.

Keep us posted on your progress.

Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 EB Excursion Spindrift Vehicles For Sale 2 12-27-2012 08:32 PM
2004 Excursion Limited 4cstr Vehicles For Sale 1 04-21-2011 04:20 PM
2004 Excursion Limited 4x4 JohnNolen Vehicles For Sale 0 02-16-2010 11:09 PM
2004 Excursion Report JohnNolen Ford Oasis requests 1 05-12-2009 09:25 PM
2004 6.0L Excursion jethrow Ford Oasis requests 0 11-28-2007 03:42 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome