blue smoke - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by elctricbluecummins, this thread has received 10 replies and been viewed 6197 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 03-24-2009, 10:02 PM Thread Starter
 
Join Date: Feb 2009
Posts: 14
Points: 1,711
Thanks: 0
Thanked 1 Time in 1 Post
blue smoke

sometimes when im not getting on it too hard my truck lags a little bit and it will blow a little puff of blue smoke does anyone elses do this
elctricbluecummins is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 03-25-2009, 01:27 AM
Senior Member
 
fuzzy's Avatar
 
Join Date: Dec 2008
Posts: 268
Points: 23,472
Thanks: 4
Thanked 55 Times in 55 Posts
Usually a lighter colored smoke is a regen, but most would call it white. But I guess if your going into regen, something is wrong with your delete kit. Maybe set your edge to alert you of a regen, and you can see if that's it.
Could be because the egr is still on also. Dpf delete with a functional egr will smoke a little more, but usually just a little haze of black, which I guess could be confused as a blue. Maybe?????

12 mega dually. garbage gone. mini with od.
fuzzy is offline  
post #3 of 11 (permalink) Old 03-25-2009, 01:21 PM
Built Not Bought
 
SOOTBANDIT's Avatar
 
Join Date: Dec 2008
Location: Columbia Missouri
Posts: 3,072
Points: 78,356
Thanks: 496
Thanked 264 Times in 225 Posts
Images: 9
Like fuzzy said if all you did is unplug and install the plates the egr then it will puff a little blue/white smoke untill you drive a little ways. I know people hate to look at the cel nut put your edge to not clear codes on startup and it should take care of the problem.

2011.5 6.7 HO Crew Cab Laramie Dually 4x4 H&S A-1 H11 Studs GDP Pro Gate AFE drop in Isspro EV2 Boost/EBP RDS 90 Aux Tank/Toolbox Combo Reese 20k 5th wheel

2007 2500 6.7 4x4 Handshaker SOLD



Military Quote Of The Year

________________________________

"When I joined the military it was illegal to be homosexual, then it became optional. I'm getting out before it becomes mandatory."

MSGT Harry T. Serres, USAF Ret.
SOOTBANDIT is offline  
post #4 of 11 (permalink) Old 03-25-2009, 09:46 PM
Senior Member
 
Kummins's Avatar
 
Join Date: Jan 2008
Location: Utah
Posts: 754
Points: 48,559
Thanks: 51
Thanked 112 Times in 101 Posts
Quote:
Originally Posted by elctricbluecummins View Post
sometimes when im not getting on it too hard my truck lags a little bit and it will blow a little puff of blue smoke does anyone elses do this
If you are in the higher setting on your Edge then what's happening is the truck is fueling hard when you step on it and causing the turbo to lag a bit and the puff of blue smoke. Mine 5.9L does this bad on Crazy Larry. I have to roll into the trottle from low RPM's.

06 2500 Quadcab SLT
Billet Tranny
BD with Crazy Larry
Quadzilla Boost Fooler
S&B Intake
MBRP all the way back and "High Flow Cat"
6" Lift, 35" Toyo MT's, 20" Incubus wheels
Some Audio Goodies Too



MAY 2008 TDG Truck of the Month



Kummins is offline  
post #5 of 11 (permalink) Old 03-27-2009, 04:22 PM Thread Starter
Threadstarter
 
Join Date: Feb 2009
Posts: 14
Points: 1,711
Thanks: 0
Thanked 1 Time in 1 Post
im getting the egr delete done on monday so we'll see if that's it....I only run my edge on 3 at the highest because it slips my clutch so bad so I don't guess that's it but thanks everyone for your input ill tell yall what happens when I do the egr delete
elctricbluecummins is offline  
post #6 of 11 (permalink) Old 03-28-2009, 12:26 AM
Member
 
Join Date: Jan 2009
Location: huntsville
Posts: 131
Points: 20,380
Thanks: 15
Thanked 8 Times in 8 Posts
I have the same problem with smoke and mine is going into a regen by what the edge tells me, does that mean that my deletes are not working? my egr is gone but i didn't remove the butterfly's could that be causing it?

2007.5 Ram 3500 4x2 QC
6 speed manual
Edge Attitude with/ Juice
MP-8
S&B Cold Air Intake
4" TBE Flo-Pro
DPF delete
Egr and Egr Cooler delete
Black Tec Mafia #19
BigRed6.7CTD is offline  
post #7 of 11 (permalink) Old 03-28-2009, 01:14 AM
Senior Member
 
fuzzy's Avatar
 
Join Date: Dec 2008
Posts: 268
Points: 23,472
Thanks: 4
Thanked 55 Times in 55 Posts
What kind of dpf delete do you have? Check your sims, maybe pull them out and clean them, (blow them out), put some electric grease on them and reinstall. I don't know what your running, but newer flashes have a regen counter or timer in them. If your truck don't see a regen in so many miles, or over some time period, it will go into regen. The newer delete kits have a regen timer reset in them to put that back to 0 everytime you start the truck. So if you have a newer flash, without the right electronics, it could be the problem. If none of those apply, then check your sims.

12 mega dually. garbage gone. mini with od.
fuzzy is offline  
The Following User Says Thank You to fuzzy For this addition to TDG:
BigRed6.7CTD (03-28-2009)
post #8 of 11 (permalink) Old 03-28-2009, 11:19 AM
Member
 
Join Date: Jan 2009
Location: huntsville
Posts: 131
Points: 20,380
Thanks: 15
Thanked 8 Times in 8 Posts
ok so it may end up being a problem that I have to deal with right?, I will chech the sensors this weekend and let ya'll know.

2007.5 Ram 3500 4x2 QC
6 speed manual
Edge Attitude with/ Juice
MP-8
S&B Cold Air Intake
4" TBE Flo-Pro
DPF delete
Egr and Egr Cooler delete
Black Tec Mafia #19
BigRed6.7CTD is offline  
post #9 of 11 (permalink) Old 03-29-2009, 04:13 AM Thread Starter
Threadstarter
 
Join Date: Feb 2009
Posts: 14
Points: 1,711
Thanks: 0
Thanked 1 Time in 1 Post
I set my edge to alert me when it went into regen and it did last night it blew a ton of white smoke but then I drove it today and it was fine....so is my delete kit messed up or what
elctricbluecummins is offline  
post #10 of 11 (permalink) Old 03-29-2009, 08:51 PM
Senior Member
 
fuzzy's Avatar
 
Join Date: Dec 2008
Posts: 268
Points: 23,472
Thanks: 4
Thanked 55 Times in 55 Posts
Quote:
Originally Posted by elctricbluecummins View Post
I set my edge to alert me when it went into regen and it did last night it blew a ton of white smoke but then I drove it today and it was fine....so is my delete kit messed up or what
I'd say the same to you as I did to bigred6.7ctd. Check your sims, but it could be your flash and the kit your running. Does it seem like it's doing it every so many miles, or over a certain amount of drive time? Or is it out of the blue whenever it wants?

12 mega dually. garbage gone. mini with od.
fuzzy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
White smoke blue smoke low on coolant whats wrong littlebigrig6.0 2003-2007 6.0L Power Stroke 24 12-05-2009 11:11 PM
blue smoke? imported_ditchdigger 2003-2007 6.0L Power Stroke 4 04-07-2008 01:43 AM
Got Blue Smoke *2GLAMIS* 2003-2007 6.0L Power Stroke 2 04-01-2008 01:20 AM
Blue smoke 94straightpiped 5.9L Cummins 12 Valve (1994-1998.5) 16 01-25-2008 02:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome