P2000 Code, TSB's done, now strange sound - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by DarkDesertDiesel, this thread has received 6 replies and been viewed 1712 times.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-09-2009, 09:29 PM Thread Starter
 
Join Date: Aug 2009
Posts: 14
Points: 1,983
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
P2000 Code, TSB's done, now strange sound

Hey all. Had the P2000 code CEL a week ago, took it to the dealer and they did 3 seperate TSBs which included installing a cleaning port in my Turbo and cleaning it and also wrapping part of the exhaust with this funky looking wrap stuff.

I now have a strange kind of whooshing sound coming from under the hood, Seems to coincide perfectly with the turbo whine when I give it throttle and let off and it sounds like air escaping from or being pulled in from somewhere it shouldnt be. Anyone have this issue or know what it might be? I'm thinking maybe they didnt cover that hole they drilled in my turbo or something. It's noticeable in the cab with the windows up and A/C on so it's nothing small. I dont feel any loss of power. Any help or ideas of what it might be are appreciated.

Thanks,

DDD
DarkDesertDiesel is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-11-2009, 05:03 AM Thread Starter
Threadstarter
 
Join Date: Aug 2009
Posts: 14
Points: 1,983
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
Update. Went on about a 100 mile round trip and im noticing a little loss of power. It almost seems and sounds as if air is escaping from the turbo and robbing a bit of power. I'll be going to the dealer in the next couple days to drop it off and I'll keep you all posted
DarkDesertDiesel is offline  
post #3 of 7 (permalink) Old 08-11-2009, 10:26 AM
Member
 
CANYONBIKER's Avatar
 
Join Date: Aug 2006
Posts: 46
Points: 1,487
Thanks: 43
Thanked 1 Time in 1 Post
Keep us updated I for one would like to know what the problem is.
CANYONBIKER is offline  
post #4 of 7 (permalink) Old 08-11-2009, 01:40 PM
Built Not Bought
 
SOOTBANDIT's Avatar
 
Join Date: Dec 2008
Location: Columbia Missouri
Posts: 3,072
Points: 78,365
Thanks: 496
Thanked 264 Times in 225 Posts
Images: 9
Quote:
Originally Posted by DarkDesertDiesel View Post
Hey all. Had the P2000 code CEL a week ago, took it to the dealer and they did 3 seperate TSBs which included installing a cleaning port in my Turbo and cleaning it and also wrapping part of the exhaust with this funky looking wrap stuff.

I now have a strange kind of whooshing sound coming from under the hood, Seems to coincide perfectly with the turbo whine when I give it throttle and let off and it sounds like air escaping from or being pulled in from somewhere it shouldnt be. Anyone have this issue or know what it might be? I'm thinking maybe they didnt cover that hole they drilled in my turbo or something. It's noticeable in the cab with the windows up and A/C on so it's nothing small. I dont feel any loss of power. Any help or ideas of what it might be are appreciated.

Thanks,

DDD
Its not a turbo bark or comression surge is it?? Dodges and Ferds have it bad especially they 5.9 and 6.0

2011.5 6.7 HO Crew Cab Laramie Dually 4x4 H&S A-1 H11 Studs GDP Pro Gate AFE drop in Isspro EV2 Boost/EBP RDS 90 Aux Tank/Toolbox Combo Reese 20k 5th wheel

2007 2500 6.7 4x4 Handshaker SOLD



Military Quote Of The Year

________________________________

"When I joined the military it was illegal to be homosexual, then it became optional. I'm getting out before it becomes mandatory."

MSGT Harry T. Serres, USAF Ret.
SOOTBANDIT is offline  
post #5 of 7 (permalink) Old 08-12-2009, 01:22 AM
Senior Member
 
sstockton's Avatar
 
Join Date: Jan 2009
Posts: 3,514
Points: 69,915
Thanks: 3
Thanked 64 Times in 60 Posts
Is it possible that its a boost leak? Obviously, the must have pulled the turbo to drill it for a new port, so Maybe they didn't get a boot hooked back up quite right and its a pretty substantial boost leak. I've had that happen a couple times on my 24v. It'd be worth looking into.
Sean

2000 2500 reg. cab 4x4 auto 577hp
09 6.7L QC LB stick, 4x4.

TOTAL PERFORMANCE DIESEL 707-545-FUEL (3835)
www.totalperformancediesel.com
sstockton is offline  
post #6 of 7 (permalink) Old 08-12-2009, 11:21 AM
I now drive a Duramax...
 
Join Date: Dec 2008
Location: Tucson AZ
Posts: 318
Points: 32,557
Thanks: 6
Thanked 29 Times in 25 Posts
I agree with Sean, sounds like a boost leak...

2007 Chevrolet 3500 SRW CrewCab Longbed, PPE Modded AirBox, Edge Evo Race level 4.

***SOLD***2001 Dodge 2500 CTD Quadcab Longbed SRW, Straightpiped, BHAF, no silencer ring.


They call it PMS because Mad Cow Disease was taken...
CumminsTorq is offline  
post #7 of 7 (permalink) Old 08-16-2009, 07:17 PM Thread Starter
Threadstarter
 
Join Date: Aug 2009
Posts: 14
Points: 1,983
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
Sorry for the late update. Took it to the Dealer and took the Diesel Tech for a test ride and he agreed that it was an air leak from someplace. Next day the Service Writer called and said that it was ready and that when it was in for the de-soot issues that the Tech hadn't tightened a clamp on the intake tube to the Turbo so it was throwing half of the air out the sides instead of feeding all the air to the turbo. Got it back now and all is well.
DarkDesertDiesel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Sound from my Under Dash JohnJohn 2003-2007 6.0L Power Stroke 4 02-21-2008 08:38 PM
strange sound bronco81 2003-2007 6.0L Power Stroke 6 01-18-2008 08:12 PM
strange air sound 1999 M11 otis calhune Medium and Heavy Duty 3 07-24-2007 11:55 PM
6.0 with a strange sound. efoster_01 2003-2007 6.0L Power Stroke 5 11-03-2006 02:05 AM
strange sound oliver-2150 2003-2007 6.0L Power Stroke 6 09-24-2006 01:54 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome