Have a bad problem - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by TeamTonkadodge, this thread has received 21 replies and been viewed 3005 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old 09-08-2009, 01:29 AM Thread Starter
TeamTonka
 
Join Date: Mar 2006
Posts: 38
Points: 17,636
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to TeamTonkadodge
Have a bad problem

I own an 08 dodge 2500 6.7l and jus recently put on an mbrp 5in. turbo back exhaust, smarty with m/e download and an afe stage II intake also an egr delete. My problem is that after putting all this on and running about 100 miles or so i would come to an idle and my turbo would gradually begin to whistle louder and louder all while still at a dead stop idle it would then get to a certain point and change the tone of the whistle and then my motor would begin idleing rough and rev up to almost 1000rpms... I began trying all sorts of things and still had the weird whistle until finally i pulled the fuse controlling the vgt and it stopped but my turbo took forever to spool up which was expected and my motor would still idel funny as it did before. It also threw a code for mass airflow sensor weak circuit so i narrowed it down to something with the vgt part of the turbo but have no idea how to permenantly fix it... as of right now the only thing i can do is change power levels on my smarty and stop the whistle temporarily. Ive asked everybody i know and have yet to come up with an answer so i was hoping yall couldgive me any kind of HELP!!!!

thanks

2002 3/4 ton CTD 4x4. 5 spd. jus straight piped for now. Want a edge programer.
"No Stoppin Team Tonka"
TeamTonkadodge is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 09-08-2009, 01:54 AM
Senior Member
 
fuzzy's Avatar
 
Join Date: Dec 2008
Posts: 268
Points: 23,481
Thanks: 4
Thanked 55 Times in 55 Posts
Check your sensor in your new afe stage 2 intake tube. Make sure it's plugged in and installed correctly. I'd say that has to be it. Might need a new one, but since you just messed with it, check it all out first.

12 mega dually. garbage gone. mini with od.
fuzzy is offline  
post #3 of 22 (permalink) Old 09-08-2009, 02:04 AM Thread Starter
TeamTonka
Threadstarter
 
Join Date: Mar 2006
Posts: 38
Points: 17,636
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to TeamTonkadodge
Well i would agree with you on that but i had to replace the intake and exhaust with the stock parts to get some warranty work done and actually left it on for a while to see if it would do the same thing and it didnt which is what really confused me... but thanks for the advice

2002 3/4 ton CTD 4x4. 5 spd. jus straight piped for now. Want a edge programer.
"No Stoppin Team Tonka"
TeamTonkadodge is offline  
post #4 of 22 (permalink) Old 09-08-2009, 04:46 AM
 
Join Date: Feb 2009
Posts: 27
Points: 2,743
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
after having my truck for 3 days and previously driving a older powerstroke, I just CAN'T UNDERSTAND why everyone wants to mod these trucks out. In stock form, the Cummins would run circles around my modified Ford Powerstroke.
JakeB is offline  
post #5 of 22 (permalink) Old 09-08-2009, 06:51 PM
6.7L Man Van
 
-lenny-'s Avatar
 
Join Date: Sep 2009
Location: Brooks Alberta
Posts: 120
Points: 45,867
Thanks: 8
Thanked 19 Times in 17 Posts
Its simple really. Too much is never enough. I don't know if it is a disease or an addiction, or what, but whenever I get something that has an engine in it of some sort, I start looking for ways to change it. I guess maybe I like tinkering, or seeing what the hidden potential is. I can't do stock. Obviously, you've got to pay to play, and as long as you realize that, it can be a very enjoyable process, even when its not going quite right.

08 MC 3500 68RFE
Mostly Stock
-lenny- is offline  
post #6 of 22 (permalink) Old 09-09-2009, 02:11 PM Thread Starter
TeamTonka
Threadstarter
 
Join Date: Mar 2006
Posts: 38
Points: 17,636
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to TeamTonkadodge
ttt

2002 3/4 ton CTD 4x4. 5 spd. jus straight piped for now. Want a edge programer.
"No Stoppin Team Tonka"
TeamTonkadodge is offline  
post #7 of 22 (permalink) Old 09-09-2009, 05:46 PM
Smarty Guru
 
Join Date: Dec 2008
Location: Seattle WA
Posts: 80
Points: 16,936
Thanks: 0
Thanked 2 Times in 1 Post
are you sure that you are running R14ME software? When you plug the smarty in look quick at the screen to see the version number on the right side of the display. Have you changed any of the default settings?
Bob Wagner is offline  
post #8 of 22 (permalink) Old 09-09-2009, 09:32 PM Thread Starter
TeamTonka
Threadstarter
 
Join Date: Mar 2006
Posts: 38
Points: 17,636
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to TeamTonkadodge
Im pretty sure i am running the me software... and i do go into the default settings to turn the dpf/egr off. I thought it might be something the smartys doin but im not sure yet... I dont know why the smarty would make the turbo do that after so many miles.
Has anybody ever heard of a problem like this?

2002 3/4 ton CTD 4x4. 5 spd. jus straight piped for now. Want a edge programer.
"No Stoppin Team Tonka"
TeamTonkadodge is offline  
post #9 of 22 (permalink) Old 09-09-2009, 11:10 PM
Senior Member
 
JacktheBear3's Avatar
 
Join Date: Jan 2007
Location: Northeast Ohio
Posts: 174
Points: 28,644
Thanks: 5
Thanked 27 Times in 17 Posts
Quote:
Originally Posted by Bob Wagner View Post
are you sure that you are running R14ME software? When you plug the smarty in look quick at the screen to see the version number on the right side of the display. Have you changed any of the default settings?
Quote:
Originally Posted by TeamTonkadodge View Post
Im pretty sure i am running the me software... and i do go into the default settings to turn the dpf/egr off. I thought it might be something the smartys doin but im not sure yet... I dont know why the smarty would make the turbo do that after so many miles.
Has anybody ever heard of a problem like this?
I think the reason Bob is asking is because Regen will raise the idle.... Stanger things happen.

If you have too much build up in the VGT, would it spool at idle more? causing an issue with MAP, MAf and the fueling at idle ?

JacktheBear3 is offline  
post #10 of 22 (permalink) Old 09-09-2009, 11:36 PM Thread Starter
TeamTonka
Threadstarter
 
Join Date: Mar 2006
Posts: 38
Points: 17,636
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to TeamTonkadodge
hey bob I looked at my smarty and I have R10ME software. is the R14ME software an update?

2002 3/4 ton CTD 4x4. 5 spd. jus straight piped for now. Want a edge programer.
"No Stoppin Team Tonka"
TeamTonkadodge is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ole JIm Problem Ole JIM 5.9L Cummins (Pre 1994) 6 04-29-2009 03:48 AM
ABS problem plowman61 5.9L Cummins 12 Valve (1994-1998.5) 12 03-27-2008 08:29 AM
big problem- need help!! vrsc 2003-2007 6.0L Power Stroke 8 09-14-2007 01:10 AM
1 new problem, 1 old problem, 1 problem fixed LOL Liftedpsd 2003-2007 6.0L Power Stroke 16 04-23-2007 12:13 PM
Fuel Pressure Problem? Lift problem? Going on long trip this weekend! JaredMTFD 5.9L Cummins (1998.5-2002) 4 01-24-2007 03:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome