intermittent check engine light - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by rtrolli69, this thread has received 7 replies and been viewed 1466 times.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 04-03-2010, 02:01 AM Thread Starter
Junior Member
 
Join Date: Feb 2010
Posts: 5
Points: 374
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Angry intermittent check engine light

Well hey need some info.Dealer didnt fix it yet. I keep getting a intermittent check engine light and truck throws the code p2121.they reset it. reflashed computer,then next time said they changed accelerator pedal position sensor. Week later same thing. The truck runs fine but if it comes on sometimes it wont accelerate or I have to let off and then reapply the gas pedal. It will be on when I pull it in the garage,then next morning when I start it its gone?Sometimes it will go a month or sometimes two no trouble? The last few weeks more frequent on & off. Still under warranty but its my only vehicle and hate it at the dealer.Any info?
rtrolli69 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-03-2010, 11:42 PM
Junior Member
 
buffalobob's Avatar
 
Join Date: Dec 2008
Location: n. missouri
Posts: 212
Points: 25,949
Thanks: 23
Thanked 12 Times in 11 Posts
mine kept doing that and the dealer replaced egr valve, then the o2 sensor. finally i replaced the batteries and it all went away. one was weak and causing voltage fluctuation on cold mornings. service managwer didnt believe me when i told him it fixed the problem. hasnt come back on in 6 months.

2011 silverado lt, crewcab, short bed, 4X4, d-max/ allison
buffalobob is offline  
post #3 of 8 (permalink) Old 04-04-2010, 03:19 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Feb 2010
Posts: 5
Points: 374
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Thanks for the info,I think I will have them tested.Took a road trip yesterday about 200miles and the light went off,has not come back yet? maybe some hwy driving put a good charge on them?interesting!
rtrolli69 is offline  
post #4 of 8 (permalink) Old 04-04-2010, 08:31 PM
Junior Member
 
buffalobob's Avatar
 
Join Date: Dec 2008
Location: n. missouri
Posts: 212
Points: 25,949
Thanks: 23
Thanked 12 Times in 11 Posts
i had read on one of the forums about voltage effecting the computer. i asked the service manager straight up itf that could possibly be my problem. he was very definite that it was not the problem. his words." no. if there is enough voltage to light the lights, the computer will work" guess he dont know much about computers. didnt mind having to buy my batteries, but 5 trips to the dealership 70 miles each was a little irritating.

2011 silverado lt, crewcab, short bed, 4X4, d-max/ allison
buffalobob is offline  
post #5 of 8 (permalink) Old 04-07-2010, 03:23 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Feb 2010
Posts: 5
Points: 374
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
well tested batteries today they were both ok.So what to do now?
rtrolli69 is offline  
post #6 of 8 (permalink) Old 05-24-2010, 05:08 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Feb 2010
Posts: 5
Points: 374
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Well here is an update,truck has still been doing this off&on for months.pull it in the garage w/cel on, next morning fire it up, back out its gone??!! Dealer had truck for several days,they did the J35 recall,also changed the throttle pedal position sensor again...still same result. usually happens in the morning on the way to work,short drive.1 morning im driving to the dealer & rpm is @ 1500.. then it would just drop to an idle you could push the pedal to the floor & hold it truck wouldnt accel at all??! I get there leave truck running ask them to drive it,now they say it acts up and the trble is n the harness?? This doesnt sound good! I mean if its not the sensor its either the wiring or Computer right? Im just worried its my first new truck.... any help would be greatly appreciated!
rtrolli69 is offline  
post #7 of 8 (permalink) Old 05-26-2010, 01:55 PM
Member
 
Join Date: Jan 2009
Location: huntsville
Posts: 131
Points: 20,384
Thanks: 15
Thanked 8 Times in 8 Posts
first off the light going away after you restart is normal on newer vehicles, there are some codes that will stay on but not usually.

2007.5 Ram 3500 4x2 QC
6 speed manual
Edge Attitude with/ Juice
MP-8
S&B Cold Air Intake
4" TBE Flo-Pro
DPF delete
Egr and Egr Cooler delete
Black Tec Mafia #19
BigRed6.7CTD is offline  
post #8 of 8 (permalink) Old 05-27-2010, 04:07 AM
Junior Member
 
mdcody101's Avatar
 
Join Date: Jan 2010
Location: Minnesota
Posts: 38
Points: 20,124
Thanks: 2
Thanked 1 Time in 1 Post
Sounds like you have a throttle valve sticking from carbon build up
mdcody101 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light jordan_labelle 2003-2007 6.0L Power Stroke 1 01-22-2010 12:57 AM
Check engine Light because of air box Baldguy5.0 2008-2010 6.4L Engine Tuner Forum 11 12-06-2009 12:22 AM
#08-06-04-054: Snow Intrusion into Air Cleaner, Check Engine Light On, Engine Reduced ripmf666 GM TSB Info 0 08-10-2009 04:46 AM
Check engine light blackcloudCTD95 5.9L Cummins 12 Valve (1994-1998.5) 2 07-10-2007 01:49 AM
check engine light imported_hotrod 1994-2003 7.3L Power Stroke 10 03-13-2006 09:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome