IH 4900 DT530 with fuel primee problem - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by ekimsnevets, this thread has received 0 replies and been viewed 185 times.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-13-2017, 12:01 AM Thread Starter
Junior Member
 
Join Date: Aug 2017
Posts: 1
Points: 233
Thanks: 0
Thanked 0 Times in 0 Posts
IH 4900 DT530 with fuel primee problem

Hello, I bought a 2002 with a DT530. Its a dump truck that the previous owner said he did an inframe overhaul. He drove it about 500 miles after the overhaul when he noticed coolant leak. When he asked the mechanic he found out the head was dropped on the head gasket. He replaced the head gasket and 2 injectors, (this made 4 injectors replaced since the start of overhaul) and he said it started right up. He made one short run and parked it. Next day it would not start and has never been started since. Before buying it I shot some starting fluid in the breather and it would run. The Primer Pump was missing and when I asked he said another potential buyer took it with him to source a new one. He only wanted $7000 which was what he said he spent on the inframe. I bought it and had it towed to a shop. First thing I did was buy a primer pump and installed it. I removed the strainer and cleaned it. It was not plugged. I also took the cap off above the strainer and visually inspected the ball. It looked fine. I back off the primary fuel filter on the driver side. It was not full. While the filter was off I tried the new primer pump but could not get any fuel to discharge after several hundred strokes. I removed the supply line upstream of the primer pump and strainer and used compressed air to push fuel through the line and made up the supply line while fuel was expelling from it. Then immediately tried the primer pump and still couldn't get it to discharge any fuel. Unless I am missing something I think I am not going to be able to start the truck until i can install a full filter and then pump it up tight. Does anyone have any ideas of why I can't get fuel to discharge from the primer pump while the filter is removed?
ekimsnevets is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
95 international dt530 chris366 Medium and Heavy Duty 4 01-30-2010 02:20 AM
DT530 with NO oil pressure! pjred63 Medium and Heavy Duty 7 01-30-2010 12:12 AM
dt466 to dt530 murphandsons Medium and Heavy Duty 12 12-06-2007 06:03 PM
Fuel Pressure Problem? Lift problem? Going on long trip this weekend! JaredMTFD 5.9L Cummins (1998.5-2002) 4 01-24-2007 04:35 PM
More ponies out of DT530...... diesel dan Medium and Heavy Duty 5 11-03-2006 02:30 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome