New - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Detroit7, this thread has received 0 replies and been viewed 185 times.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-01-2018, 08:43 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 1
Points: 222
Thanks: 0
Thanked 0 Times in 0 Posts
I have a international 4300 dt466e it first had an issue when itll surge at idle when engine at full operating temp like it would drop like its about to cut off then catch itself i hooked up scanner and got cam code 143 incorrect signature we replaced cam sensor ipr valve and icp sensor due to oil at connector it idles fine but once reach highway speeds itll blow wh.ite smoke and stall i hooked up scanner gave me cam sensor data erratic and incorrect signature i also got icp pressure low code but i ran it down the road and it keep giving me cam sensor codes checkex wire and connector all looks fine any suggestions???

Last edited by Detroit7; 07-01-2018 at 08:52 PM.
Detroit7 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New, New and New! 2003 E350 7.3L $uperlongpowerstroke03 Introductions 1 04-06-2018 02:24 PM
NEW LEAK NEW LEAK NEW LEAK!!!! BOBCAT_JON 1994-2003 7.3L Power Stroke 6 03-10-2010 04:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome