2012 Maxforce 7 - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Farmboy60, this thread has received 5 replies and been viewed 129 times.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-18-2019, 12:56 AM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 5
Points: 272
Thanks: 0
Thanked 0 Times in 0 Posts
2012 Maxforce 7

Hi everyone. I'm new to the forum and have a few questions about my Terrastar. Great Truck but I have noticed the temp gauge keeps going from 180 to 220. Had a forced regeneration done today but did not help. If I'm going uphill with a load warning light comes on everytime. It is the triangle light. If I'm pulling a trailer i can hear cooling fan come on every 5 minutes or so. Any help would be greatly appreciated. Thanks in Advance. Forgot to mention once I slow down to 60 or so truck will stay at 190 degrees. Faster i go the hotter it gets.
Farmboy60 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-21-2019, 02:34 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Apr 2019
Posts: 5
Points: 272
Thanks: 0
Thanked 0 Times in 0 Posts
Need Help

Anybody have any ideas?
Farmboy60 is offline  
post #3 of 6 (permalink) Old 04-22-2019, 09:16 AM
Junior Member
 
Jasong's Avatar
 
Join Date: Feb 2015
Location: Plant City Fl
Posts: 309
Points: 29,951
Thanks: 41
Thanked 26 Times in 25 Posts
Check to see if your cooling stack is clean and the condition of your coolant.
When driving on a flat, what temp are you holding? Should be around 190
Jasong is offline  
post #4 of 6 (permalink) Old 04-25-2019, 01:14 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Apr 2019
Posts: 5
Points: 272
Thanks: 0
Thanked 0 Times in 0 Posts
Holding at 190 on flat road. Go uphill and beats up fast to around 220. Go downhill and cools off to 190 in a minute. Can't figure this one out.
Farmboy60 is offline  
post #5 of 6 (permalink) Old 04-25-2019, 01:15 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Apr 2019
Posts: 5
Points: 272
Thanks: 0
Thanked 0 Times in 0 Posts
Radiator is clean.
Farmboy60 is offline  
post #6 of 6 (permalink) Old 05-03-2019, 10:35 AM
Junior Member
 
Jasong's Avatar
 
Join Date: Feb 2015
Location: Plant City Fl
Posts: 309
Points: 29,951
Thanks: 41
Thanked 26 Times in 25 Posts
I just noticed your above mention of a forced regen. Your DPF could be getting clogged. What percent is it reading?
Jasong is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Harley F350 Piker 2011+ 6.7L Power Stroke Diesel 10 03-05-2012 07:51 PM
New 2011-2012 F250-F550 Fabfours bumpers dfuser Supporting Vendors Forum 0 06-04-2010 05:25 PM
2012 Prototype? upnsmoke 2011+ 6.7L Power Stroke Diesel 13 12-19-2009 09:27 PM
2010 Maxforce fjh Medium and Heavy Duty 4 06-19-2009 03:18 PM
The 2012 Pelosi GTxi SS/RT Sport Edition bmoeller The Parking Lot 2 01-25-2009 05:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome