Edge CTS trouble - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Longbob, this thread has received 11 replies and been viewed 3249 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 08-10-2010, 01:54 PM Thread Starter
Junior Member
 
Join Date: Nov 2006
Location: Denton, TX
Posts: 17
Points: 806
Thanks: 0
Thanked 0 Times in 0 Posts
Edge CTS trouble

I searched the forums and didn't find the answers to these problems that I am having. Sorry if I come off as a newbie. I am new to the Fords, but not new to bombing diesels and monitoring them.

Here are the things I am dealing with and wanted to know if there are any good solutions. I have a 2004 6.0 F350 Crew Cab long bed. The Edge CTS mounts with a suction cup on the windshield. The problem is that Texas gets really hot and the Edge will blank out if it gets over 170 degrees or something. I cannot find a built in pillar mount that will help keep the sun off the unit. Does anyone make one for these trucks? I would like to hide the wires, also.

I am disappointed that it doesn't read the Engine Oil Temperature. This truck is completely stock except for a MBRP exhaust and a larger Titan tank. No tuners at all. The Edge CTS is the first thing I have hooked to it and it is just a monitor. I did add the EGT probe pre-turbo.

The tech person at Edge said that he didn't think the 2004 Ford OBD II read the engine oil temp, but I thought it did. I could be wrong. He said that it does read the Transmission Oil Temperature, but there is not a PID for the transmission. Is this a software update that I need to download from Edge?

Any help is greatly appreciated.

2000 2500 QC 4X4 Shrtbd Auto 3.54 gears White Laramie, Autometer Boost, EGT, and Trans gauges, AFE Stage 2, MBRP 4", F-1 1.6 injectors, Quick Diesel 64 Turbo, Smarty, TST Power Max 3, Goerend Full Billet, ATS Billet Flex Plate, Mag HyTech trans cover, PSC Quick Ratio, 2003 trackbar, DSS.
Longbob is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 08-18-2010, 03:20 PM
Junior Member
 
DoneDunIt's Avatar
 
Join Date: Mar 2010
Location: Western NC
Posts: 26
Points: 911
Thanks: 1
Thanked 5 Times in 4 Posts
Garage
Adam at First Coast Diesel is a sponsor on this forum. I don't want to put up a link to another forum but he has the answer to your problems. I would contact him. I have a Edge CTS Evolution and have not had the problems with the EOT.

abrannan19 on this board

http://www.firstcoastdieselperformance.com/
(904) 813-5067

2003 CC SB 4X4 6.0 26,250 miles July 1, 2010
DoneDunIt is offline  
post #3 of 12 (permalink) Old 08-18-2010, 03:38 PM
Supporting Vendor
 
abrannan19's Avatar
 
Join Date: Dec 2008
Location: Jacksonville,FL
Posts: 504
Points: 54,265
Thanks: 142
Thanked 46 Times in 35 Posts
you need to call edge right away, some of the first units are having this problem with the screens not working at high temps, they will replace this unit for you.

There is an update available (or will be) shortly to address the EOT and ECT and TFT on the 03-04 trucks, this problem has been fixed on the beta firmware.
abrannan19 is offline  
post #4 of 12 (permalink) Old 08-19-2010, 01:27 AM
Junior Member
 
Join Date: Dec 2008
Posts: 139
Points: 4,790
Thanks: 0
Thanked 11 Times in 10 Posts
update the cts with the insight software. mine has all temps, including oil temp

2006 F250 CCSB

Thanks to Innovative and FCDP
SamW is offline  
post #5 of 12 (permalink) Old 08-19-2010, 12:03 PM
Supporting Vendor
 
abrannan19's Avatar
 
Join Date: Dec 2008
Location: Jacksonville,FL
Posts: 504
Points: 54,265
Thanks: 142
Thanked 46 Times in 35 Posts
Quote:
Originally Posted by SamW View Post
update the cts with the insight software. mine has all temps, including oil temp
sam your truck is an 05. This is a problem with the 03/04 trucks only.
abrannan19 is offline  
post #6 of 12 (permalink) Old 08-21-2010, 01:20 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Nov 2006
Location: Denton, TX
Posts: 17
Points: 806
Thanks: 0
Thanked 0 Times in 0 Posts
I have called Edge tech support and pressed them a little for the update. They were wonderful and this is a completely different box! There are several useful PIDs now. It is so much better than the original set up, I am surprised that they would release it in what I considered a crippled product.

I need to call them back about the overheating issue. Mine will go out every time if I leave it attached to the window mount in our Texas heat. I called them about it the first time and the tech person told me it was a safety feature that shut it off at 170 degrees. His words. I also asked him about the PIDs at that time. He didn't know what I was talking about.

My first contact with the Edge tech support left a lot to be desired. Thank you for the responses!

2000 2500 QC 4X4 Shrtbd Auto 3.54 gears White Laramie, Autometer Boost, EGT, and Trans gauges, AFE Stage 2, MBRP 4", F-1 1.6 injectors, Quick Diesel 64 Turbo, Smarty, TST Power Max 3, Goerend Full Billet, ATS Billet Flex Plate, Mag HyTech trans cover, PSC Quick Ratio, 2003 trackbar, DSS.

Last edited by Longbob; 08-21-2010 at 01:22 PM.
Longbob is offline  
post #7 of 12 (permalink) Old 08-23-2010, 06:05 PM
Senior Member
 
mattsn's Avatar
 
Join Date: Jan 2007
Location: maryland
Posts: 1,660
Points: 36,317
Thanks: 31
Thanked 50 Times in 47 Posts
I have an '04 and my insight does not show oil temp

'04 6.0, 4.5" lift, straight piped, SCT tunes by Innovative Diesel, studded, coolant filter, EGR delete Tru track in the rear, sounds by JL audio some other odds and ends
mattsn is offline  
post #8 of 12 (permalink) Old 08-24-2010, 01:01 PM
Supporting Vendor
 
abrannan19's Avatar
 
Join Date: Dec 2008
Location: Jacksonville,FL
Posts: 504
Points: 54,265
Thanks: 142
Thanked 46 Times in 35 Posts
Quote:
Originally Posted by mattsn View Post
I have an '04 and my insight does not show oil temp
new insight or old insight? If its the old one, it does, there are not any issues with the older one.
abrannan19 is offline  
post #9 of 12 (permalink) Old 08-24-2010, 08:37 PM
Senior Member
 
mattsn's Avatar
 
Join Date: Jan 2007
Location: maryland
Posts: 1,660
Points: 36,317
Thanks: 31
Thanked 50 Times in 47 Posts
Quote:
Originally Posted by abrannan19 View Post
new insight or old insight? If its the old one, it does, there are not any issues with the older one.
I just bought it about a month ago so I'm going to say it's the new one. Is there a fix for this?

'04 6.0, 4.5" lift, straight piped, SCT tunes by Innovative Diesel, studded, coolant filter, EGR delete Tru track in the rear, sounds by JL audio some other odds and ends
mattsn is offline  
post #10 of 12 (permalink) Old 08-25-2010, 01:24 AM
Supporting Vendor
 
abrannan19's Avatar
 
Join Date: Dec 2008
Location: Jacksonville,FL
Posts: 504
Points: 54,265
Thanks: 142
Thanked 46 Times in 35 Posts
which of these does it look like?





if its either of the last 2, call Edge and they will set you up with a beta version of a new firmware that will address the issues.
abrannan19 is offline  
Reply

Tags
edge cts, oil temp, pillar mount

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
how much trouble imported_newtodiesel 2003-2007 6.0L Power Stroke 5 02-05-2008 11:47 PM
edge comp or edge juice w/attidue fitz1985 5.9L Cummins (1998.5-2002) 13 10-03-2007 01:43 AM
Trouble with edge HOT code bad_cummins 5.9L Cummins (1998.5-2002) 4 05-22-2007 03:56 PM
Edge Drag Comp vs. Edge Juice/Attitude lbdodge24v 5.9L Cummins (1998.5-2002) 12 03-08-2007 08:31 PM
edge juice and edge comp??? masonjo 24 Valve Performance 19 01-23-2007 11:51 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome