Vibration w/ New Edge Install + other questions - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Ride-Orange, this thread has received 15 replies and been viewed 1134 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 09-27-2006, 03:40 PM Thread Starter
 
Join Date: Sep 2006
Posts: 4
Points: 1,095
Thanks: 0
Thanked 0 Times in 0 Posts
Vibration w/ New Edge Install + other questions

Howdy y'all-
Just had the Edge Platinum installed yesterday on my new '06 250 4x4 TorqueShift. When I hit it hard on take-off, it emits an initial vibration (after the turbo lag) that seems to be coming from the tranny, which subsides when it reaches the shift point. This happens in first gear only and is more pronounced with higher power level settings. I don't recall this vibration prior to yesterday's install. Is it the tires trying to break loose, or something bad happening in the tranny?

Also, this "lag" is driving me crazy! Will the Airaid Intake fix it?

Thanks in advance for any advice you can offer.
Ride-Orange is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 09-27-2006, 03:59 PM
 
Join Date: Aug 2005
Posts: 311
Points: 7,371
Thanks: 0
Thanked 0 Times in 0 Posts
Ride-Orange,

Sounds like your converter is slipping to me. Get the AFE Mega Stage II systems as far as air intakes, biggest filter most CFM of flow etc. It'll help on the lag issue. Call us if you have any questions on it.

Mark @ DPPI
Mark_Craig is offline  
post #3 of 16 (permalink) Old 09-27-2006, 04:16 PM
 
Squatch's Avatar
 
Join Date: Dec 2008
Posts: 1,941
Points: 72,842
Thanks: 2
Thanked 21 Times in 12 Posts
I would say it is driveline shudder from the axle rap on take off.

06 F-350 Crewcab 5.9 CR
03 Excursion 6.0
99 F-250 7.3
97 Dodge 3500 5.9
95 F-250 7.3
Squatch is offline  
post #4 of 16 (permalink) Old 09-28-2006, 01:41 AM
 
Join Date: Apr 2006
Posts: 162
Points: 886
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Squatch
I would say it is driveline shudder from the axle rap on take off.
"DITTO":Thumbup: Have the same issue with mine....no Edge but do have a 3" lift. The problem was worse with just the leveling kit. I read a TSB on this somewhere as well. Also read on the Ford Tech Forum that the following diagnostics and fix are available. If the vibes are less pronounced when the truck is loaded the wedge blocks on the rear diff need to be flipped so the skinny end is to the front, reducing the drive line angle. If worse when loaded then you may need a steeper wedge or shims or the wedge block was installed incorrectly. Alternately, the TSB indicates that you can shim the centre carrier bracket using 1/4" shims to a maximum of 3/4"

I have attached the TSB for your information.:Thumbup:
Attached Files
File Type: pdf Drive Away Shudder.pdf (10.7 KB, 197 views)
wsa308 is offline  
post #5 of 16 (permalink) Old 09-28-2006, 01:59 AM
Senior Member
 
Join Date: Jul 2006
Posts: 324
Points: 2,499
Thanks: 0
Thanked 0 Times in 0 Posts
I had that issue after a few of my mods. Fixed it with traction bars from Farmboy Fabrications!! LOVE'EM. Talk about a hard launch too!! WOW!!
6L PWR is offline  
post #6 of 16 (permalink) Old 09-28-2006, 01:59 AM
 
BogginF350's Avatar
 
Join Date: Dec 2008
Posts: 2,997
Points: 29,219
Thanks: 57
Thanked 163 Times in 126 Posts
Im with squatch, MY 06` shudders under a hard load. It did it stock also with a heavy trailer. Its the nature of a u-joint under a heavy load. They speed up and slow down in every rotation.

Josh Davis
32 Lugnuts, 4 gallons of rotella Syn, 5 gallons of coolant, Two Heads, 8 Pistons, 7 U-Joints, 8 Injectors and some exhaust.
You know you are doing something right when the Ford dealers call you for parts.
6.0L Ford
http://www.youtube.com/watch?v=iR2w7Ciaut8
6.4L Ford
http://www.youtube.com/watch?v=9KmgiQg4G8E
WWW.RIVERCITYDIESEL.COM
(309) 699-2488
BogginF350 is offline  
post #7 of 16 (permalink) Old 09-28-2006, 03:52 AM
 
Join Date: Apr 2006
Posts: 162
Points: 886
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 6L PWR
I had that issue after a few of my mods. Fixed it with traction bars from Farmboy Fabrications!! LOVE'EM. Talk about a hard launch too!! WOW!!
Any Pics of the traction bars mounted on the truck?????:squish
wsa308 is offline  
post #8 of 16 (permalink) Old 09-28-2006, 03:59 AM
Senior Member
 
Join Date: Jul 2006
Posts: 324
Points: 2,499
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by wsa308
Any Pics of the traction bars mounted on the truck?????:squish
Not yet, but I'll try to get some this weekend. They're really sweet. I bought them from a guy on here. I'm trying to find the thread where I found him and post a link for everyone. Cost was $475 if I remember right. I had a buddy help me install them. They came with bolts to go to the frame and plates to weld onto the axle, but we just welded both since we had to weld to begin with.
6L PWR is offline  
post #9 of 16 (permalink) Old 09-28-2006, 04:12 AM
K45
 
Join Date: Jan 2006
Posts: 79
Points: 857
Thanks: 0
Thanked 0 Times in 0 Posts
I have the same vibration, shutter on my 06, installed traction bars, did not help one bit, seems to ride rougher as well, good luck.
K45 is offline  
post #10 of 16 (permalink) Old 09-28-2006, 04:22 AM
Senior Member
 
Join Date: Jul 2006
Posts: 324
Points: 2,499
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by wsa308
Any Pics of the traction bars mounted on the truck?????:squish
Alrighty! Found three threads talking about Jesse that made mine. One even includes some pics for ya'll.

Quote:
Originally Posted by WILDCAT
I had a buddy make me a set for my truck. They are 7 feet long with 5/8 heims. He also made a couple of extra sets. If you want set let me know.
http://fordtruckworld.tenmagazines.c...ter/652241.jpg
http://fordtruckworld.tenmagazines.c...ter/652242.jpg
http://fordtruckworld.tenmagazines.c...ter/652243.jpg
http://fordtruckworld.tenmagazines.c...ter/652245.jpg
Quote:
Originally Posted by CBSuperduty
If you ever go to FTW then you may want to check with BigGreen (I think that is his name) he has been making some for some guys and they all seem to be extremely happy.
Quote:
Originally Posted by COTTS4x4
I have a set of bars made by Bigreen. I have no axle wrap what-so-ever. Here is a link to the thread on Ford Truck World. http://fordtruckworld.tenmagazines.c...bars_installed

Jesse is making a set for a friend of mine in the next week or so.
6L PWR is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome