Outlook Egt Problem - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by DOOSKIDU0127, this thread has received 7 replies and been viewed 760 times.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-16-2006, 04:55 AM Thread Starter
 
Join Date: Oct 2006
Posts: 5
Points: 404
Thanks: 0
Thanked 0 Times in 0 Posts
Outlook Egt Problem

I installed a bullydog tripple dog with outlook on my freinds 03 6.0 and the egt's are reading extremely high even when the power level is in stock mode. I called bullydog and they said to send it back to them so they could update it, but that didn't seem to make a difference. Any replies would be greatly appreciated.
Thanks.
DOOSKIDU0127 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-25-2006, 06:39 PM
 
GOFASORGOBROK's Avatar
 
Join Date: Oct 2006
Posts: 328
Points: 24,084
Thanks: 19
Thanked 19 Times in 13 Posts
What temp is it reading? Where is the probe located?

Corey Tyler
Performance Products Manager
D&W Diesel, Inc.

[email protected]

www.dwperformance.com
www.dwdiesel.com
http://dwperformance.wordpress.com/
http://www.facebook.com/home.php?#/p...m/140701044325
Hours: Mon-Fri 8AM-5PM EST
888-296-8074
Power. Torque. Performance. Get Ahead.
Stay Ahead.
GOFASORGOBROK is offline  
post #3 of 8 (permalink) Old 10-25-2006, 07:22 PM
Junior Member
 
Join Date: Oct 2006
Location: Palestine, TX
Posts: 23
Points: 198
Thanks: 0
Thanked 0 Times in 0 Posts
A couple of months ago I talked to a vendor who said they were pulling the BullyDog products off their site b/c too many people were having problems with them. Not sure if they ever got it worked out and what the problems were. Just my .02$.

04' F250 4x4 CC SB Lariat
6.0 PSD
MBRP Turbo-back exhaust, Cat Delete, EGR un-plugged, Zoodad mod, 4" lift, Westin Push Bar (dented from pushing over tree)
cjc4x4 is offline  
post #4 of 8 (permalink) Old 10-25-2006, 11:43 PM
Old Geezer-TDG Mafia #19
 
LargeCar's Avatar
 
Join Date: Dec 2008
Location: Bridge Creek, OK (Tornado Ally)
Posts: 4,396
Points: 62,166
Thanks: 70
Thanked 187 Times in 78 Posts


Images: 9
Several vendors of programmers buy their EGT probes from the same manufacturer, maybe through different wholesaler but the same manufacturer. I got several probes that were just plain bad. I would check with isspro to see what a new probe would cost, or what kind of ohms should be read on a probe. I had the test procedures at one time but can't find them now. Isspro is a supporting vendor I think, or you could pm Michael.[email protected]

LargeCar :mafia

LargeCar

Mafia # 19 The Dually Club # 19

If a country does not remember and honor its fallen heroes of the past, in the future that country will not be honored or remembered.

G.R. Wemmer

A veteran is someone who, at one point in his/her life wrote a blank check made payable to 'The United States of America' for an amount of 'up to and including their life.' That is Honor, and there are way too many people in this country who no longer understand it.
LargeCar is offline  
post #5 of 8 (permalink) Old 10-26-2006, 12:02 AM
fordt
Guest
 
Posts: n/a
Points: 0 [Check]
Let us know how hot it was reading, that may help a bit. I have heard more than several people say they are getting false readings with the Outlook.
post #6 of 8 (permalink) Old 10-26-2006, 01:01 AM
MAFIA #8
 
hhrecovery's Avatar
 
Join Date: Dec 2008
Location: Pulaski, VA
Posts: 5,567
Points: 88,898
Thanks: 104
Thanked 223 Times in 209 Posts
Images: 1
Garage
i have had the outlook for almost 2 years now and my EGTs have always been accurate. I am actually watching my EGTs in both manifolds now and they seem to be right in check w/ each other.

Aaron - 2004 F350 "Offroad Edition"

2003 F250 "Pulling Truck"
hhrecovery is offline  
post #7 of 8 (permalink) Old 10-26-2006, 03:33 PM
Senior Member
 
Lariat Trucker's Avatar
 
Join Date: Nov 2005
Location: Sticksville, Texas
Posts: 342
Points: 2,713
Thanks: 0
Thanked 2 Times in 2 Posts
There are four ways that the EGT temps will be out of whack.

1. The installer trimmed the excess wire out of the system. The sensor wiring is a measured loop so any wire removal will effect the reading.
2. The sensor lead is grounded. This can occur with a bad sensor also.
3. The wiring from the monitor pig tail has been pulled from the back of the monitor. Sometimes they can even get crossed if handled improperly.
4. A bad Outlook Monitor will usually have a blank screen or lines across the screen. It normally won't just effect one setting.

Hope that helps! :

2008 Newmar Essex 525HP CAT w/mystery box
2010 Roush 427R Convertible
2009 F150 SCrew
2007 Dodge 5.9L "SmokdU"

They only look stock........:evil:
Lariat Trucker is offline  
post #8 of 8 (permalink) Old 10-26-2006, 05:52 PM
Junior Member
 
Join Date: Oct 2006
Location: Palestine, TX
Posts: 23
Points: 198
Thanks: 0
Thanked 0 Times in 0 Posts
Just so I make sure I was clear, they were having problems with new units not the old ones. It might have been just a simple problem like what LargeCar was saying about bad batch of probes. I would check with several different vendors (not mfg) to see if anyone else is having problems like urs.

04' F250 4x4 CC SB Lariat
6.0 PSD
MBRP Turbo-back exhaust, Cat Delete, EGR un-plugged, Zoodad mod, 4" lift, Westin Push Bar (dented from pushing over tree)
cjc4x4 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome