Strange Issue - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by TurboTPI, this thread has received 1 replies and been viewed 1172 times.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-18-2010, 02:19 PM Thread Starter
Senior Member
 
TurboTPI's Avatar
 
Join Date: Dec 2008
Location: Bensenville, IL
Posts: 213
Points: 18,706
Thanks: 0
Thanked 2 Times in 2 Posts
Garage
Strange Issue

Im working on a late 99 7.3l at work. It came in as a no start, or start then die in a few min and wont start back up. It has two ICP codes. 1211 and 1212. the owner tried a new ICP sensor, same problem. The oil is clean and full. It got towed in and it started right up. Ran perfect, very responsive and could spin the tires brake boosting it. I let it run for about 25 min. I shut it off and tried restarting agian. started up, but had a extended crank and ran very poorly. No power, very sluggish and would think about spinning the tires brake boosting it. I shut it off again, no start. I took the IPR valve out and cleaned it. Started up and ran good again. Shut it off, no start again? WTF? I think there is something wrong with the IPR valve.

92 Firebird Formula 350-Custom turbo setup, 570rwhp, [email protected](daily driver when its nice out)
97 F-250, 4wd, CC, SB, aFe 4in Turbo Back, diy Tymar intake, Edge Evo, CCV Mod, FPR Mod, 1.0 housing, 7.3 SD Cooler
93 Jeep Wrangler 4.0-Up 7in on 36in SS TSL's
09 Polaris Dragon 800SP
TurboTPI is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-18-2010, 10:32 PM
Senior Member
 
moose99psd's Avatar
 
Join Date: Dec 2008
Location: bend oregon
Posts: 2,334
Points: 43,455
Thanks: 16
Thanked 24 Times in 14 Posts
Send a message via AIM to moose99psd
i would prolly say itd be safe to change the ipr valve.. and if that doesnt fix it pull the covers and check for oil leaking past the orings.. when it wont fire hook a scan tool up and check icp during cranking.. wont fire unless it sees atleast 400psi
moose99psd is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange 2tonePSD 1994-2003 7.3L Power Stroke 9 04-03-2008 05:53 PM
Very Strange Light Issue bigdraft 1994-2003 7.3L Power Stroke 0 01-01-2007 05:49 PM
Strange F/P haz-mat19 5.9L Cummins (1998.5-2002) 7 12-11-2006 12:26 AM
It's Strange Isn't It? BUCKSHOT The Parking Lot 4 04-04-2006 02:08 PM
tune issue or tranny issue? licketysplit 2003-2007 6.0L Power Stroke 10 02-14-2006 11:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome