No acceleration - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by rsjohnsn, this thread has received 2 replies and been viewed 1627 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-24-2010, 06:25 PM Thread Starter
Senior Member
 
rsjohnsn's Avatar
 
Join Date: Dec 2008
Posts: 356
Points: 10,107
Thanks: 10
Thanked 6 Times in 6 Posts
No acceleration

My father has an 02 F350 6 speed that has been running great until this morning. He left the house and then all of a sudden there was no acceleration. The fastest he could get it up to was 30mph. During all this time, there was no smoke. He only has 60+k miles and has had no issues until now. He did say that he moved the wiring harness under the turbo and the rpm went up but when he got back into the cab it went back down. He has removed and reinstalled all the connections he could get to but no good. The check engine light is on and he plans to get the code this afternoon but until then, if there are any ideas, I would appreciate hearing them.

Thanks
Scott

2004 F350 CC LB Dually FX4
SCT x3, MBRP 4in Turbo back with kitty/muffler delete
AFE air filter, Leveling Kit, Firestone Air Bags, B&W Hitch
Zoodad Mod, High Idle Mod, ARP Studs, EGR Delete, Modified Trans
rsjohnsn is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-25-2010, 01:57 AM Thread Starter
Senior Member
Threadstarter
 
rsjohnsn's Avatar
 
Join Date: Dec 2008
Posts: 356
Points: 10,107
Thanks: 10
Thanked 6 Times in 6 Posts
For those that run into this issue, check the wiring harness connection for the injectors at the valve covers. We had to pull the passenger valve cover to reconnect the harness. While we had it apart we used some wire ties to prevent it from happening again. Runs the way it is suppose to!!

Scott

2004 F350 CC LB Dually FX4
SCT x3, MBRP 4in Turbo back with kitty/muffler delete
AFE air filter, Leveling Kit, Firestone Air Bags, B&W Hitch
Zoodad Mod, High Idle Mod, ARP Studs, EGR Delete, Modified Trans
rsjohnsn is offline  
post #3 of 3 (permalink) Old 06-29-2010, 02:29 AM
Senior Member
 
Join Date: Jan 2006
Posts: 120
Points: 3,062
Thanks: 0
Thanked 0 Times in 0 Posts
possible EBPV (exhaust back pressure valve) stuck shut?

Early 99 Crew Cab Long Bed Lariat 4x4 7.3L PSD Primary Horse Hauling Rig
-Stage 1 160cc Single Shot Injectors - DP Tuner F5 - 60 Tow, 80 Econo, High Idle, Stock - NVK5 PCM thanks to DP Tuner
-Home Brew fuel system with Aeroquip socketless fittings, socketless hose, and Aeromotive Regulated Return
-4" Lift 285/75R16 E Nitto Dura Grapplers - 5" MKO Aluminized Exhaust w/6" Stainless Tip - Pair of Optima Red Tops - Napa 6637 Air Intake filter - Triple Gauge A-pillar Pod w/Autometer UltraLite:Trans, EGT, Boost - CCV Mod
ndrorydr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No acceleration above 55 mph. lambstroker6.0 5.9L Cummins (1998.5-2002) 2 12-06-2009 05:15 PM
Acceleration problem. Bone stock 99 6.5L Diesel Engine 11 03-19-2009 02:27 AM
acceleration test skter97 2008-2010 6.4L Engine Tuner Forum 0 03-05-2009 03:25 AM
acceleration Cincinnati Guy 7.3L and 6.9 IDI (Pre 1994) 14 04-17-2008 04:11 AM
A lesson in Acceleration biavaperformance The Parking Lot 8 12-04-2005 04:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome