speedo gone crazy - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by just visiting, this thread has received 7 replies and been viewed 1565 times.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-08-2010, 02:02 AM Thread Starter
Senior Member
 
Join Date: May 2006
Posts: 535
Points: 26,674
Thanks: 0
Thanked 13 Times in 13 Posts
speedo gone crazy

hey guys, well yesterday my speedo started going nuts, it will drop 10-20 MPH and back to norm fast, well after some research i figured the place to start is the VSS on the rear diff. I replaced the sensor and the truck is doing the same thing. Its a 97 PSD auto trans. i have found that most people also had issues with the trans shifting when the sensor was bad, well mine shifts great as if there was no problem at all. Now there is one other issue though about 50% of the time i go to hit the breaks its activating the RABS system (not pulsating but just stiffens the pedal) I stopped by 2 dealerships to ask them and they both said the VSS, after explaining that i replaced it and checked the wiring they stated that i would have to schedule a diagnosis..... no thanks!

So is there any other ideas as to where to look? im gettin agravated

2007 Dodge Ram 2500 lonestar 5.9 CRD, 6-Speed
full MBRP 5" turboback, S&B intake, FASS, ISSPRO gages, BD Diesel steering stabilizer, Tough country leveling kit, Air lift Rear leveling, Southbend clutch, XD Hoss 18" wheels, Nitto Trail grapplers, Satellite radio, LED tailights


1997 ford f-250 POWERSTROKIN auto ex cab LB, homemade intake, superchips programmer, trans, egt, boost gages, tripple a pillar pod (daily driver)

2005 dodge SRT-4 2.4turbo ED hard pipes, aem short ram, MPx 3" turboback, HKS SSQ BOV, AEM wideband, Motegi Mr7 18"rims custom painted (weekend racer) [email protected] 107

2001 suzuki GSX-R600 K&N, Two bros. exhaust, neons, polished frame, (sumertime DD, and track toy)
11.000 @ 127

2006 raptor 700R blue dirt toy

2006 raptor 700R white dirt toy
just visiting is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-08-2010, 03:57 AM
Member
 
bpogue's Avatar
 
Join Date: Feb 2007
Location: Missouri
Posts: 391
Points: 56,930
Thanks: 124
Thanked 28 Times in 27 Posts
Garage
Two more possibilities.

1. The rear ABS sensor reads off of the speed sensor ring in the rear end. The ring isn't really attached very well to the ring gear. Occasionally you will find one that is a little loose and wobbles as it turns. This can cause your problem.

2. The speedometer is controlled by the GEM, under the dash. Windshield leaks seem to happen in this area. When this happens, weird things can happen including erratic speedometer problems. Watch to see if rain has any effect on the speedometer.

1996 Int 4700, 175hp DT466, 5 speed, 2x rear end, service body

2001 F350 SRW flatbed, 4x4, crew cab

1978 International F2275 Dump Truck

1996 NH LX665, steel tracks on foam filled tires

2005 Tackeuchi TB145

2003 Takeuchi TL150

Case 850B Highlight, 4 way bucket
bpogue is offline  
post #3 of 8 (permalink) Old 07-08-2010, 04:01 AM
Senior Member
 
CSIPSD's Avatar
 
Join Date: Sep 2005
Location: Bend OR
Posts: 6,337
Points: 55,114
Thanks: 19
Thanked 78 Times in 70 Posts
Its a 97... could be the vacumn pump... I doubt it, but it could be. At least for the brake issue...

01 F-250 SC PSD,210k,16 Isspro Gauges, AFE-2,CCV Mod,IAH delete,map reg,Modded H2e, 6.0 IC, GTS Hybrid injectors, Studs, 910 Valve springs, Forged rods Water injection,Swamps tuned, MBRP 4" dual's, Aero, 6" tip's, 100 axl tank, 4" Revtek lift, 37-14.50-17 TOYO MT's 469hp and 1068tq...

Best Auto Insurance | Auto Protection Today | FREE Trade-In Quote
CSIPSD is offline  
post #4 of 8 (permalink) Old 07-08-2010, 07:14 PM Thread Starter
Senior Member
Threadstarter
 
Join Date: May 2006
Posts: 535
Points: 26,674
Thanks: 0
Thanked 13 Times in 13 Posts
thanks guys will check on it, Its not the vacuume pump, that has been replaced but it has something to do with the speedo they started the exact same time

2007 Dodge Ram 2500 lonestar 5.9 CRD, 6-Speed
full MBRP 5" turboback, S&B intake, FASS, ISSPRO gages, BD Diesel steering stabilizer, Tough country leveling kit, Air lift Rear leveling, Southbend clutch, XD Hoss 18" wheels, Nitto Trail grapplers, Satellite radio, LED tailights


1997 ford f-250 POWERSTROKIN auto ex cab LB, homemade intake, superchips programmer, trans, egt, boost gages, tripple a pillar pod (daily driver)

2005 dodge SRT-4 2.4turbo ED hard pipes, aem short ram, MPx 3" turboback, HKS SSQ BOV, AEM wideband, Motegi Mr7 18"rims custom painted (weekend racer) [email protected] 107

2001 suzuki GSX-R600 K&N, Two bros. exhaust, neons, polished frame, (sumertime DD, and track toy)
11.000 @ 127

2006 raptor 700R blue dirt toy

2006 raptor 700R white dirt toy
just visiting is offline  
post #5 of 8 (permalink) Old 07-10-2010, 09:59 PM Thread Starter
Senior Member
Threadstarter
 
Join Date: May 2006
Posts: 535
Points: 26,674
Thanks: 0
Thanked 13 Times in 13 Posts
ok so heres what i found...
Pulled the diff cover and found that there were some small bits of metal in the bottom of the pumpkin (dunno whats normal after 224k) i cleaned everything up and found that the "sprocket on the rear end ring gear that looks like a bicycle sproket had 2 teeth that were slightly messed up, so i took a file to it and cleaned them up a bit, cleaned everything and replaced fluid with synthetic and resealed rear cover, the speedo still acts up.
Even though there is a very minor bit of dammage i have a feeling the chipped teeth are a part of the problem, whats involved in replacing the sprocket? and whats it actually called? thanks!

2007 Dodge Ram 2500 lonestar 5.9 CRD, 6-Speed
full MBRP 5" turboback, S&B intake, FASS, ISSPRO gages, BD Diesel steering stabilizer, Tough country leveling kit, Air lift Rear leveling, Southbend clutch, XD Hoss 18" wheels, Nitto Trail grapplers, Satellite radio, LED tailights


1997 ford f-250 POWERSTROKIN auto ex cab LB, homemade intake, superchips programmer, trans, egt, boost gages, tripple a pillar pod (daily driver)

2005 dodge SRT-4 2.4turbo ED hard pipes, aem short ram, MPx 3" turboback, HKS SSQ BOV, AEM wideband, Motegi Mr7 18"rims custom painted (weekend racer) [email protected] 107

2001 suzuki GSX-R600 K&N, Two bros. exhaust, neons, polished frame, (sumertime DD, and track toy)
11.000 @ 127

2006 raptor 700R blue dirt toy

2006 raptor 700R white dirt toy
just visiting is offline  
post #6 of 8 (permalink) Old 07-11-2010, 09:51 PM
Member
 
bpogue's Avatar
 
Join Date: Feb 2007
Location: Missouri
Posts: 391
Points: 56,930
Thanks: 124
Thanked 28 Times in 27 Posts
Garage
I believe you are referring to the speen sensor ring. You have to pull the center section out of the differential to replace it. It isn't all that tough. Just make sure you pay close attention to where each crush ring (I think that is the term) goes to that you get it all back exactly the same way.

1996 Int 4700, 175hp DT466, 5 speed, 2x rear end, service body

2001 F350 SRW flatbed, 4x4, crew cab

1978 International F2275 Dump Truck

1996 NH LX665, steel tracks on foam filled tires

2005 Tackeuchi TB145

2003 Takeuchi TL150

Case 850B Highlight, 4 way bucket
bpogue is offline  
post #7 of 8 (permalink) Old 07-12-2010, 02:53 AM
Senior Member
 
Join Date: Jan 2009
Location: Billerica MA
Posts: 454
Points: 24,848
Thanks: 6
Thanked 14 Times in 14 Posts
Quote:
Originally Posted by bpogue View Post
Two more possibilities.


2. The speedometer is controlled by the GEM, under the dash. Windshield leaks seem to happen in this area. When this happens, weird things can happen including erratic speedometer problems. Watch to see if rain has any effect on the speedometer.
Its not the GEM that is getting water on it, it is the fuse panel assembly. I had mine out to inspect both the GEM and the fuse box. The internals of the fuse box was all covered with green and blue corrosion. The GEM is fine. My speedo was going crazy to because of this, also the blower motor would be affect as well as the wipers and interior light.
cumminsdude2001 is offline  
post #8 of 8 (permalink) Old 07-12-2010, 03:47 AM Thread Starter
Senior Member
Threadstarter
 
Join Date: May 2006
Posts: 535
Points: 26,674
Thanks: 0
Thanked 13 Times in 13 Posts
so you guys think its the ring? anyone know of a how-to on replacing it?

2007 Dodge Ram 2500 lonestar 5.9 CRD, 6-Speed
full MBRP 5" turboback, S&B intake, FASS, ISSPRO gages, BD Diesel steering stabilizer, Tough country leveling kit, Air lift Rear leveling, Southbend clutch, XD Hoss 18" wheels, Nitto Trail grapplers, Satellite radio, LED tailights


1997 ford f-250 POWERSTROKIN auto ex cab LB, homemade intake, superchips programmer, trans, egt, boost gages, tripple a pillar pod (daily driver)

2005 dodge SRT-4 2.4turbo ED hard pipes, aem short ram, MPx 3" turboback, HKS SSQ BOV, AEM wideband, Motegi Mr7 18"rims custom painted (weekend racer) [email protected] 107

2001 suzuki GSX-R600 K&N, Two bros. exhaust, neons, polished frame, (sumertime DD, and track toy)
11.000 @ 127

2006 raptor 700R blue dirt toy

2006 raptor 700R white dirt toy
just visiting is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Speedo 83RTS GM Transmissions 1 07-29-2012 04:09 AM
speedo??? Lil Boosty 2003-2007 6.0L Power Stroke 8 10-27-2009 01:14 PM
Speedo stuck at 90 km/h Borcht Warrior 2003-2007 6.0L Power Stroke 3 12-22-2007 05:16 PM
Funny Speedo LargeCar 2003-2007 6.0L Power Stroke 9 12-08-2007 10:19 PM
Need speedo help on 07 F 250 firedude167 2003-2007 6.0L Power Stroke 8 07-06-2007 10:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome