CPS Failing - Again, something else? - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by dog3434, this thread has received 2 replies and been viewed 657 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-17-2006, 10:02 PM Thread Starter
 
Join Date: Jan 2006
Posts: 60
Points: 3,424
Thanks: 0
Thanked 0 Times in 0 Posts
CPS Failing - Again, something else?

Ok, I got my truck in Oct 2003. My CPS went out in Nov 2004 and was replaced with another stock. Then in Oct 2005 a rebuilt engine was swapped for my old one and a new CPS installed. That one started acting up in early January so I replaced it in late January. Two weeks ago, early March that one failed and I replaced it with a stocker which is now failing 3 weeks into March. That one is being replaced under warranty for a new part but now the stocker I installed 2 weeks ago is starting to fail.

Is there something else that could cause these to fail. When I take them off there is a little bit of oil on the back side. Is this normal? I know its a part prone to failure but good Lord its 4 in 4 months.
dog3434 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-18-2006, 01:52 AM
Senior Member
 
Diesel Dog's Avatar
 
Join Date: Dec 2008
Location: N.E. Mississippi
Posts: 4,024
Points: 45,592
Thanks: 84
Thanked 24 Times in 22 Posts
I think I would try another sorce.... I've had good luck with navistar, Napa, and Ebay
I heard tails of bad in the box ones too.
Yes alittle oil on the end is normal
How many miles on the motor? I read somewhere that too much end play in the cam could make the cps not pick up the rotation of the cam,but had no negitive influence on the cps.

I believe this was "fixed" by shimming the cps closer to the cam......

'00 cc f 350 a few mods, and a bts tranny.

Wet concrete, Hot Asphalt And Life Wait for no one
Diesel Dog is offline  
post #3 of 3 (permalink) Old 03-18-2006, 06:04 PM Thread Starter
Threadstarter
 
Join Date: Jan 2006
Posts: 60
Points: 3,424
Thanks: 0
Thanked 0 Times in 0 Posts
I pulled the CPS today and was surprised to find the Oring in pieces. I'm sure if the Oring wasn't snug it would have some play and definately mess with the CPS. I installed the new CPS but will keep this one as a spare. I'll just get another ORing. Oh well, I hope that's all it was. tks
dog3434 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome